Kia Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
Hey everyone!
So a brief description of the problem...01 rio had the typical drl issue...no dash lights or tail lights, but when a junkyard module was put in it eats batteries...went through 4 batterries in about 2 weeks, were all replaced under wauranttee at ct...but now with the module unplugged it doesnt eat batteries, just no dash lights or tail lights?? It is my good buddies car and i am going to look at it tonight but i am trying to gain as much info as possible...is it possible that all modules are not the same and maybe a junkyard thought all were the same??maybe some internal wiring within module causing the new issue??is the volt reg internal on the alt? or is it an external mounted unit?? he had alt checked out 3 times and is good...any help on this issue would be great...I have a santa fe and love these vehicles but i have seen my fair share of ellectrical issues with these, but this one has me scratchin my head....thanks again
cheers

i just talked to him and the only symptoms it had were eating batteries...lights always worked but ate batteries...with module unplugged it did not eat batteries...so that leads me to believe an ellectrical connection within the drl circuit, but it does not blow fuses...so not typical drl issue but def related to drl circuit
 

·
Registered
2002 Kia Rio, 2011 Kia Sorento 2005 f 250 1996 geo metro 1992 f 150
Joined
·
1,023 Posts
Did you try the stickey post at the top of the page "fix your DRL and save$" By MR. B on the old module and try it. It's is a good write up if you can't solder find a freind to help give it a try. As far as i know the regulator is built into the alt. Good luck with it. I don't know if the modules are different we don't have it in the USA. Reguard's Ronjohn
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
thanks and no i havent tried that fix yet...i am gonna try to see if it is a bad joint, i am fairly familiar with electronics so i will check it out myself...what is in place of this drl module on usa cars??or is the whole wiring harness different?? this drl module ties into allot of the electrical...can it just be bypassed with a nother plug??we live on the border and could go buy whatever from the other side...
thanks
cheers
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,928 Posts
You said" 01 rio had the typical drl issue...no dash lights or tail lights,"

It sounds like the junkyard replacement may be bad...and draining the battery. Was the original DRL module doing the same (draining the battery) or was it only the original DRL module? I'd be tempted to believe the second module was also bad as they are KNOWN to fail.
Dave
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
okay guys thanks for all the help...i took apart 2 of the 3 modules and they seem fine...everything works while they are plugged in all lights fine but it still eats batteries...while any drl module is plugged in the alt and volt reg seem to be working as a simple battery voltage test while running isaround the 14 volt mark....i havent checked amps to the battery, and when key is off voltage is 12.78....this to me seems fairly normal...I have a schematic from the kia info link posted on here and the drl module seems to be wired into allot of things....even wipers are somehow tied into this....i think this is gonna be a challenge to trace....only symptom is batteries appear to be dead after a day or two, and fails load test everytime, once charged back up....so what could cause a battery to fail like this??I was under the impression a battery can fail from either overcharging and boiling out all acid, short in the circuit, or possibly a parasitic draw killing the battery to zero and it not be able to charge....is there any other way i should be focussing on???
thanks
cheers
 
1 - 5 of 5 Posts
Top