Kia Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1 (Edited)
I bought a 03 rio 1.6 DOHC that had bent valves / timing belt break but the pistons and bottom half was undamaged. So i went to a Salvage Yard and found a head, but it was a 1.5 DOHC head off an 01 rio. I was told it would not interchange, but i had no choice being that it was the only one I found WITHOUT BENT VALVES within a 100 mile radius, and out of 8 Salvage Yards, so I went for broke and did it. I had to change a few things but I got it to fit. It runs and idles just fine, but the problem is when you put it into drive, it has no power. You can literally stomp on the gas and the car will barely move. And no check engine lights come on. Then i thought it was the cam timing, do to the difference in the size of the head. So i retarded the cam timing, it has a little more power but still no take off.. I also called the part store to check the computers, they do have the same part number, But is it possible that the 1.5 computer is slightly tuned differently than the 1.6? I NEED HELP, any ideas or suggestions would be greatly appreciated.
 

·
Registered
2012 Kia Soul+, Kia Sportage SX FWD
Joined
·
472 Posts
Did you check the exhaust system (Cats) to make sure they aren't clogged with debris from the first engine scramble? And.... How long was the car sitting? Fuel (gasoline)has a shelf life of about 3 months.
Lastly, double check the timing of the cams.
I was under the impression the 01 engines were not "interference" engines... as in the valves wouldn't hit the pistons... ??? Could that old head have deeper combustion chambers and lower compression? Check the compression.
 
1 - 4 of 4 Posts
Top