Kia Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
60 Posts
Discussion Starter · #1 ·
My car did this 9 months ago they said it was a bad coil and replaced it I had gotten a new battery right before I took it in and the battery was too tall to fit the negative terminal could this be the problem?? The negative terminal is on the side of the battery pleaseee HELPPP!!!
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,961 Posts
I would doubt it...As long as the terminals do not short against the hood or anywhere else on the body of the car and are clean and tight then the battery won't be your problem..You do have two coils ...maybe the second one is on it's way out... Have you checked for any stored codes? This would be a good start at figuring out whats going on...
Dave
 

·
Registered
Joined
·
60 Posts
Discussion Starter · #3 ·
I was thinking maybe the alternator I'm still a little concerned about the battery terminal just b.c its on the side and not the top as usual ;-/
 

·
Registered
Caribou, Otter, Buffalo
Joined
·
2,689 Posts
Where and how you connect to the battery is much like putting on pant, some inset the left foot others the right.

I leaned early in my career to get both feet into the legs and boots at the same time..... Philip
 

·
Registered
Joined
·
60 Posts
Discussion Starter · #5 ·
I had some help putting it in b.c it is pretty heavy for me but I will try that and the kia was given to me by my grandmother and she never had the alternator replaced
 

·
Registered
Caribou, Otter, Buffalo
Joined
·
2,689 Posts
Before you arbitrarily change parts, do an electrical system maintenance, clean all connectors and ground points.... A M/M is a good investment... Philip
 

·
Registered
Joined
·
60 Posts
Discussion Starter · #7 ·
My whole engine is dirty lol I just looked and the alternator is like black in spots and the whole engine is just dirty not really dirty but dirty enough
 

·
Registered
Cerato S Hatch Auto
Joined
·
1,236 Posts
Sporty with the shakes?
My car did this 9 months ago they said it was a bad coil and replaced it I had gotten a new battery right before I took it in and the battery was too tall to fit the negative terminal could this be the problem? The negative terminal is on the side of the battery please HELP!
Are you saying that it's shaking again?

By the sound of it (in your subsequent posts), the engine is in need of some care and attention. Stray oil in the engine bay can spoil electrical leads etc.

Not sure why you fitted the wrong battery. Any battery that I've ever seen has the terminals coming out the top; the only variation is in the type of terminals. They are usually slightly-tapered posts to fit clamps on the battery leads, or drilled posts to take flat lugs on the leads. The tapered clamps on the leads can sometimes get distorted with age and need replacing.

If the terminal is indeed "on the side of the battery", this shouldn't be a problem, provided the battery is secured properly, both physically and electrically.
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,961 Posts
Sounds like a multi terminal battery with posts and GM type recessed tread terminals and one post was used (positive) and a lead "adapter" post was screwed into the side for the negative connection...
Anyway this is not causing the above problems...It probably has a dirty IAC (intake air control) valve or a dirty MAF (mass air flow) sensor.
Dave
 

·
Registered
VW Diesel Bug & Jetta
Joined
·
4 Posts
If it's not the 'other' coil, it could be an egr valve stuck open.
Or a vacuum leak.

Take it to an auto parts store that'll read the codes for free.
Advance Auto, Autozone, Pep Boys, etc.
 

·
Registered
Joined
·
2,241 Posts
Do you have access to a multimeter (voltage checks) and an ODBII scanner (to read sensor values from the ECM) ?

You really need to check battery voltage to see if the alternator is working when the electrical system is under load (headlights/cabin heater),

And posting sensor values w/ engine warmed up to operating temp. would really be helpful for us to help you..

Regards,
GottaCruise
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,961 Posts
This "could" qualify as a "99" if it was built pre 2000 and may need the SC014 bulletin work done... (supplied by GottaCruse).
Dave
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,961 Posts

·
Registered
Joined
·
60 Posts
Discussion Starter · #17 ·
it's kind of weird though b.c my car just started doing this It was given to me by my grandmother she would always take it in for recalls and as it sits it leaks oil hasn't been cranked in days ;-<
 

·
Registered
VW Diesel Bug & Jetta
Joined
·
4 Posts
Amara,
Where are you located?
Maybe someone with a scanner can come to help you.
Always good to have another pair of eyes to look things over too!
-Dan
 

·
Registered
Joined
·
60 Posts
Discussion Starter · #19 ·
amara is my middle not my first im on the east coast car is still down i have people telling me its serious its been leaking oil too and i have cranked it or anything oil pan gasket has been done and valve cover what now
 
1 - 19 of 19 Posts
Top