Kia Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-5 of 5 Results
  1. 2G (2003-2010) Sportage
    I have a 2006 kia Sportage 2.7 V6 engine. Car sometimes crank without starting and lights on the cluster remains on when turning the switch to off position. i have to remove the ECU fuse so i can start the car without problem. Car dies suddenly from time to time in the middle of the road at...
  2. Kia Carens & Rondo Forum
    My question has a few parts to it: [tl;dr No crank with immobilizer warning light. Replace ECU with another paired with key to avoid predatory dealer b.s.?] First, the biggest issue is my 2009 Rondo (Canadian made 4-cyl) won't crank and shows a solid "key and car" logo light on the cluster...
  3. 2G (2006 - 2011) Rio & Rio5
    Hi everyone I am hoping someone has an answer for my issue, its a bit of a long story, complete with the usual frustration, expense and lack of resolution so far. It started with my daughters Kia Rio 2008 1.4 manual, the engine light had been on for more than a year and the car runs well. We are...
  4. Kia Cerato, Shuma & Spectra Forum
    I got my Kia Cerato K3 2014 version. Recently it didn't start and when I took it to the local KIA service center, found out that the ECU is blown. But didn't get quite a reason on why it happened. Did any of you here have the same problem and may I know how does the ECU gets not working and had...
  5. 2003-2010 Sorento Forum
    Can't seem to find any pictures or youtube for the ECU on my 2004 Sorento. Anyone know how to get to the plugs? need to cut a wire to get rid of this p1330 code... thanks!!!
1-5 of 5 Results
Top