Kia Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-5 of 5 Results
  1. 2014 - 2015 Sorento Forum
    Can anyone identify this fitting? Recently my A/C system went out on my 2014 sorento, and while trying to diagnose the issue I found the this brass fitting under the engine on top of the plastic engine tray. I do not know if it is associated with the A/C system but it does look like an A/C...
  2. 3G 2011 - 2016 Sportage
    What is the correct pressure rating for the radiator cap? I heard a tech manager say 8; the last one I bought was spec'ed at 11 psi; and when I look them up today, only 16 psi are recommended. Mine will push coolant to the overflow when hot, but it doesn't suck it back to the engine when cold. I...
  3. 1G/2G (2001-2006) Magentis & Optima
    Hi! my name is Herbie and I have a 2004 Magentis 2.4L, with a code p0118. It sometimes starts and sometimes doesn't in cold weather. If it does start, sometimes stalls. I changed the ect sensor, same result, code. On scanner, shows engine temperature at a constant -40c. My temperature gauge in...
  4. 3G (2006.5+) Magentis & Optima
    Hey all. This car has been killing me lately and I'm at a loss with it. Sorry if I throw too much unrelated info at you, just trying to be thorough. My 2006.5 Kia Optima with ~220k miles started stalling while driving a little over a month ago, immediately after filling the tank up (I had run...
  5. 2011 - 2013 (XM) Sorento Forum
    Evidently my sensor is going bad, or it and the cam position sensors are going bad. (according to the kind folks at two different auto parts dealers here) There are numerous videos on how to find and replace the camshaft position sensors, but very little, or mislabeled/misleading videos on the...
1-5 of 5 Results
Top