How to trace earthing fault in Pride 1999 - Kia Forum

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 10-25-2008, 11:20 AM Thread Starter
Newbie
 
Join Date: Dec 2007
Posts: 11
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
How to trace earthing fault in Pride 1999

Hi all,

I have this Pride 1999 model. It runs fine. But I am having electrical problems with it. It all started with Cig. Lighter. It stoped working, fuse were OK. Then Temp. Guage needle going past the max. then Fuel needle also past the max. The Fog light stoped working and now in the left hand [B]Head Light, both the ELEMENTS of the bulb light, and light is not bright as it should.

I took out the Fuel Float assembly and checked it, it is working fine. The Thermostat is also fine. I do not know if all these are directly wired or through some relay or what.

Any help would be appreciated.

biggerlens is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 10-25-2008, 11:48 AM
Senior Member
 
Alarmin's Avatar
 
Join Date: Mar 2007
Location: Adlington, Lancs. UK
Posts: 497
Drives: 2014 Sportage 1.7CRDi 2WD ISG 4
Gallery: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Garage

Send a message via MSN to Alarmin
To prove it is an 'earthing fault' just make a temporary earth from one of your lights to ground.

All should be well again.

All you will need to do is find the 'bad earth' and sort that.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Alarmin is offline  
post #3 of 8 (permalink) Old 11-11-2008, 02:07 PM
Newbie
 
Join Date: Nov 2008
Location: Poznań Poland
Posts: 2
Drives: FIAT 125 ,FIAT UNO
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Hi I have this same problem with Temp. Guage needle going past the max. then Fuel needle also past the max but al lights are ok. wath I can do .
mayby I should make a temporary earth from my gauge panel ?
grzegorztn is offline  
 
post #4 of 8 (permalink) Old 11-11-2008, 03:01 PM
Senior Member
 
Alarmin's Avatar
 
Join Date: Mar 2007
Location: Adlington, Lancs. UK
Posts: 497
Drives: 2014 Sportage 1.7CRDi 2WD ISG 4
Gallery: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Garage

Send a message via MSN to Alarmin
Quote:
Originally Posted by grzegorztn View Post
Hi I have this same problem with Temp. Guage needle going past the max. then Fuel needle also past the max but al lights are ok. wath I can do .
mayby I should make a temporary earth from my gauge panel ?
This doesn't sound like an earthing fault (I could be wrong), more like a voltage regulator.

It may be worth getting an auto electrician to test it.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Alarmin is offline  
post #5 of 8 (permalink) Old 11-12-2008, 12:29 AM
Newbie
 
Join Date: Nov 2008
Location: Poznań Poland
Posts: 2
Drives: FIAT 125 ,FIAT UNO
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

wen engine is stop is 12.2 V when engine i run is 14,4V
maybe is other voltage regulator only for panel instruments

Last edited by grzegorztn; 11-12-2008 at 06:53 AM.
grzegorztn is offline  
post #6 of 8 (permalink) Old 09-09-2011, 10:31 AM
Newbie
 
Join Date: Sep 2011
Posts: 1
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

i have a similar problem..my kia pride wont start..rear light, horn, dashboard lights wont turn on..but the head lights still works...when i tried to start the car..nothing happens..not even a single sound..its like dead or something..checked the battery and it's fine..
olrenz is offline  
post #7 of 8 (permalink) Old 09-22-2011, 02:58 AM
Newbie
 
Join Date: Nov 2010
Location: Cebu City Philippines
Posts: 14
Drives: toyota Lite ace GXL 1995 gas, Kia Sportage 1996 R2 diesel Engine; Kia pride 1998 GTX B3 gas
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

check your engine bay wires. located near the ignition coil and bolted near the inner side of the fender is a wire terminal that needs to be "jumper wired" for power to flow. there are 2 jumper wires. original colors are red and brown. test those jumper wires if still okay and clean the terminals before re-installing.

those wires gets corroded over time and will not make the connections.
fabianito is offline  
post #8 of 8 (permalink) Old 09-28-2011, 01:56 AM
Newbie
 
Join Date: Nov 2010
Location: Cebu City Philippines
Posts: 14
Drives: toyota Lite ace GXL 1995 gas, Kia Sportage 1996 R2 diesel Engine; Kia pride 1998 GTX B3 gas
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

the Kia Pride is rebadged Ford Aspire. click the link below and check for yourself your wiring. except for some wire colors, the connections are correct and the same for the kia pride (gtx 98) and the ford 1997 aspire.

http://www.autolib.diakom.ru/CAR/For...NG%20DIAGRAMS/
fabianito is offline  
Reply

  Kia Forum > KIA Models > Other Kia Models



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange behaviour of Fuel & Temp. Guage in Kia Pride 1999 biggerlens Other Kia Models 2 07-17-2013 01:55 PM
Most Error Codes cwalsh_00 Shuma & Spectra (1997-2003) 0 06-30-2009 02:06 PM
1999 Kia Pride interior lights Dutch&USA-KIAdriver Other Kia Models 1 04-06-2009 03:01 PM
Spare Parts Dealers around London for KIA PRIDE 1999 biggerlens Other Kia Models 0 05-22-2008 03:39 PM
KIA PRIDE 1.3 1999 Model biggerlens Performance 0 12-10-2007 11:53 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On