KIA K2700 diesel smoke problem - Kia Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-14-2016, 04:55 PM Thread Starter
Newbie
 
Join Date: Jul 2016
Location: renmark
Posts: 3
Drives: K2700 diesel
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Unhappy KIA K2700 diesel smoke problem

hi, just put a new head ,liners , conrod bearings and rings on a 2003 k2700 diesel.

been running fine for a couple weeks. now it blows smoke.

so far it seems to be when you let it sit overnight or for a long time it blows alot of smoke ( more white than blue) and does run rough for a bit , and some times stalls. , for about 3 to 5 minutes.then clears fairly well up.

after the smoke stops , i can start it various times during the day and there would only very minimal smoke , no stalling ,

i took the injectors out , and the guy who fixed them said they where very leaky and had no atomization etc.. ,so he put all new nozzles in.
put them in yesterday , and started up with small amount of smoke , then cleared up pretty good. started it up a few times after that and it all seem good, i thought....

started it up this morning and it is like it was before blowing a decent amount of smoke , running rough and stalled.

any body got any clues as to whats wrong ? injector pump is about the only thing i can think of.

mark k

turbo1600 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 12-12-2017, 12:43 AM
Newbie
 
Join Date: Aug 2014
Location: Talisay, Cebu
Posts: 5
Drives: 2006 kia bongo, 2013 hd flch
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Garage

You didnt say which engine you have. But When mine starts blue smoking on start up when cold (its time to replace the fuel filter) mine has a J2 engine
txslim is offline  
post #3 of 3 (permalink) Old 12-12-2017, 01:17 AM Thread Starter
Newbie
 
Join Date: Jul 2016
Location: renmark
Posts: 3
Drives: K2700 diesel
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Quote:
Originally Posted by txslim View Post
You didnt say which engine you have. But When mine starts blue smoking on start up when cold (its time to replace the fuel filter) mine has a J2 engine
hi , yeah that was some time ago, i really cant remember what engine type it was, BUT what it ended up being , all that smoke , was the front injector pump seal.
when i took the timing cover of and the gears , you could see a clean spot just below injector pump shaft where all the diesel was leaking , when i took seal out i found it really hard, once i put new front injector pump seal in , it was all fixed.........
...........
..........
till it developed a water leak or something , ,,,,the guy drove the engine that much while it was over heating he actually MELTED the plastic composite rocker cover , and COMPLETELY cooked the engine.....
turbo1600 is offline  
Reply

  Kia Forum > KIA Models > Other Kia Models



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
KIA Sportage 2006 2.0ltr Diesel Starting Problem after Timing Belt Changed. Karamelo 2G (2003-2010) Sportage 0 02-13-2017 05:46 AM
2012, 2.2l Diesel, clutch problem [email protected] 2011 - 2013 (XM) Sorento Forum 1 02-01-2017 02:13 AM
Problem: Pulling to the right Narvo Kia Carens & Rondo Forum 442 04-21-2013 08:52 AM
Sedona 2.9 diesel automatic throttle problem? plumothy Kia Carnival & Sedona (2002 - 2005) 2 07-10-2007 07:10 AM
Sedona 2.9 diesel automatic throttle problem? plumothy Kia Carnival & Sedona Forum 0 07-05-2007 07:19 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On