2009 Kia Borrego multiple warning lights - Kia Forum

 1Likes
  • 1 Post By HavasuPaPa
 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 12-22-2011, 01:48 PM Thread Starter
Newbie
 
Join Date: Dec 2011
Posts: 1
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Thread Starter (Thread Starter)
Question 2009 Kia Borrego multiple warning lights

We have 36,000 miles on our Borrego. Last week multiple warning lights came on - ABS, 4 wheel drive system, ESC off, Brake & DBC. When I pulled over, the vehicle would only shift into neutral from drive. It would not shift into reverse or park. I shut the vehicle off, waited a couple of minutes and restarted it. All the warning lights were gone and I was able to shift into all positions. I took it to the dealer and they couldn't find anything wrong. Last night it happened again as well as this morning. But this morning the malfunction indicator also appeared. As I drove my kids to school and returned home, the lights popped on and off several times. When the lights are on the speedometer doesn't work either. The vehicle operates normally other than the shifting issue, the speedometer and now the cruise. It seems like it has to be some kind of computer module glitch. Anyone else with similar issue???

IowaKia is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 10-22-2014, 05:10 PM
Newbie
 
Join Date: Jan 2010
Posts: 17
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)

Me too. Ever get an answer?
kb9nvh is offline  
post #3 of 10 (permalink) Old 10-22-2014, 05:29 PM
Super Moderator
 
Join Date: Oct 2011
Location: southern california
Posts: 2,919
Drives: 2015 KIA Sorento LX 2.4L & 2018 Chrysler 300 Limited
Gallery: 0
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 115 Post(s)

Quote:
Originally Posted by kb9nvh View Post
Me too. Ever get an answer?
KB9NVH I moved this thread to the Borrego forum it is a few years old and possibly you will get some help.
"73" from Ke6tz Ken
jetech00001 is offline  
 
post #4 of 10 (permalink) Old 10-22-2014, 08:28 PM
Newbie
 
Join Date: Jan 2010
Posts: 17
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)

I only see this forum now that combines mojava and borrego and is THIS thread?? What was your solution or did you just sell it?
kb9nvh is offline  
post #5 of 10 (permalink) Old 10-23-2014, 09:55 AM
Full Member
 
Join Date: Dec 2009
Location: So. California
Posts: 103
Drives: 09 Borrego EX V8 2WD
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)

Quote:
Originally Posted by IowaKia View Post
We have 36,000 miles on our Borrego. Last week multiple warning lights came on - ABS, 4 wheel drive system, ESC off, Brake & DBC. When I pulled over, the vehicle would only shift into neutral from drive. It would not shift into reverse or park. I shut the vehicle off, waited a couple of minutes and restarted it. All the warning lights were gone and I was able to shift into all positions. I took it to the dealer and they couldn't find anything wrong. Last night it happened again as well as this morning. But this morning the malfunction indicator also appeared. As I drove my kids to school and returned home, the lights popped on and off several times. When the lights are on the speedometer doesn't work either. The vehicle operates normally other than the shifting issue, the speedometer and now the cruise. It seems like it has to be some kind of computer module glitch. Anyone else with similar issue???
Quote:
Originally Posted by kb9nvh View Post
I only see this forum now that combines mojava and borrego and is THIS thread?? What was your solution or did you just sell it?
If you have the V8 Borrego, there is a TSB that addresses this issue.
Borrego-TSB-ZF ATM MECHATRONIC-035.pdf
jetech00001 likes this.
HavasuPaPa is offline  
post #6 of 10 (permalink) Old 10-23-2014, 05:54 PM
Newbie
 
Join Date: Jan 2010
Posts: 17
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)

Thanks...I have the V6 so not sure. I talked to Kia today and they didn't really have an answer. I have an appointment for tomorrow morning.



Quote:
Originally Posted by HavasuPaPa View Post
If you have the V8 Borrego, there is a TSB that addresses this issue.
Attachment 32105
kb9nvh is offline  
post #7 of 10 (permalink) Old 03-09-2016, 04:03 PM
Newbie
 
Join Date: Mar 2011
Posts: 16
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)

I got the same problem last week, ever got an answer ?
g2yeux is offline  
post #8 of 10 (permalink) Old 03-09-2016, 04:35 PM
Newbie
 
Join Date: Jan 2010
Posts: 17
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)

Yes....if a speed sensor goes out all hell breaks loose with the 4wd and traction control...
in my case, a front right wheel bearing was replace under warranty by KIA and it went bad and it caused damage to the sensor that then had to be replaced.
All those lights..one wheel sensor.


Quote:
Originally Posted by g2yeux View Post
I got the same problem last week, ever got an answer ?
kb9nvh is offline  
post #9 of 10 (permalink) Old 03-09-2016, 10:20 PM
Full Member
 
Canine's Avatar
 
Join Date: Jan 2016
Location: Lexington South Carolina
Posts: 130
Drives: 15 K900, 13 Sportage
Gallery: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 33 Post(s)

If it is a V8 then the mechatronic assembly is faulty. Basically the brain inside of the transmission. Hopefully you're the original owner and it's covered power train.. Just replaced one the other day and it was about 4700.00 warranty cost. Found out that particular trans is a bmw product. Had to wait 2 weeks for the part and had to replace it twice first one was faulty. Almost a 9k Kia warranty claim.. Fun stuff
Canine is offline  
post #10 of 10 (permalink) Old 03-10-2016, 10:32 AM
Full Member
 
Join Date: Dec 2009
Location: So. California
Posts: 103
Drives: 09 Borrego EX V8 2WD
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)

Quote:
Originally Posted by Canine View Post
If it is a V8 then the mechatronic assembly is faulty. Basically the brain inside of the transmission. Hopefully you're the original owner and it's covered power train.. Just replaced one the other day and it was about 4700.00 warranty cost. Found out that particular trans is a bmw product. Had to wait 2 weeks for the part and had to replace it twice first one was faulty. Almost a 9k Kia warranty claim.. Fun stuff
If it is a V8, here is the TSB for the fix. I had mine done at around 22K miles.
Borrego-TSB-ZF ATM MECHATRONIC-035.pdf
HavasuPaPa is offline  
Reply

  Kia Forum > KIA Models > Kia Mohave & Borrego



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
2008 Sorento 4WD Warning Lights Solid cvh8601 2003-2010 Sorento Forum 17 10-25-2016 04:49 PM
2005 Spectra Charging and Brake Warning Lights greaser Kia Cerato, Shuma & Spectra Forum 1 11-06-2009 02:35 PM
Warning Lights / Indicators nnj10 Kia Picanto Forum 0 08-31-2009 03:45 AM
Interior lights on 2009 Rondo notavan Kia Carens & Rondo Forum 11 05-05-2009 01:45 PM
First Drive: 2009 Kia Borrego 666666 Kia Mohave & Borrego 7 02-17-2009 07:30 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On