ESC OFF/ Hill Descent Light - Page 2 - Kia Forum

Reply
 
LinkBack Thread Tools Display Modes
post #11 of 27 (permalink) Old 06-20-2011, 08:10 AM
Senior Member
 
edwelly's Avatar
 
Join Date: Feb 2009
Location: Louisville, KY
Posts: 203
Drives: 2018 Sportage SX | 2009 Borrego EX (gone)
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)

Quote:
Originally Posted by Rick2456 View Post
You would think Kia or any car maker for that matter, would after attempting to fix a vehicle a certain number of time (and a certain amount of money), they would just replace the vehicle. At that point, they should sent the defective vehicle back to the factory where the engineers could figure out what went wrong and make sure it never happens to another vehicle. But I guess that makes way too much business sense.
You would think something would be done but I have noticed a common theme with Kia dealers - they don't care. Sorry if anyone works for Kia, but my experience has been less than stellar with the service dept.

edwelly is offline  
Sponsored Links
Advertisement
 
post #12 of 27 (permalink) Old 06-20-2011, 08:26 AM
Senior Member
 
Join Date: Sep 2009
Location: Atlanta, GA
Posts: 291
Drives: 14 Kia Sorento (V6 EX AWD), 2013 Nissan Altima SV
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Quote:
Originally Posted by edwelly View Post
You would think something would be done but I have noticed a common theme with Kia dealers - they don't care. Sorry if anyone works for Kia, but my experience has been less than stellar with the service dept.
I myself have been very pleased with our local Kia Service department. The sales department.. not so much. Additionally, like others, I have found that Kia Corporation is horrible when it comes to customer service. This is unusual, as I have dealt with Hyundai on occasion (I have a Santa Fe), and they are very good (IMHO).
Rick2456 is offline  
post #13 of 27 (permalink) Old 06-20-2011, 07:30 PM
Newbie
 
Join Date: Nov 2010
Location: Tampa fl
Posts: 11
Drives: 2009 borrego
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

My wife's Borrego started doing the same thing about a mon. ago. The light comes on for no apparent reason, at random, and it does not seem to effect the driving of the car. She can stop, turn the engine off, start it later and no light. Other then that she loves the car and we've had it for 15 mons. and 10,000 miles with no issues. I thought I would tell the Kia rep the next time it goes in for service.
wellcraft17 is offline  
 
post #14 of 27 (permalink) Old 06-20-2011, 08:05 PM Thread Starter
Newbie
 
Join Date: Mar 2011
Location: Oklahoma
Posts: 17
Drives: 2009 Kia Borrego EX V6 4WD
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
So, the light came on again today - at a random time as always. Does anyone else seem to notice a pattern with hills/inclines when it happens? Seems like every time it has happened to me I have been on a hill/slight incline.

1. When I park my Kia at night, I park on an incline. The light has come on twice when I turned on the car/shifted into reverse.
2. When I was driving down a slight incline, the lights came on. The light has happened twice by doing this.
3. I was parked on a slight incline today while dropping my daughter off at daycare, and left my Kia running - I came back and the lights were on. (The radio, oddly enough, was not working either...)

Each time I have been able to restart the car and the lights go away. The lights are happening much more often, and I have scheduled an appt July 1 at my local Kia dealership. (Of course, Kia does not offer rental cars - and this will be a holiday weekend).

I do have photos of three of the times that this has happened, with the mileage of each. I will be providing the dealer with those photos as well as any forum topics from this website that deal with this...but, I know they won't care. (And I don't blame them - I work on computers for a living, and usually if I follow what someone tells me is wrong with the computer I chase a ghost for a long time before I finally figure out what was wrong.)

Thanks everyone - I really, really appreciate this forum. It's nice to know I'm not the only one - but that makes me feel bad just as much as it makes me feel good. :-)
jbrigance is offline  
post #15 of 27 (permalink) Old 06-22-2011, 08:38 AM
Full Member
 
Join Date: Dec 2009
Location: So. California
Posts: 103
Drives: 09 Borrego EX V8 2WD
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)

I've got my fingers crossed too... my dealer is changing my V8 transmission "Mechatronic" part today. I'll add to this post in a week to report if the ESC/DTC warning lights problem is still occurring. I'll bet there are lots of Borregos with this same problem but only a few of us are using this forum.

Last edited by HavasuPaPa; 06-22-2011 at 08:48 AM.
HavasuPaPa is offline  
post #16 of 27 (permalink) Old 06-30-2011, 02:30 PM
Full Member
 
Join Date: Dec 2009
Location: So. California
Posts: 103
Drives: 09 Borrego EX V8 2WD
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)

Quote:
Originally Posted by artworkz View Post
how did it go? ours is in now having it replaced
Artworkz:
Just got back last night from a 650 mile trip to Arizona. NO WARNING LIGHTS! I tested the manual shift as well. I also towed a 5500 lb boat with no problem (the boat is stored in Az, so I only towed a few miles to and from the lake). 22 mpg on the trip to Az. (Cruise control set at 75mph). Not bad since the temps through the desert was around 95 degrees F...at night. Can't wait to hear your results.
HavasuPaPa is offline  
post #17 of 27 (permalink) Old 06-30-2011, 11:54 PM
Full Member
 
Join Date: May 2009
Posts: 145
Drives: GSXR1000, Aprilia SXV550, Aprilia RSV4 Factory
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)

It probably won't make you feel any better about your trans. problem, but, BMW (X5) and Hyundia Genesis owners are experiencing the same problem. The original ZF6 transmission electronic control modules were affected by stray static elecrical charges that made the transmissions do strange things. The solution was/is to replace the electroic control, unit with an electrically shielded unit that grounded these stray charges. I first read about these issues over on the Hyundia/Genisis forums. The Sachs ZF6 transmission is used in several model BMWs, Masaratis, Jaguars and of course our beloved Kia Borregos and Hyundia Genisis and Equus.
Robert

Robert
Southeast Texas
09 Kia Borrego Limited (4X2)
kiadad is offline  
post #18 of 27 (permalink) Old 07-11-2011, 03:14 PM
Full Member
 
Join Date: Dec 2009
Location: So. California
Posts: 103
Drives: 09 Borrego EX V8 2WD
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)

I had mine changed over two weeks ago and everything is good so far. Also over 1000 miles.
HavasuPaPa is offline  
post #19 of 27 (permalink) Old 07-14-2011, 08:36 AM
Newbie
 
Join Date: Aug 2010
Location: Tennessee
Posts: 5
Drives: 2009 Borrego, 2005 Sedona, 2001 Rio
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

I had the same problem. The dealer replaced a break switch and I have never had the problem since.
Sevin is offline  
post #20 of 27 (permalink) Old 07-20-2011, 08:36 AM
Newbie
 
Join Date: Feb 2005
Location: Arkansas, USA
Posts: 10
Drives: 2009 Borrego LX V6 2WD
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

I just noticed this same issue today. ESC/DBC lights are on, no reason as to why. Dash buttons for these are non-responsive. I didn't notice any change in the vehicle driving/handling. I guess I will bring it in, and get it looked at. Hopefully, it's nothing serious.

I have a V6 EX.
vanenk is offline  
Reply


Top

  Kia Forum > KIA Models > Kia Mohave & Borrego



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
KIA Fog Light LED Bulbs! Plug & Play Install! Upgrade your lights! Diode Dynamics Diode Dynamics 39 06-21-2018 05:28 PM
Turning off traction control and turn on 4wd lock sohokia 2011 - 2013 (XM) Sorento Forum 10 10-26-2017 02:57 PM
hill descent control Sloppy 4G 2016-2018+ Sportage 0 05-23-2017 09:34 AM
Need help. O/D light blinking and check engine light on. Code P1624. hardworking 2G (1998 - 2001) Sephia 29 01-12-2009 10:22 PM
Light bulbs for 06 Sedona Repsolal Kia Carnival & Sedona 2006+ 2 12-17-2008 10:44 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On