Radio cut-out - Kia Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-02-2018, 03:06 PM Thread Starter
Newbie
 
Join Date: Feb 2017
Location: Maryland
Posts: 5
Drives: Borrego 2009
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Radio cut-out

Strange one here, looking for some ideas. I replaced the stock head unit with a 7" Android model and now have Waze navigation, and also added a backup camera. This was 15 months ago. A few weeks ago the unit would simply black screen and reboot. At first I thought it was just Waze crashing, but then I noticed with just the radio on.

What gets interesting is that I can sometimes make it happen by rolling up the windows and holding up when it hits the top...as soon as that happens...black screen and reboot. This will work sometimes, but not all the time. Most times it just reboots at random intervals.

So...the question is what could be the cause?....bad head unit?, loose wiring somewhere? or something faulty with the electrical supply from the truck harness that is causing a voltage loss...

any thoughts?

MahJohn is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-03-2018, 07:15 AM
Member
 
Join Date: Aug 2016
Location: Virginia
Posts: 41
Drives: 2016 Rio SX
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)

It certainly sounds like voltage drop, caused by, most likely a bad connection/crimp or bad ground somewhere. Did you splice the power lines to the Android model. I would suggest you take a voltmeter and measure the voltage at the 'head' then do your test with the windows and see if the voltage drops significantly at the head. Then its a question of checking the wiring - and grounding of course to/from the head.
Hardware_dude is offline  
Reply

  Kia Forum > KIA Models > Kia Mohave & Borrego



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
After Market Radio Kia 2011 suave6565 2011 - 2013 (XM) Sorento Forum 1 11-30-2017 12:40 PM
REVISIT from 2015 Dead Radio LX model tedmn 2011 - 2013 (XM) Sorento Forum 3 10-27-2017 01:06 PM
09KiaOptimaSX: Dead Battery Killed my Radio?! Brickstin 3G (2006.5+) Magentis & Optima 0 05-02-2017 08:21 PM
2012 radio power issues alconnell 2011 - 2013 (XM) Sorento Forum 1 08-13-2016 12:37 AM
Turn your radio on... Eutychus 2003-2010 Sorento Forum 3 07-05-2006 11:06 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On