2009 Kia Borrego Check Engine help - Kia Forum

 4Likes
 
LinkBack Thread Tools
Old 07-29-2017, 08:23 AM Thread Starter
Newbie
 
Join Date: Jul 2017
Location: Massachusetts
Posts: 14
Drives: 2009 Kia Borrego
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)

Thread Starter (Thread Starter)
2009 Kia Borrego Check Engine help

Hi, I am new to this forums and hoping I can gets some help.

My wifes borrego just recently failed inspection. The check engine light was on and error code was reading "P0018 Crankshaft Position, Camshaft Position, Correlation Bank 2, Sensor A"

We did take it to the kia dealer in Putnam, CT and they in short said she needed a rebuilt motor. Notes were as follows. " RECC L/H INTAKE ALL 3 CHAINS & TENSIONER SV/C GASKETS OIL & COOLANT $3200"

I have been reading this code is also related to other possible emissions issues such as loose gas cap, bad sensors, etc. The check engine light shuts off, then comes back on. Its very inconsistent.
-One day it shut off and I drove nearly 60 miles. Stopped to get gas and it came back on again. So I replaced the gas cap.-This didnt fix it.

-I replaced the air filter. Honestly, it was so dirty I don't think my wife ever had it replaced. This didn't fix it. Matter of fact. It actually made it stay on more permanently.

-So then i was thinking.. Maybe the mass airflow sensor was bad. After all, I did nudge it a bit while replacing the air filter. So I replaced that. Reset the check engine light. I drove it to work, restarted the car nearly 10 times. Drove it 68miles and it stayed off the entire time. Got home and hooked up the scanner and it read the P0018 code still. this time I restarted the car and the check engine light came back on.

My wife took the car to a cheapo oil place the time before last to have the oil changed. Oddly its when the check engine light started coming on. I have heard that a cheap oil filter could cause this problem. Since then the dealer did the oil the same time they gave us there diagnosis, so I'm really thinking were ok in the oil change department.

So Now im on the sensor testing kick. I'm thinking the oxygen sensor might be bad. Can someone tell me where to look? I found these sensors and one is covered with oil what are they?


Thanks for reading my post. Any help would be greatly appreciated.

SpecterM is offline  
Sponsored Links
Advertisement
 
Old 07-29-2017, 08:24 AM Thread Starter
Newbie
 
Join Date: Jul 2017
Location: Massachusetts
Posts: 14
Drives: 2009 Kia Borrego
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)

Thread Starter (Thread Starter)
I would post images but I cant.
SpecterM is offline  
Old 07-29-2017, 08:34 AM
Veteran
 
Join Date: Sep 2016
Location: USA,WESTERN NY
Posts: 1,752
Drives: 09 kia spectra ex,04 Neon,04 Chry. T&C, 98 Avenger
Gallery: 0
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 364 Post(s)

Sounds like a high mileage and poorly maintained vehicle to me. Your best bet is to follow the proper diagnostic path and start where the code from the computer sees a problem .. the crank and cam sensors. And yes timing chains can be part of the problem for that condition.
ron1004 and SpecterM like this.
MIA KIA 09 is offline  
 
Old 07-29-2017, 08:57 AM Thread Starter
Newbie
 
Join Date: Jul 2017
Location: Massachusetts
Posts: 14
Drives: 2009 Kia Borrego
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)

Thread Starter (Thread Starter)
The picture I am trying to show is the Variable Timing Solenoid. It is covered with oil. Ive never replaced one, but it looks real easy to do. Do you know of a way to test it?
SpecterM is offline  
Old 07-29-2017, 08:58 AM
Super Moderator
 
ron1004's Avatar
 
Join Date: Jun 2005
Location: USA
Posts: 8,437
Drives: 1999 Kia / 기아 Elan, 2017 Ford Edge Sport, 2015 Ford Mustang, 2008 Harley Nightrain
Gallery: 13
Mentioned: 18 Post(s)
Tagged: 0 Thread(s)
Quoted: 704 Post(s)
Garage

Quote:
Originally Posted by SpecterM View Post
I would post images but I cant.
No reason why you shouldn't be able to - scroll down to "Manage Attachments".


You don't tell us what the mileage is, the real service history, etc. so that leaves it open to further guessing, and as you have reported you've spent a fair bit on guesswork (new MAF sensor) - best use a diagnostic approach.

Quote:
I replaced the air filter. Honestly, it was so dirty I don't think my wife ever had it replaced.
Another sign that this engine is failing prematurely due to poor maintenance.

There are non-OEM oil filters that are compatible, but safest to stick with the very reasonably priced OEM ones - would you expect that the cheap quick-lube places use a high grade oil and filter?

Replacing the timing chains and tensioners isn't really a rebuilt motor, but most likely your cheapest option, dependant on the mileage.

Quality and not quantity counts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Sig image is 500X100 at 11.7 kb
ron1004 is offline  
Old 07-29-2017, 09:00 AM
Super Moderator
 
ron1004's Avatar
 
Join Date: Jun 2005
Location: USA
Posts: 8,437
Drives: 1999 Kia / 기아 Elan, 2017 Ford Edge Sport, 2015 Ford Mustang, 2008 Harley Nightrain
Gallery: 13
Mentioned: 18 Post(s)
Tagged: 0 Thread(s)
Quoted: 704 Post(s)
Garage

Quote:
Originally Posted by SpecterM View Post
The picture I am trying to show is the Variable Timing Solenoid. It is covered with oil. Ive never replaced one, but it looks real easy to do. Do you know of a way to test it?
What makes you think that it needs replacement, ....... just a guess?

Quality and not quantity counts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Sig image is 500X100 at 11.7 kb
ron1004 is offline  
Old 07-29-2017, 09:02 AM
Veteran
 
Join Date: Sep 2016
Location: USA,WESTERN NY
Posts: 1,752
Drives: 09 kia spectra ex,04 Neon,04 Chry. T&C, 98 Avenger
Gallery: 0
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 364 Post(s)

VVT trouble has its own specific code. If it has a problem, it will show it. START with the given code(s) area FIRST.
MIA KIA 09 is offline  
Old 07-29-2017, 09:07 AM Thread Starter
Newbie
 
Join Date: Jul 2017
Location: Massachusetts
Posts: 14
Drives: 2009 Kia Borrego
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)

Thread Starter (Thread Starter)
Ron.. Your absolutely correct on everything you say. I am by NO means a mechanic. My wife did neglect her vehicle.

My guess work is based on Hunches and Youtube videos. Sorry.. Its what I got.
Attached Thumbnails
Click image for larger version

Name:	20170729_083421.jpg
Views:	1023
Size:	195.3 KB
ID:	87538  
SpecterM is offline  
Old 07-29-2017, 09:09 AM Thread Starter
Newbie
 
Join Date: Jul 2017
Location: Massachusetts
Posts: 14
Drives: 2009 Kia Borrego
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)

Thread Starter (Thread Starter)
MIA KIA 09 thanks. I guess I should just leave this stuff to the pros.
SpecterM is offline  
Old 07-29-2017, 09:12 AM Thread Starter
Newbie
 
Join Date: Jul 2017
Location: Massachusetts
Posts: 14
Drives: 2009 Kia Borrego
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)

Thread Starter (Thread Starter)
Just out of curiosity. Computer shows this code Where would you start?
SpecterM is offline  
 


Top

  Kia Forum > KIA Models > Kia Mohave & Borrego

User Tag List

Thread Tools



  Similar Threads
Thread Thread Starter Forum Replies Last Post
2001 Kia Optima check engine light - code P0455 - EVAP System Leak Detected magenta 1G/2G (2001-2006) Magentis & Optima 3 09-24-2017 10:07 PM
Check engine - Low Oil pressure lights Leinie Kia Carnival & Sedona 2006+ 8 12-31-2015 05:01 PM
KIA Sportage sputtering - misfire - no power - check engine smoke - PO303 HPYUNBDAY 1G (1993 - 2002) Sportage 2 05-27-2009 07:39 AM
Check Engine light on, car stalls at 4k rpm TxDriver Kia Sephia Forum 12 01-26-2008 02:47 PM
Check Engine light on, car stalls at 4k rpm TxDriver 2G (1998 - 2001) Sephia 1 01-23-2008 10:24 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On