Wiper pump - Kia Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 02-15-2016, 09:45 AM Thread Starter
Member
 
Join Date: Nov 2011
Posts: 57
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Thread Starter (Thread Starter)
Wiper pump

Anyone change one? How much work was it. My wiper pump doesn't seem to want to work when the temp is below 20 degrees. The rear one seems to work fine. I was going to try replacing the pump by the tank. I cant see it from the top so it must be able to remove it from the bottom.

Thanks
Steve69

Steve69 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 02-15-2016, 05:34 PM
Full Member
 
Join Date: May 2015
Location: Maryland
Posts: 167
Drives: 2015 Hyundai Elantra GT, 2010 Kia Rio
Gallery: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 17 Post(s)

Maybe your wiper fluid is freezing and clogging the tubes
Kevin77 is offline  
post #3 of 4 (permalink) Old 02-22-2016, 09:30 AM
Member
 
Join Date: Aug 2009
Location: Eden, NC
Posts: 39
Drives: 2009 Borrego Limited
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

You have to make sure to use a good, sub-zero, washer fluid. My Kia dealer waters theirs down to much, and it freezes at around 20 degrees. I've complained, but it hasn't done any good. I just buy my own (Rain-X Brand) *and* I replaced the fuse with a self - resetting fuse, and now I have no more issues. If the pump freezes, even a little, it will kick the fuse. Keep that in mind.
MonkeyThumper is offline  
 
post #4 of 4 (permalink) Old 02-22-2016, 03:40 PM Thread Starter
Member
 
Join Date: Nov 2011
Posts: 57
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Thread Starter (Thread Starter)
Id agree with that but the rear winder wiper is pumping fluid fine.

Steve69
Steve69 is offline  
Reply

  Kia Forum > KIA Models > Kia Mohave & Borrego



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Windshield wiper pump kaihlabee Kia Soul Forum 3 07-07-2018 11:54 AM
Rear wiper running continuously NorseRaider 2003-2010 Sorento Forum 6 02-28-2018 06:27 AM
HELP? Wiper fluid pump fuse? Rondo 2010 Chrisleemacm Kia Carens & Rondo Forum 2 07-21-2017 04:07 AM
Replace fuel pump as pump or complete module? JensenHealey Kia Carnival & Sedona (2002 - 2005) 1 01-06-2017 09:10 AM
Timing Belt/Water Pump Problems. Help! rover449 1G (2001-2005) Rio 15 04-28-2014 12:10 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On