Rear Climate Control Unit - Kia Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 03-27-2015, 04:08 PM Thread Starter
Newbie
 
Join Date: Jul 2010
Location: Indiana, United States
Posts: 17
Drives: 2005 Sorento & 2009 Borrego
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)

Thread Starter (Thread Starter)
Rear Climate Control Unit

My Borrego is doing the same thing as others (where the rear climate control unit malfunctions and the heat stays on high).

Since I didn't see the answer in search results...My question: Does anybody know the part number? Is this something I can buy outside of the dealer?

Dealer wants close to $600 to repair.

Thanks!

jkoby is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 03-27-2015, 04:47 PM
Super Moderator
 
cobra259's Avatar
 
Join Date: Aug 2010
Location: Waterford MI
Posts: 4,419
Drives: 1995 Procharged Mustang Cobra -- 2006 Grand Cheorkee limted Hemi.
Gallery: 0
Mentioned: 20 Post(s)
Tagged: 0 Thread(s)
Quoted: 375 Post(s)

No, this not something you can buy aftermarket. "Dealer wants $600 to do the job", that would be parts AND labor to fix. The part is $345.00 from any Kia dealership. If you like you can send me a PM with the last 8 of your vin# and I'll see what I can do for a discount.
cobra259 is offline  
post #3 of 4 (permalink) Old 03-30-2015, 03:05 PM
Member
 
Join Date: Aug 2009
Location: Eden, NC
Posts: 39
Drives: 2009 Borrego Limited
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Clean it...

I took mine out last year when it started doing it, and cleaned it with electronics cleaner. Seems to have fixed it for now. Going on 3 months since it has messed up over the holidays when I cleaned it.

I *think* that this control panel has an issue with "tin wiskers" bridging a gap, causing the issues we see.
http://en.wikipedia.org/wiki/Whisker_(metallurgy)

Cleaning it with electronics cleaner from a pressurized can should clean a lot/all of those up, and make the problem go away, at least in my case. I just let the can of cleaner basically pressure wash it, and let it dry, then reinstalled it.

Easy, cheap, and worth a try, before spending all of that money on a replacement part.

If it starts doing it again, I will take it back out, and clean it again, but may use my ultrasonic cleaner to see if it helps. (Or I may just take the shortcut and spray it again, depending on how long before I see the issue pop back up)
MonkeyThumper is offline  
 
post #4 of 4 (permalink) Old 04-19-2015, 08:23 PM Thread Starter
Newbie
 
Join Date: Jul 2010
Location: Indiana, United States
Posts: 17
Drives: 2005 Sorento & 2009 Borrego
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)

Thread Starter (Thread Starter)
Quote:
Originally Posted by MonkeyThumper View Post
Clean it...

I took mine out last year when it started doing it, and cleaned it with electronics cleaner. Seems to have fixed it for now. Going on 3 months since it has messed up over the holidays when I cleaned it.

I *think* that this control panel has an issue with "tin wiskers" bridging a gap, causing the issues we see.
http://en.wikipedia.org/wiki/Whisker_(metallurgy)

Cleaning it with electronics cleaner from a pressurized can should clean a lot/all of those up, and make the problem go away, at least in my case. I just let the can of cleaner basically pressure wash it, and let it dry, then reinstalled it.

Easy, cheap, and worth a try, before spending all of that money on a replacement part.

If it starts doing it again, I will take it back out, and clean it again, but may use my ultrasonic cleaner to see if it helps. (Or I may just take the shortcut and spray it again, depending on how long before I see the issue pop back up)
Is the board behind the rear climate control switches? I guess if it is broke, I can't hurt it anymore then it already is!
jkoby is offline  
Reply

  Kia Forum > KIA Models > Kia Mohave & Borrego



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
2016 Optima Climate Control Issues LauraB 4G (2011+) Optima 8 01-12-2017 03:07 PM
Climate Control Dual (Manual Use) Questions fugitiv3 4G 2016-2018+ Sportage 3 11-09-2016 07:58 AM
auto climate control??? brandxj Kia Forte/Cerato (TD) and Koup Discussion Forum 7 12-02-2009 01:18 PM
Automatic Climate Control hoho Kia Carens & Rondo Forum 5 11-27-2007 06:20 AM
Central Locking / Remote Control unit location 02 plate sedona GingerAngles Kia Carnival & Sedona (2002 - 2005) 3 11-04-2007 05:41 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On