Aftermarket Radio Installation - Antenna Connection - Kia Forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 03-13-2014, 09:15 AM Thread Starter
Newbie
 
Join Date: Dec 2009
Location: Haverhill Ma
Posts: 8
Drives: 2009 Kia Borrego, LX
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Thread Starter (Thread Starter)
Aftermarket Radio Installation - Antenna Connection

I have a 2009 Borrego EX (8cylinder) that had the Infinity 10 speaker system with Sat. I have replaced all the speakers, installed multiple amplifiers and installed my new Kenwood receiver. The issue that I am having is that I am UNABLE to get a AM/FM signal to the receiver. I can stream music from my iPhone to the system with great results and I have been using this method since last fall. Now that spring is on the horizon I would like to resolve this issue.

I would like to obtain a schematic that indicates what each of the connectors are that came from the back of the OEM radio (not the wiring harnesses) but the two plug in connectors. I don't have an nav or back up camera (yet) but the oem radio did have aux/usb on the console. There is a SAT antenna on the back roof and I am unsure where the antenna is located (rear windshield maybe)? The OEM radio had of course AM/FM/SAT working when I purchased the car but I think I have overlooked something when I installed the Kenwood. I have connected the blue wires (from the OEM harness to the AFM radio harness) and have purchased a metra 40-Ki10 connection to adapt the AFM radio to the OEM antenna. The OEM antenna connection has two wires feeding the connector but the metra connector only has one plug exiting the connector and this is the male RCA type plug that plugs directly to the Kenwood radio. I am thinking that my issue is with this connection somehow.

Any suggestions, comments, thoughts would be appreciated. Thank you

mtbikerejg is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 03-13-2014, 03:42 PM
Full Member
 
Join Date: Dec 2009
Location: So. California
Posts: 103
Drives: 09 Borrego EX V8 2WD
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)

Quote:
Originally Posted by mtbikerejg View Post
I have a 2009 Borrego EX (8cylinder) that had the Infinity 10 speaker system with Sat. I have replaced all the speakers, installed multiple amplifiers and installed my new Kenwood receiver. The issue that I am having is that I am UNABLE to get a AM/FM signal to the receiver. I can stream music from my iPhone to the system with great results and I have been using this method since last fall. Now that spring is on the horizon I would like to resolve this issue.

I would like to obtain a schematic that indicates what each of the connectors are that came from the back of the OEM radio (not the wiring harnesses) but the two plug in connectors. I don't have an nav or back up camera (yet) but the oem radio did have aux/usb on the console. There is a SAT antenna on the back roof and I am unsure where the antenna is located (rear windshield maybe)? The OEM radio had of course AM/FM/SAT working when I purchased the car but I think I have overlooked something when I installed the Kenwood. I have connected the blue wires (from the OEM harness to the AFM radio harness) and have purchased a metra 40-Ki10 connection to adapt the AFM radio to the OEM antenna. The OEM antenna connection has two wires feeding the connector but the metra connector only has one plug exiting the connector and this is the male RCA type plug that plugs directly to the Kenwood radio. I am thinking that my issue is with this connection somehow.

Any suggestions, comments, thoughts would be appreciated. Thank you
This might help.
Attached Files
File Type: pdf audio.pdf (907.8 KB, 926 views)
HavasuPaPa is offline  
post #3 of 5 (permalink) Old 03-18-2014, 10:38 AM Thread Starter
Newbie
 
Join Date: Dec 2009
Location: Haverhill Ma
Posts: 8
Drives: 2009 Kia Borrego, LX
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Thread Starter (Thread Starter)
This is an awesome all in one document. While I found sections of this document on METRA and from KGIS (owners tech support), there is some additional detail here that I haven't seen before (and would have come in handy when I was removing door speakers and trim panels to replace the OEM subwoofer)..Thank you for taking the time to locate this document (or put it together) although specifically this doesn't address my specific issue which is the antenna connection (all the diagrams show one wire feeding the connector) and my connection has two...

Regardless, thank you for the attachment, I have saved this for future reference. Its much appreciated..
mtbikerejg is offline  
 
post #4 of 5 (permalink) Old 07-14-2014, 11:19 AM
Newbie
 
Join Date: Jul 2010
Posts: 3
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Hi there,

I have there same issue with the antenna connection, no AM but FM works fine. one of the antennas is located in the rear passenger side window, the roof antenna is apparently dual, GPS AM/FM.

It appears that the factory AM/FM antenna has two cables, the original KIA head unit has one connector but with both cables going into it and as you have already stated the Metra antenna adapter apparently uses only one of the two original cables. Maybe that's where we are having difficulty.

Your thoughts and good luck.
manxman is offline  
post #5 of 5 (permalink) Old 09-01-2014, 09:48 AM
Newbie
 
Join Date: Jul 2010
Posts: 3
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Were you ever able to get a definite answer on the two versus one antenna connection?

I did some investigating on my Borrego LX antenna. took things apart, one antenna cable comes from the roof antenna (the other is Sirius and completely different) and the other comers from the antenna mounted in the rear passenger side window, The roof antenna has a power connection.
manxman is offline  
Reply

  Kia Forum > KIA Models > Kia Mohave & Borrego



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
radio antenna problem vroomvroom 2003-2010 Sorento Forum 1 05-18-2016 07:42 AM
Aftermarket radio Daniel Negron 2G (2003-2010) Sportage 2 08-05-2015 02:53 PM
Aftermarket Radio - Any Luck? gumbyjunior1 Kia Forte/Cerato (TD) and Koup Discussion Forum 7 10-05-2009 06:38 PM
Radio antenna in rear window problems N106FM Kia Magentis & Optima Forum 0 06-22-2007 08:06 PM
Aftermarket Radio in 03 Spectra LX Fixxxer Shuma & Spectra (1997-2003) 2 08-27-2006 09:50 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On