HELP- check engine light P0018 - Kia Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 02-14-2014, 04:51 PM Thread Starter
rb2
Newbie
 
Join Date: Apr 2011
Posts: 7
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
HELP- check engine light P0018

My check engine light is on and my Borrego has been at the Kia dealer for over a month. It started after a routine tune up an oil change.
They replaced the sensors mentioned under the trouble code P0018 but the check engine light remains on. Kia replaced the main computer and the light still remains on. Besides the obvious, changing what the below details say, anyone run into this error code and ended up being something totally unrelated???


P0018 KIA - Crankshaft/Camshaft Correlation Error Bank 2 Sensor 1

Read more: P0018 KIA Crankshaft/Camshaft Correlation Error Bank 2 Sensor 1 OBDII Engine Light Trouble Code | Engine-Codes.com

rb2 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 02-14-2014, 08:18 PM
Full Member
 
Join Date: Jan 2014
Location: Milton, ontario
Posts: 97
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)

If it's the V6 I have seen stretched timing chains and faulty CVVT's cause these types of codes. The techs need to back probe the cam and crank sensors with an occiliscope and compare the readings.
Madwrench is offline  
post #3 of 7 (permalink) Old 02-14-2014, 09:14 PM
Veteran
 
Join Date: Mar 2010
Location: Southwest PA
Posts: 1,412
Drives: 10 Optima LX, 07 Rondo EX, 89 Chevy C1500
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)

Another thing that could set this DTC is low oil pressure. Check the oil filter cap to see if the post is still attached, and the that the small o-ring on the post is there.

I have also seen aftermarket cartridge oil filters cause this. I had one customer with a V6 Borrego come in twice, both times right after he had an oil change done aftermarket(he wouldn't say where). I installed the Kia filter, the code cleared, and he didn't come back until the after next time he had the oil changed. I changed it again, the code cleared, and I haven't seen him since.

You would assume it would set codes for both banks, but it only set one. This threw me off and had me doing all kinds of checks and tests until I got the whole story about it not happening till right after an oil change.

Last edited by spongebob218; 02-14-2014 at 09:21 PM.
spongebob218 is offline  
 
post #4 of 7 (permalink) Old 02-21-2014, 03:44 PM Thread Starter
rb2
Newbie
 
Join Date: Apr 2011
Posts: 7
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Just wanted to thank the two members for the responses.
update: Dealership has been unable to fix issue. Kia is flying in an engineer to help.
rb2 is offline  
post #5 of 7 (permalink) Old 05-01-2015, 08:52 PM
Newbie
 
Join Date: May 2015
Posts: 1
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

So what were the results of the engineer coming in? I'm having the same issue. The dealership replaced the OCV Valves today. The light came back on. I'm dreading that it's gonna be way more than we can afford. The vehicle has 103,000 miles on it. It ran like a top for all 100,000 miles. Had a some warranty work done on it at about 96,000 miles. Dealership did not do an oil change. And now the V6 Borrego runs like garbage. It's past NYS inspection and I can't get by this p0018 error code.

Please help!!!
jreddout is offline  
post #6 of 7 (permalink) Old 01-05-2016, 04:46 PM
Newbie
 
Join Date: Jan 2016
Location: Jeannette Pa
Posts: 1
Drives: 2009 Borrego
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

My Borrego check engine light came on around 45,000 miles and when I took it in the replaced the cams. It came back on recently at 92,000 and it was the cams again. Took it to the dealer and they replaced them again. When I got it back it seemed to run rough like it was missing. Christmas Eve my daughter was using it and the light came on again and was flashing. She told me it was like driving a tank. She made it home and I had it towed back to the dealer. It was the cams again. Just got it back after Christmas and it was still running rough. Took it back to the dealer 1-4-2016 and was told it was going to run that way because the new cams self adjust to the timing. So I went back home and on my way home from work this morning check engine light flashing and was driving like a tank. Took it back in and they have it torn apart again. Me and my wife love the vehicle and the dealer has jumped through hoops. Just wish the manufacturer could address the issue and fix the problem. We don't want to trade it but if it continues we have no other option
beech360 is offline  
post #7 of 7 (permalink) Old 01-05-2016, 05:36 PM
Full Member
 
Join Date: Jan 2014
Location: Milton, ontario
Posts: 97
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)

Sounds like your dealership has no idea what they are doing. What exactly was replaced?
Madwrench is offline  
Reply

  Kia Forum > KIA Models > Kia Mohave & Borrego



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List




  Similar Threads
Thread Thread Starter Forum Replies Last Post
Check Engine Light On....Because? palebeachbum 3G (2006.5+) Magentis & Optima 10 09-11-2009 02:20 PM
check engine light hotrodhenson Kia Cerato, Shuma & Spectra Forum 5 06-03-2009 09:06 PM
3 week old Kia Rio 2009 - check engine light Janye 2G (2006 - 2011) Rio & Rio5 14 04-07-2009 05:51 PM
Flashing O/D + Check Engine Light kiaSephiaUser2008 2G (1998 - 2001) Sephia 2 02-25-2008 09:22 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On