Passenger Air Bag light issue - Kia Forum

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 07-06-2008, 09:50 PM Thread Starter
Newbie
 
Join Date: Jun 2008
Posts: 4
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Exclamation Passenger Air Bag light issue

Have a 2008 Optima, less than 2500 miles on it. Today I noticed that when my wife was sitting in the passenger seat, the dash light indicated "Passenger Air Bag OFF". I pulled over and restarted the car it and went off. I had a Chevy Aveo that had this EXACT same problem and the dealer could not/would not fix it. Incidentally, my wife is 5'6" and about 150 lbs. Anyone else out there with a 2008 Optima LX ever see this? I know it was a common problem with the Aveo - but again? On a Kia Optima LX? HELP!

gjc866 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 07-06-2008, 09:58 PM
Senior Member
 
Join Date: Feb 2008
Posts: 209
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

she was probably not sitting upright and how the owners manual says she should. i have seen that alot. the customer complains of passanger airbag light not working i get in and sit upright in the correct posistion and then it turns off. im not saying there is nothing wrong but im just throwing that out as a suggestion
TEXKIATECH is offline  
post #3 of 8 (permalink) Old 07-06-2008, 10:12 PM Thread Starter
Newbie
 
Join Date: Jun 2008
Posts: 4
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Question Not sitting upright?

Huh? I don't mean to be a smart ass but she was sitting in it -normally- not with her head down or leaning to one side. I even had her move around -lean with back straight, shift weight from side to side and the light never went off. It immediately corrected itself when I turned the engine off and restarted it. She never got out of the car or switched positions in the seat. The only thing that changed was that the car was restarted.
gjc866 is offline  
 
post #4 of 8 (permalink) Old 07-07-2008, 12:32 AM
Senior Member
 
Join Date: Feb 2008
Posts: 209
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

ok then it is probably the sensor or a lose connection
TEXKIATECH is offline  
post #5 of 8 (permalink) Old 07-07-2008, 01:16 AM
Expert
 
Raven1210's Avatar
 
Join Date: Feb 2006
Location: Toronto Ontario
Posts: 968
Drives: 1999 Acura Integra
Gallery: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

My acura 1.7EL has side airbags in the seats. If I put a little bit of weight where the airbag is for a second my passenger airbag light comes on. It just helps if you get in a T bone accident. You don't want that airbag to blow when your mm's away from it.
Raven1210 is offline  
post #6 of 8 (permalink) Old 07-07-2008, 08:11 AM Thread Starter
Newbie
 
Join Date: Jun 2008
Posts: 4
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Okay - will try and thank you!

txkiatech, thanks. I reviewed the manual and didn't realize there was almost 4 pages dedicated to the airbag system operation. It clearly indicates that if you aren't in the right spot initially it might not recognize a passenger is present in the seat. Raven1210, also appreicate your input with this.
gjc866 is offline  
post #7 of 8 (permalink) Old 07-07-2008, 12:52 PM
Newbie
 
Join Date: May 2008
Posts: 16
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Our 2007 intermittantly does the same thing. If I don't reposition myself reasonably soon after the car was started, the light will stay on. We also learned that turning it(The car) on and off seems to reset the airbags. I now just try to make a point of getting in and sitting with my feet flat on the floor and clicking the seat belt, and we have had much fewer times where the light won't go off.
Floorslayer is offline  
post #8 of 8 (permalink) Old 07-17-2008, 01:57 PM
Newbie
 
Join Date: Aug 2006
Location: North Charleston, SC
Posts: 13
Drives: 2008 Kia Optima 2.4l
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Send a message via Yahoo to Reno
Talking Same issue with 1 month old 08 Optima

I have the same issue with my 08 Optima. I have had the car for a little bit over 1 month. It seems like it is 50/50 if the light will go out or not. I figured it was because the seats are still stiff and the problem would go away when the seats are broken in. I'll let you know if the problem goes away in a few months.
Reno is offline  
 

  Kia Forum > KIA Models > Kia Magentis & Optima Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
KIA Fog Light LED Bulbs! Plug & Play Install! Upgrade your lights! Diode Dynamics Diode Dynamics 39 06-21-2018 05:28 PM
2007 Kia Amanti Brake Light Issue chudson17 1G Kia Amanti & Opirus Forum 3 03-28-2018 10:03 PM
Light bulbs for 06 Sedona Repsolal Kia Carnival & Sedona 2006+ 2 12-17-2008 10:44 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On