Help! Weird rubbing/screeching on acceleration - Kia Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-12-2019, 02:45 PM Thread Starter
Newbie
 
Join Date: Jun 2019
Location: East Coast USA
Posts: 1
Drives: 2010 Kia Forte Ex
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Help! Weird rubbing/screeching on acceleration

So I've got an obnoxious problem I cannot figure out.
When I'm accelerating, there's a crazy loud screeching noise coming from what I think is the engine bay, but it could be wheel well related? I'm not super car-savvy so I'm not sure, that's just what I've heard.

I just bought my 2010 Kia Forte Ex used and had it inspected, the front brakes were replaced (among other things like part of the exhaust) and I also asked them to look into the screeching but they didn't find anything or tell me anything about it.

The strangest part is that while in neutral/park and I rev the engine, the noise isn't there. Or if it is, it's too quiet for me to hear it. I doubt it is too quiet, however, as I can hear it while accelerating with the windows down (and up) while driving.

I've read that most screeching noises come from the Idler Pulley or the AC Compressor Pulley? I'm not sure why either of those would only screech on acceleration though. I know literally nothing about Kias (more of a Saab guy) so any help would be appreciated.

Thanks

gnidem is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 06-12-2019, 04:10 PM
Full Member
 
Join Date: Jan 2019
Location: Oak Island N.C.
Posts: 76
Drives: 2007 Rondo and 2000 Tacoma
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)

First off I’d get a piece of garden hose ( or similar tubing) and use it as a stereoscope and listen carefully to each moving part while idling.

Just a guess but maybe it’s the serpentine belt....possibly at idle the alternator and power steering are not under as much load as when going down the road.
Old ní slow is offline  
Reply

  Kia Forum > KIA Models > Kia Forte/Cerato (TD) and Koup Discussion Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On