2009 Spectra battery and e-brake indicator lights on at same time - Kia Forum

 1Likes
  • 1 Post By DavesSpectra
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 10-14-2018, 03:50 PM Thread Starter
Newbie
 
Join Date: Oct 2018
Location: Rome Georgia
Posts: 2
Drives: 2009 Kia Spectra
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
2009 Spectra battery and e-brake indicator lights on at same time

Hi all,

Recently my battery light and e-brake light came on at same time; they remain on while engine is running (at one time they both went out but moments later they BOTH came back on at-the-same-time). I've been driving for about a week light this and the engine starts up fine. Brake fluid level is fine, alt belt is tight - battery is about a month old. Kia has 230,000 miles on it - has been a great car.

I figured I'd remove the 6 screws holding the console in and directly check the e-brake switch - figured maybe after 10 years it's broken. Not much of a "switch"; just one little white wire going to a contact - is that all there is to it? I checked the switch and it is being engaged by the handle (there is no adjustment for the switch position); even removed the switch from the bracket and manually activated it - light stays on. Checked codes - none present.

Anybody had this or heard of it? I figured I really need to get it fixed before it leaves me stranded. Attached is a picture of this "switch"; hopefully it came through.

Attached Thumbnails
Click image for larger version

Name:	switch.JPG
Views:	26
Size:	32.5 KB
ID:	103030  
realoldman is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 10-16-2018, 10:35 AM Thread Starter
Newbie
 
Join Date: Oct 2018
Location: Rome Georgia
Posts: 2
Drives: 2009 Kia Spectra
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
What a plethora of fine responses by caring and knowledgable individuals!! I'm certainly glad I signed up for this!!

Seriously, since there was no response, my car quit on me yesterday - had to have it towed off expressway to a local shop - walked out after having to pay them $504.00 (a third of what I make a month on social security)! Thanks guys.

Since nobody helped me or replied to message, I'll answer it myself. Replace the alternator; all is well now.

Have a nice week guys.
realoldman is offline  
post #3 of 4 (permalink) Old 10-16-2018, 01:32 PM
Veteran
 
Join Date: Sep 2016
Location: USA,WESTERN NY
Posts: 1,756
Drives: 09 kia spectra ex,04 Neon,04 Chry. T&C, 98 Avenger
Gallery: 0
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 364 Post(s)

Sorry to hear that it "died" out on the road on you, The way you posted of going at brake warning light switches made it seem like you would not accept a simple response of TEST for charging voltage. The alternator is the heart of the electrical system, not the battery which works with it. Yup you drained out the battery by continued running with it.
MIA KIA 09 is offline  
 
post #4 of 4 (permalink) Old 10-16-2018, 01:43 PM
Super Moderator
 
DavesSpectra's Avatar
 
Join Date: Jan 2010
Location: Massillon, Ohio, USA
Posts: 6,745
Drives: 2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Gallery: 0
Mentioned: 22 Post(s)
Tagged: 2 Thread(s)
Quoted: 452 Post(s)

realoldman...
We are not a "pay for" answer site... We are a bunch of people just like you that own KIAs and don't sit and wait for questions... Please note that what we post may sound like we are attacking you... This is NOT the case...There is no intonation in most text and things can be taken wrong...

I just checked in today and found your post... Usually when the ebrake and battery light come on at the same time I have found that the battery voltage or the charging system are at fault (as you also found)...

The "brains" that control the engine/transmission/and body functions do not work well under low voltage conditions...

A one time post and a need for an immediate response usually won't work here as you found... but... It doesn't work on most forums... We do care about our members and "if" we are present and have a good guess we will post...

A new alternator for your 2009 Spectra would have cost you under $125 on ebay and with some basic tools you could have replaced it yourself... I have a 2008 Spectra that caused me charging problems and I found that the ground wires located under the battery tray and attached to the frame/body caused my charging problems...my alternator was putting out only 12.1 volts... A voltage drop between the alternator frame and the negative terminal of 2.7 volts made the internal voltage regulator to operate at 12.1 volts (12.1v plus 2.7v =14.8v)... cleaning the frame/wire lugs/and bolts and applying silicon grease solved the low charging voltage...

This problem IS very common on the 2007~2009 Spectras and many alternators and batteries get replaced because of mis-diagnosis..I hope your repair cures the problem...
Dave
ron1004 likes this.
DavesSpectra is offline  
Reply

  Kia Forum > KIA Models > Kia Cerato, Shuma & Spectra Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
2009 Sedona battery won't charge properly Rjdon13 Kia Carnival & Sedona 2006+ 1 07-10-2017 07:10 PM
2009 Spectra, No AC, no power windows after crossing battery connection batperez Kia Cerato, Shuma & Spectra Forum 2 09-08-2015 10:12 PM
Battery and Parking brake light keep flashing 1quicksilver 2G (1998 - 2001) Sephia 1 09-14-2009 03:55 PM
alternator problem = no brakes?? ten45 Kia Carnival & Sedona (2002 - 2005) 10 08-13-2007 01:46 AM
02 Cinco headlights dim while driving zfmrchnt 1G (2001-2005) Rio 2 03-19-2007 02:01 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On