New code challenge..P0011 - Kia Forum

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 06-11-2017, 07:02 AM Thread Starter
Veteran
 
Join Date: Sep 2016
Location: USA,WESTERN NY
Posts: 1,744
Drives: 09 kia spectra ex,04 Neon,04 Chry. T&C, 98 Avenger
Gallery: 0
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 364 Post(s)

Thread Starter (Thread Starter)
New code challenge..P0011

Well the little spectra has wanted more attention again. daughter came home from work Friday and said that the CEL was back(rather angrily)! went and scanned it and found this code. Knowing of the POOR maint. this little car had before we got it, I will be taking out the CVVT solenoid and checking for oil sludging in it and the port in the cylinder head. Car runs fine and NO troubles there, but motor oil was always horrible black and nasty of the 4 previous changes I have done. So far on the current oil and filter the oil still looks like new with a little over 1 thousand miles on it. Will keep all informed here as to what I find(when I can pry the car from daughter AGAIN). And yes it has 10k been put on it since getting it in 10/16, and been using conventional oil, due to not knowing its previous history(Moil Super 10-30).

MIA KIA 09 is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 06-11-2017, 11:54 AM
Veteran
 
aquanaut20's Avatar
 
Join Date: Jun 2010
Location: Fraser Valley, BC, Canada
Posts: 2,696
Drives: Caribou, Otter, Buffalo
Gallery: 0
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 251 Post(s)

You may need to use a professional scan tool to check the duty cycle of the solenoid. 2 way comms function, comparing demanded %, vs actual.

FWIW, I have cured a couple with Shell T6 10W30 (high detergent), But that would be conclusive only if sticky..

... Philip
aquanaut20 is offline  
post #3 of 15 (permalink) Old 06-11-2017, 12:49 PM Thread Starter
Veteran
 
Join Date: Sep 2016
Location: USA,WESTERN NY
Posts: 1,744
Drives: 09 kia spectra ex,04 Neon,04 Chry. T&C, 98 Avenger
Gallery: 0
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 364 Post(s)

Thread Starter (Thread Starter)
Have been VERY happy with the Mobil for ALL of my "ponies" in our "stable", as the Spectra is #5 in the "stalls"..LOL

I rather trust a mechanical issue in the solenoid(sludge chunk) or possible wire end connection inside the plastic plug end for the solenoid as to be at issue here on this car, I know it is not a TB concern as I recently checked that after rains interrupted doing the belt and H2O pump replacement that is planned for it. This car did not have much care given it by previous owners, That is NOT the case now! But to be honest, I still prefer my MOPARS.
THANKS for the input, and I will post my findings.
MIA KIA 09 is offline  
 
post #4 of 15 (permalink) Old 06-12-2017, 08:33 AM Thread Starter
Veteran
 
Join Date: Sep 2016
Location: USA,WESTERN NY
Posts: 1,744
Drives: 09 kia spectra ex,04 Neon,04 Chry. T&C, 98 Avenger
Gallery: 0
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 364 Post(s)

Thread Starter (Thread Starter)
Friday when this happened, I cleared the code out, and then daughter went away for the weekend and put 150 miles on it. This a.m. there were no recurring codes. Will R&R and check the oil passages in the CVVT solenoid and head when she gets home from work this evening...STAY TUNED!
MIA KIA 09 is offline  
post #5 of 15 (permalink) Old 06-12-2017, 06:50 PM Thread Starter
Veteran
 
Join Date: Sep 2016
Location: USA,WESTERN NY
Posts: 1,744
Drives: 09 kia spectra ex,04 Neon,04 Chry. T&C, 98 Avenger
Gallery: 0
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 364 Post(s)

Thread Starter (Thread Starter)
Well here is the VERDICT: Removed the CVVT solenoid and the bottom end had a fair amount of sludge and the pistons in the solenoid had a fairly heavy coating of shellac build up. Gave the motor a few spins to push out any sludge from the head area and soaked and cleaned the solenoid pistons and body. Put it back together and test drove it. Running FINE and live data looks good to go! No codes after 210 miles since it was last cleared on Friday. And yes I did clean up the minor oil spillage from the motor, need to keep things clean and pretty you know!
MIA KIA 09 is offline  
post #6 of 15 (permalink) Old 07-05-2017, 08:36 PM Thread Starter
Veteran
 
Join Date: Sep 2016
Location: USA,WESTERN NY
Posts: 1,744
Drives: 09 kia spectra ex,04 Neon,04 Chry. T&C, 98 Avenger
Gallery: 0
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 364 Post(s)

Thread Starter (Thread Starter)
Well the problem has just started returning... Finally found the screen in the head for the system(on the end,low near the block and the 2 radiator hose route above and below the bolt head (14mm wrench). Was not clogged with "chunks", but the very fine mesh screen looked varnished over. carb cleaner sprayed and soaked it and reinstalled it. will see how the daughter reports over the next few days. Oh and it is due AGAIN for a shorter miles oil and filter change this weekend, has 3500 mile on it already! At least the oil still looks like oil and NOT black and nasty looking!

Last edited by MIA KIA 09; 07-05-2017 at 08:39 PM.
MIA KIA 09 is offline  
post #7 of 15 (permalink) Old 07-17-2017, 05:42 PM Thread Starter
Veteran
 
Join Date: Sep 2016
Location: USA,WESTERN NY
Posts: 1,744
Drives: 09 kia spectra ex,04 Neon,04 Chry. T&C, 98 Avenger
Gallery: 0
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 364 Post(s)

Thread Starter (Thread Starter)
Well Eleven days and NO return of the code. Car running fine!
MIA KIA 09 is offline  
post #8 of 15 (permalink) Old 08-01-2017, 06:36 PM Thread Starter
Veteran
 
Join Date: Sep 2016
Location: USA,WESTERN NY
Posts: 1,744
Drives: 09 kia spectra ex,04 Neon,04 Chry. T&C, 98 Avenger
Gallery: 0
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 364 Post(s)

Thread Starter (Thread Starter)
08/01/17 UPDATE:
NO problems at all with this code!
MIA KIA 09 is offline  
post #9 of 15 (permalink) Old 11-26-2017, 07:59 AM Thread Starter
Veteran
 
Join Date: Sep 2016
Location: USA,WESTERN NY
Posts: 1,744
Drives: 09 kia spectra ex,04 Neon,04 Chry. T&C, 98 Avenger
Gallery: 0
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 364 Post(s)

Thread Starter (Thread Starter)
UPDATE: Still no return of this code problem, and motor oil still looks like motor oil and not black!
MIA KIA 09 is offline  
post #10 of 15 (permalink) Old 11-26-2017, 10:11 AM
Veteran
 
aquanaut20's Avatar
 
Join Date: Jun 2010
Location: Fraser Valley, BC, Canada
Posts: 2,696
Drives: Caribou, Otter, Buffalo
Gallery: 0
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 251 Post(s)

Cheers, still keeping an eye on you...

... Philip
aquanaut20 is offline  
Reply


Top

  Kia Forum > KIA Models > Kia Cerato, Shuma & Spectra Forum



Currently Active Users Viewing This Thread: 2 (0 members and 2 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
2008 Mass Air Flow Sensor Code P0102 KiaGlock&Jacoby 2003-2010 Sorento Forum 1 08-11-2017 12:31 PM
07 Spectra Code P0011 JonV Kia Cerato, Shuma & Spectra Forum 7 03-23-2017 09:03 PM
2011 Forte SX P0017 Code Impaqt Kia Forte/Cerato (TD) and Koup Discussion Forum 0 08-17-2016 11:52 PM
Just bought A Code Reader! Actron Autoscanner CP9670 2012kiario5owner 3G (2012 - 2017) Rio 6 12-25-2015 12:56 AM
P0133 code and cracked exhaust manifold slydog 2G (1998 - 2001) Sephia 7 07-26-2010 10:39 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On