Turn signal issues - Kia Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 10-22-2018, 05:12 PM Thread Starter
Full Member
 
sega626's Avatar
 
Join Date: Aug 2015
Location: South Carolina
Posts: 120
Drives: 2015 Kia Sedona SX, 2012 Mazda6i Touring
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 35 Post(s)
Garage

Thread Starter (Thread Starter)
Turn signal issues

Has anyone else had issues with their turn signal not working correctly? Specifically at random times when I press down on the stalk to turn left, the signal will not start flashing. I have to flip it back up and down again or press down just a bit more to get it to start blinking. It only does it on left turns. Even on lane change as well.


2015 Sedona SX Venetian Red/Camel
sega626 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 10-30-2018, 12:38 PM
Full Member
 
Join Date: Jun 2018
Location: Atlanta, GA, USA
Posts: 153
Drives: '14 Cadenza SX-L '16 Sedona SX
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 33 Post(s)

I have that also, on rare occasions. I figured I just wasn't pressing it down far enough. It's infrequent enough that it's not really a problem, but it is a distraction because every time I put on the left blinker, I check the dash to see if it's blinking.
Kia-Driver is offline  
post #3 of 6 (permalink) Old 06-28-2019, 12:04 PM
Newbie
 
Join Date: Jun 2019
Location: San Jose, CA
Posts: 1
Drives: Kia Sedona SXL 2016
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

I have started to have the exact same issue on my left turn signal only. If I flip it back up and down, then yes it will eventually work again. But it has becoming annoying. And I am one of the people that hates it when the person in front of me doesn't signal on their turn, so I don't want to do that to people behind me.

Did either of you guys or anyone else on this forum figure out the issue with the blinker?

Thank you.
SedonaML is offline  
 
post #4 of 6 (permalink) Old 06-28-2019, 01:50 PM
Full Member
 
Join Date: Jun 2018
Location: Atlanta, GA, USA
Posts: 153
Drives: '14 Cadenza SX-L '16 Sedona SX
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 33 Post(s)

No I never followed up on it. It still happens on occasion, but not enough of a bother to make me replace it.

2014 Kia Cadenza
2016 Kia Sedona
Kia-Driver is offline  
post #5 of 6 (permalink) Old 07-03-2019, 02:07 AM
Member
 
Penetronn's Avatar
 
Join Date: Apr 2016
Location: Laurel, MD
Posts: 31
Drives: 2008 Ford Fusion SEL / 2016 Kia Sedona SX
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)

Yes, this is definitely happening on my '16 SX. Left turns only. Anyone else tow with their Sedona? Seems to happen most often the first or second trip after I've towed our trailer and then disconnected the 4 pin wiring connection.
Penetronn is offline  
post #6 of 6 (permalink) Old 07-03-2019, 08:15 AM
Member
 
Join Date: Aug 2018
Location: Boston
Posts: 51
Drives: '15 Kia Sedona SX
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)

Quote:
Originally Posted by Penetronn View Post
Left turns only.
Well, as they say, while two wrongs don't make a right, three lefts do...
darisgin is offline  
Reply

  Kia Forum > KIA Models > Kia Carnival & Sedona Forum > Kia Carnival & Sedona 2015+



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn signal issues. GabbiD 2011 - 2013 (XM) Sorento Forum 6 03-31-2019 09:10 PM
2008 Sedona - Turn Signal Connector kiamipjh Kia Carnival & Sedona 2006+ 1 05-21-2018 04:27 PM
Turn Signal issues with 2008 Optima joshw72381 3G (2006.5+) Magentis & Optima 1 10-24-2017 06:02 PM
Turn signal relay problem? mlawrence17 Kia Carnival & Sedona (2002 - 2005) 1 03-03-2016 10:09 AM
Turn Signal Woes.. sauce1187 2G (1998 - 2001) Sephia 4 03-16-2009 09:45 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On