2014 Kia Sedona with Infiniti sound system (no sound with aftermarket stereo) - Kia Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 06-23-2019, 09:04 PM Thread Starter
Newbie
 
Join Date: Sep 2014
Location: Wisconsin
Posts: 2
Drives: sedona 2014
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Question 2014 Kia Sedona with Infiniti sound system (no sound with aftermarket stereo)

I am attempting to install an aftermarket stereo (Pioneer AVH-4200NEX) with a Maestro RR steering wheel control unit.

The head unit powers on just fine when I start the car, but I am having two issues

1) I get no sound out of the speakers at all. When I press volume up or down I hear a beep coming from the head unit itself, but nothing coming out of the speakers.

2) the steering wheel controls only work sometimes. When they stop working a message shows up on the screen stating that the maestro isn't working and to check it's connections.

From the googling I've done it sounds like #1 could be an amp issue. Is there a built in amp in this trim level?

Any help someone could provide would be greatly appreciated.

Snarf

snarfsmojo is offline  
Reply

  Kia Forum > KIA Models > Kia Carnival & Sedona Forum > Kia Carnival & Sedona 2006+



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On