Intermittent Stalling No Start Air Conditioner Electrical Gremlin Ghost Kia Sedona - Kia Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 05-04-2018, 12:01 PM Thread Starter
Member
 
jsinton's Avatar
 
Join Date: Sep 2012
Location: Inverness, Florida
Posts: 48
Drives: 1999 Hyundai Elantra Wagon, 2003 Kia Sedona, 2012 Kia Sedona, 2007 Hyundai Tucson
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Thread Starter (Thread Starter)
Intermittent Stalling No Start Air Conditioner Electrical Gremlin Ghost Kia Sedona

Hello all! Have I got a post for you. Probably you want to make a sticky out of this.

Is your Kia Sedona family road-barge experiencing weird intermittent electrical problems? Does it stall for no apparent reason? Does the air conditioner do weird things like shut off on “high”? Do the headlights dim, the battery acts like its bad, and the starter won't turn, then wait a while and it starts like nothing happened?

Yes, I've seen these problems. I have a 2003 Kia Sedona AND a 2012 Kia Sedona. BOTH of my cars have this problem. My 2003 failed to start 50 miles from anywhere in Northwoods Maine, and my 2012 likes to die going down the road when I drive my Mom around with AC blasting.

THE PROBLEM IS CAUSED BY INSUFFICIENT GROUNDING OF THE MOTOR TO THE BATTERY.

This was a known problem that I was aware of on the Hyundai XG350, which shared nearly the same drivetrain with the early Sedonas, I believe there was a Hyundai recall. My guess is this problem is also found on Hyundai Santa Fe with 3.5 V6, Kia Amati, and other cars which share this motor.

On 2012 Kia Sedona ( and probably all models) there are cheesy little ground wires that connect the battery to the body, and the body to the engine. I believe the Sedona, being the electricity hog it is, is gets insufficient grounding when the threads on the attaching bolts to the body get a little corrosion.

The cost-free fix is to identify the ground connections to the body and disconnect them, grind the paint off the surface of the body where the connector contacts, clean up the bolt and the wire connector, put it back together, and maybe smear it with some die-electric grease. That should eliminate the problem.

An even BETTER fix, but could cost a few pesos, is get yourself a piece of negative battery cable and create a new ground independent of the cheesy grounds. Simply bolt the battery cable from the negative terminal on the battery to a solid bolt on the motor, preferably the intended grounding bolt on the motor. This is on the other side of the motor from the battery, so I used a six foot piece of cable that cost $22. Instant relief. It's still a good idea to clean up those grounds on the body even if you use a battery cable.

Good Luck!



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jsinton is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 05-04-2018, 12:18 PM
Super Moderator
 
ron1004's Avatar
 
Join Date: Jun 2005
Location: USA
Posts: 8,437
Drives: 1999 Kia / 기아 Elan, 2017 Ford Edge Sport, 2015 Ford Mustang, 2008 Harley Nightrain
Gallery: 13
Mentioned: 18 Post(s)
Tagged: 0 Thread(s)
Quoted: 704 Post(s)
Garage

This is a fairly common issue and seems to be more prevalent with the older Sportage models.

The grounding between battery and chassis, engine to chassis, and once cleaned and tightened you could use grease or I prefer to spray it with battery terminal spray.

Quality and not quantity counts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Sig image is 500X100 at 11.7 kb
ron1004 is offline  
post #3 of 3 (permalink) Old 05-04-2018, 12:55 PM Thread Starter
Member
 
jsinton's Avatar
 
Join Date: Sep 2012
Location: Inverness, Florida
Posts: 48
Drives: 1999 Hyundai Elantra Wagon, 2003 Kia Sedona, 2012 Kia Sedona, 2007 Hyundai Tucson
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Thread Starter (Thread Starter)
Interesting. I also have a 2007 Hyundai Tucson, so I'll have to check that out.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jsinton is offline  
Reply

  Kia Forum > KIA Models > Kia Carnival & Sedona Forum > Kia Carnival & Sedona 2006+



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
2002 Sedona will not start danged Kia Carnival & Sedona (2002 - 2005) 3 11-16-2009 05:34 PM
Sedona 03 stalling problem makiadriver Kia Carnival & Sedona Forum 4 10-04-2009 09:33 AM
wet sedona wont start 93fxdl Kia Carnival & Sedona Forum 0 10-25-2008 07:35 AM
problems with 07 sedona - stalling and computer candi33 Kia Carnival & Sedona Forum 5 08-13-2008 11:14 PM
my sedona wont start :( clartsonly Kia Carnival & Sedona (2002 - 2005) 3 07-28-2006 04:50 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On