Kia Sedona won't start when temp outside is hot - Kia Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-16-2018, 04:32 PM Thread Starter
Newbie
 
Join Date: Jun 2018
Location: Aurora, CO
Posts: 1
Drives: Kia Sedona 2005
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Thread Starter (Thread Starter)
Kia Sedona won't start when temp outside is hot

Have a 2005 Kia Sedona with a new used engine just put in and a new A/C system. Since then the car cranks but will not start when the temperature outside is hot (it's been mid to upper 90's here. Never had the problem with old engine. Mechanics are baffled. They have replaced O-2 sensors, thermostats. When the engine is in their covered shop the car cools down and it will start as it will start in the morning when I leave to go to work. Battery is fine, starter is fine. It reminds me of the old days when I would maneuver the choke to get the right amount of fuel in. You can try cranking it 3 o4 times (sometimes 5-7 times) and then it will start.

The code right now is reading a transmission sensor needs checking but I'm thinking that wouldn't make it not start. I could be wrong.

Any suggestions I can take to the mechanics would be appreciated.

Doc Kathy

kathleenhaley is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-16-2018, 04:36 PM
Super Moderator
 
ron1004's Avatar
 
Join Date: Jun 2005
Location: USA
Posts: 8,437
Drives: 1999 Kia / 기아 Elan, 2017 Ford Edge Sport, 2015 Ford Mustang, 2008 Harley Nightrain
Gallery: 13
Mentioned: 18 Post(s)
Tagged: 0 Thread(s)
Quoted: 704 Post(s)
Garage

Exclamation Update user CP with location, vehicle model and year

Quote:
Originally Posted by kathleenhaley View Post
Have a 2005 Kia Sedona with a new used engine just put in and a new A/C system. Since then the car cranks but will not start when the temperature outside is hot (it's been mid to upper 90's here. Never had the problem with old engine. Mechanics are baffled. They have replaced O-2 sensors, thermostats. When the engine is in their covered shop the car cools down and it will start as it will start in the morning when I leave to go to work. Battery is fine, starter is fine. It reminds me of the old days when I would maneuver the choke to get the right amount of fuel in. You can try cranking it 3 o4 times (sometimes 5-7 times) and then it will start.

The code right now is reading a transmission sensor needs checking but I'm thinking that wouldn't make it not start. I could be wrong.

Any suggestions I can take to the mechanics would be appreciated.

Doc Kathy
Welcome.

I would suggest you find a good mechanic, or a Kia service center.

What code is coming up?

Quality and not quantity counts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Sig image is 500X100 at 11.7 kb

Last edited by ron1004; 06-16-2018 at 05:59 PM.
ron1004 is offline  
post #3 of 3 (permalink) Old 06-16-2018, 06:30 PM
Full Member
 
Join Date: Sep 2012
Location: Cincinnati OH, USA
Posts: 95
Drives: KIA Sedona 2005 EX 3.5L Automatic
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)

May want to try changing the CPS (crankshaft position sensor). Common problem with a failing CPS is what you are describing (does not start when hot but ok when cold).
Gidner is offline  
Reply

  Kia Forum > KIA Models > Kia Carnival & Sedona Forum > Kia Carnival & Sedona (2002 - 2005)



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Intermittent Stalling No Start Air Conditioner Electrical Gremlin Ghost Kia Sedona jsinton Kia Carnival & Sedona 2006+ 2 05-04-2018 12:55 PM
Test drove a new 2018 Honda Odyssey today! Thoughts vs Sedona and Pacifica SWSedonaSX-L Kia Carnival & Sedona 2015+ 20 09-06-2017 09:36 AM
2005 Kia Sedona - No Start / No Crank, Alarm TomInPA Kia Carnival & Sedona (2002 - 2005) 1 11-01-2015 08:12 AM
2002 Sedona will not start danged Kia Carnival & Sedona (2002 - 2005) 3 11-16-2009 05:34 PM
Intermittent start problem-seems heat/sun related entletank 2G (1998 - 2001) Sephia 6 05-11-2009 01:49 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On