Diesel Sorento Not Starting - ELECTRICALS or What? - Kia Forum
 1Likes
  • 1 Post By nstoolman1
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 08-06-2018, 12:18 AM Thread Starter
Newbie
 
Join Date: Aug 2018
Location: Johannesburg South Africa
Posts: 7
Drives: Kia Sorento 2010 Model, 2.2 CRDi 4WD, Diesel, 7 Seater.
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Question Sorento Goes on Lim Mode

Hi guys! Please assist. I own a 2010 Kia Sorento 2.2 Diesel Automatic which is out of warranty. Recently i noticed if I put more gas wanting to overtake it reduces speed and can no longer rev past 3000rpm unless i switch off the ignition and on again. The first time it threw 2 error codes, P1186 and the other one which i forgot plus EML shows up but both codes were pointing to fuel pressure too low. I recently took it to its annually service at KIA but they did not pick anything. Now it is no longer throwing any error codes and EML but it still does the same problem. I have tried to clean all the connectors with Q20 but no changes. Anyone who had a similar problem and succeeded in curing the problem may assist. I hope it is not the High pressure fuel pump. Lastly i have noticed that this problem started when i used two diesel additives for injector cleaning in a space of a month. Could they be the ones which damaged the pump or something?

Attached Thumbnails
Click image for larger version

Name:	Kia-Sorento-2010-1600-20.jpg
Views:	24
Size:	318.2 KB
ID:	102352  
[email protected] is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 06-05-2019, 08:16 AM Thread Starter
Newbie
 
Join Date: Aug 2018
Location: Johannesburg South Africa
Posts: 7
Drives: Kia Sorento 2010 Model, 2.2 CRDi 4WD, Diesel, 7 Seater.
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Lightbulb Sorento Not Starting - ELECTRICALS or What?

Hi everyone. I need some help. My Sorento developed a hard start problem in the mornings and after a long period of parking. Now it refused to start whatsoever. This is what I did sor far:

1. Hook up a scan tool and get a P1186 - Low pressure in fuel rail.
2. Changed the fuel pump from the tank.
3. Changed the crankshaft sensor.
4. removed the injectors and thoroughly clean them
5. removed the glow pugs and checked. They're working.
6. Changed the fuel rail pressure regulator Part number 0281006037
7. remove and check the Fuel Pressure Control Valve. here is the part number 0928400752.

All these has been done as trial and error method to no avail. When the hard start developed, the vehicle will just not rev past the 3000rpm unless you switch off and on again. No error codes are found now but I have realised something which I need a confirmation with anyone with knowledge of auto electricals.

Using a test light from the battery positive the test light is lighting on all the wires in the crankshaft engine connector (ie plugs) in fact it is lighting on all wires present on all the sensors wiring connectors. For example, the crankshaft sensor, the inlet valve sensor and the camshaft sensor have three wires in the connectors and all the three wires are responding to the light tester. Are they supposed to do that or can I conclude that I now have an electrical problem?

The car has 173 000km (107497 miles) Kia Sorento 2010 Model, 2.2 CRDi RHD and the car is way out of warranty.

Your help will be appreciated!
[email protected] is offline  
post #3 of 8 (permalink) Old 06-05-2019, 08:27 AM
Member
 
Join Date: May 2012
Location: Long Island, NY
Posts: 62
Drives: Silver 2012 Kia Sorento FWD Base with 2.4L
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)

How is the starter? My bad starter did the no start after turning off the engine because it was taking away the power that the battery needed for charging while in motion. It first acted like it was a bad alternator which I got replaced first. Even with a bad CKPS or Camshaft sensor, the car can still start but not normally. You try clearing the code with the scan tool and trying again?
DefMan is offline  
 
post #4 of 8 (permalink) Old 06-05-2019, 08:45 AM Thread Starter
Newbie
 
Join Date: Aug 2018
Location: Johannesburg South Africa
Posts: 7
Drives: Kia Sorento 2010 Model, 2.2 CRDi 4WD, Diesel, 7 Seater.
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Thanks for quick response. The starter seams to be cranking ok. I have cleared all the codes
cjeremiah29v1[email protected] is offline  
post #5 of 8 (permalink) Old 06-07-2019, 12:41 PM
Full Member
 
Join Date: May 2017
Location: Minnesota
Posts: 162
Drives: Sorento 2012
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)

I am sorry to say but since the Sorento diesel was never offered for sale in the US, there is not a lot of people on this board that have one. I have not run across any information for a Sorento diesel when looking for my Sorento. This could account for the lack of posts for you as US and Canada owners post more on this board then others. You may have to try a car site from a different country like the Soviet Union or from Asia that sold the Sorento diesel. This may involve something like a Google translator if your like me. I will say that on the GDI gasoline engine with a low pressure fault code that it could be the high pressure fuel pump that is mounted to the engine and is not the fuel pump in the gas tank. The tank pump is just used to get the fuel to the high pressure pump that sprays the fuel into the cylinders. Also remember that KIA and HYUNDAI are the same engine so you may want to search for HYUNDAI also.

https://www.autocodes.com/p1186_hyundai.html

I'm sorry I could not be of help and wish you good health for both you and your KIA.
jolt2 is offline  
post #6 of 8 (permalink) Old 06-07-2019, 01:16 PM
Veteran
 
Join Date: Dec 2005
Location: Middleton, Idaho
Posts: 2,335
Drives: 2003 S-10 Had an 03 LX 3.5 Sorento
Gallery: 0
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 96 Post(s)

https://www.kia-forums.com/europe/

Try this one and maybe a mod can move this thread over so that you don't have to repeat everything.
And I know S.A. is not in Europe but there was not a section for it.
ron1004 likes this.
nstoolman1 is offline  
post #7 of 8 (permalink) Old 06-07-2019, 03:38 PM Thread Starter
Newbie
 
Join Date: Aug 2018
Location: Johannesburg South Africa
Posts: 7
Drives: Kia Sorento 2010 Model, 2.2 CRDi 4WD, Diesel, 7 Seater.
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Wow! Thank you jolt2 for your response. I do understand your view very well. I will do just as you said.
[email protected] is offline  
post #8 of 8 (permalink) Old 06-07-2019, 03:41 PM Thread Starter
Newbie
 
Join Date: Aug 2018
Location: Johannesburg South Africa
Posts: 7
Drives: Kia Sorento 2010 Model, 2.2 CRDi 4WD, Diesel, 7 Seater.
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Thanks to you nstoolman1
[email protected] is offline  
Reply

  Kia Forum > Regional > Europe



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On