2001 Kia Magentis - weird electrical issue - Kia Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 03-20-2015, 08:01 AM Thread Starter
Newbie
 
Join Date: Mar 2015
Posts: 2
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Thread Starter (Thread Starter)
Question 2001 Kia Magentis - weird electrical issue

Having some weird electrical issues with my Magentis. It started last weekend when the oil light came on, and then slowly faded away as I was driving (I checked, the oil level was OK). It came on again the next day and then faded away again, but the day after that the battery light came on with it. The stereo started cutting out next, and when we pulled over the car wouldn't start.

Had it towed home and replaced the alternator yesterday, and everything seemed to be OK. Took it for 3 drives and there were no issues. This morning the oil light came on again, though, and once again faded away before I got to work.

Could it be another bad alternator? A bad battery? I'm stumped on this one.

Bob M is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 03-20-2015, 08:10 AM
Super Moderator
 
ron1004's Avatar
 
Join Date: Jun 2005
Location: USA
Posts: 8,409
Drives: 1999 Kia / 기아 Elan, 2017 Ford Edge Sport, 2015 Ford Mustang, 2008 Harley Nightrain
Gallery: 13
Mentioned: 18 Post(s)
Tagged: 0 Thread(s)
Quoted: 690 Post(s)
Garage

Quote:
Originally Posted by Bob M View Post
Having some weird electrical issues with my Magentis. It started last weekend when the oil light came on, and then slowly faded away as I was driving (I checked, the oil level was OK). It came on again the next day and then faded away again, but the day after that the battery light came on with it. The stereo started cutting out next, and when we pulled over the car wouldn't start.

Had it towed home and replaced the alternator yesterday, and everything seemed to be OK. Took it for 3 drives and there were no issues. This morning the oil light came on again, though, and once again faded away before I got to work.

Could it be another bad alternator? A bad battery? I'm stumped on this one.
What made you decide to change the alternator?

It sounds more like a poor grounding - check the grounding straps between the battery and the chassis, and the engine and chassis.

I'd be too scared to drive a car when the oil light comes on, although in this case it looks like a false alarm.

Quality and not quantity counts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Sig image is 500X100 at 11.7 kb
ron1004 is offline  
post #3 of 3 (permalink) Old 03-20-2015, 08:46 AM Thread Starter
Newbie
 
Join Date: Mar 2015
Posts: 2
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Thread Starter (Thread Starter)
Local mechanic suspected the computer was shutting down one system after another because it didn't have enough power to keep running, and the oil light was just first in the sequence. I was a bit worried about the oil light myself, but the way it faded away was strange, and when the battery light followed, electrical seemed to make sense.

Thanks - I'll get the grounding wires checked and see if that's the issue. I'd love it to be something simple (and cheap).
Bob M is offline  
Reply

  Kia Forum > Technical > Car Audio, Video & Electronics



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
2005 Kia Sportage Mystery Electrical Issue Andrea Meissner 2G (2003-2010) Sportage 3 04-06-2018 04:01 AM
Weird electrical issue in 2009 Rondo Rondo-owner Kia Carens & Rondo Forum 1 12-10-2017 09:20 PM
Weird Electrical issue ChaseRallix 4G (2011+) Optima 5 06-03-2017 12:40 AM
Odd Electrical Issue BWatkins 2011 - 2013 (XM) Sorento Forum 3 01-11-2017 05:15 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On