Optima Antenna cover broken - Kia Forum

 5Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 20 (permalink) Old 02-10-2015, 08:35 PM Thread Starter
Newbie
 
Join Date: Feb 2015
Posts: 5
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Thread Starter (Thread Starter)
Optima Antenna cover broken

Can anyone help me to prove it could be the manufacture fault, please?

I bought an Optima last May.
I realized that Antenna cover was taken apart last weekend. I was able to take it away with just few fingers.
I checked the inside of the cover and it has 5 pieces to connect with 5 screws. They were all broken. And one of the screw is totally rusted and red. And also 3 out of 5 screws didn't even come out from the holes.
And there is absolutely no damage out side of antenna cover and in side it's totally damaged. Please take a look at my album I posted on the gallery.
I talked to dealer service manager and Kia canada customer service.

They can cover this with warranty because it's damaged. But they can't explain how it's possibly happened by using this car. Their main focus is the word "damage".

The service manager told me "it could happen because of the car wash." all of 5 places can be broken by car wash, those people who don't have this problem never went to car wash?

If they don't want to give me the warranty service, I believe they must prove it's customer's fault. But nothing can be proven. There is no damage outside not even scratch.

They just tried to charge over 600$ to the customer to repair that piece.

I can't believe this.

Attached Thumbnails
Click image for larger version

Name:	antenna_cover1.jpg
Views:	9518
Size:	88.3 KB
ID:	36186   Click image for larger version

Name:	antenna_cover2.jpg
Views:	13352
Size:	77.5 KB
ID:	36194   Click image for larger version

Name:	antenna_cover3.jpg
Views:	7741
Size:	79.0 KB
ID:	36202  

Last edited by crazykiaservice; 02-10-2015 at 09:10 PM.
crazykiaservice is offline  
Sponsored Links
Advertisement
 
post #2 of 20 (permalink) Old 02-11-2015, 06:54 AM Thread Starter
Newbie
 
Join Date: Feb 2015
Posts: 5
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Thread Starter (Thread Starter)
More than that,
Conversation with the service manager at Kia:

Question: One of the screw inside is totally rusted. How it can happen?
service manager's answer: I don't know. But it's damaged.
My question: Why those 3 screw didn't come out? They are on the surface. They cannot even hold the cover?
service manager's answer: I don't know. But it's damaged.
My question: How can customer make them damaged?
Service manager's answer: I don't know.

The only reason it cannot be covered by warranty is "Just Damaged".
They cannot prove it's broken by customer's mis-usage. They don't even want to think if it's manufacture's fault.
crazykiaservice is offline  
post #3 of 20 (permalink) Old 02-12-2015, 10:28 AM
Newbie
 
Join Date: Feb 2015
Location: London Ontario
Posts: 2
Drives: 2014 Kia Forte
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Me too!

Just had to temporarily tape my cover on because of the exact same problem. Looks to be a poorly designed part. I'll probably just glue the stupid thing down instead of trying to get it replaced.
crazykiaservice likes this.
JCDean is offline  
 
post #4 of 20 (permalink) Old 02-12-2015, 11:00 AM
Super Moderator
 
cobra259's Avatar
 
Join Date: Aug 2010
Location: Waterford MI
Posts: 4,427
Drives: 1995 Procharged Mustang Cobra -- 2006 Grand Cheorkee limted Hemi.
Gallery: 0
Mentioned: 20 Post(s)
Tagged: 0 Thread(s)
Quoted: 375 Post(s)

Quote:
Originally Posted by crazykiaservice View Post
Can anyone help me to prove it could be the manufacture fault, please?

I bought an Optima last May.
I realized that Antenna cover was taken apart last weekend. I was able to take it away with just few fingers.
I checked the inside of the cover and it has 5 pieces to connect with 5 screws. They were all broken. And one of the screw is totally rusted and red. And also 3 out of 5 screws didn't even come out from the holes.
And there is absolutely no damage out side of antenna cover and in side it's totally damaged. Please take a look at my album I posted on the gallery.
I talked to dealer service manager and Kia canada customer service.

They can cover this with warranty because it's damaged. But they can't explain how it's possibly happened by using this car. Their main focus is the word "damage".

The service manager told me "it could happen because of the car wash." all of 5 places can be broken by car wash, those people who don't have this problem never went to car wash?

If they don't want to give me the warranty service, I believe they must prove it's customer's fault. But nothing can be proven. There is no damage outside not even scratch.

They just tried to charge over 600$ to the customer to repair that piece.

I can't believe this.

Who's car is this????? You state "they tried to charge the customer 600"
Things do break, hell a tree branch could have fell on it WITHOUT you ever know it happened. Stranger things have happened..............
crazykiaservice likes this.
cobra259 is offline  
post #5 of 20 (permalink) Old 02-12-2015, 11:16 AM
Senior Member
 
eyeballface's Avatar
 
Join Date: Dec 2010
Location: Troll Bait & Bisc Inc.
Posts: 364
Drives: 2015 Sorento
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)

Is this your car? Di you buy is brand new, or second owner?

Let me kick you a scenerio: Your local dealer decides to believe your story and they warranty it. Kia asks to get the part sent to them to have a look, as this is not something that is common to be a bad part. They look at it and say "why is this warranty, its broken and damaged" . They deny to pay the claim to the dealer, now the dealer just gave away over $600 of free parts and service. Why should they take that hit when you have no evidence that is was a factory defect.

Maybe if it was a common issue, but it seems like its not. Ive seen many antenna be broken by car washes, not everyone goes to the same wash, so not everyone has the same experience.

From your pictures it looks like someone or something has hit and broken it off. Not sure what could be dont to prove otherwise.
eyeballface is offline  
post #6 of 20 (permalink) Old 02-12-2015, 11:45 AM
Newbie
 
Join Date: Feb 2015
Location: London Ontario
Posts: 2
Drives: 2014 Kia Forte
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

I wouldn't be surprised if (in my case) my wife or I hit it while clearing snow off the roof of our car.

Just got back in from using a little JB Weld and tape to hold it until it cures. Our AM/FM and satellite still work fine. Fingers crossed it stays put now.
crazykiaservice likes this.
JCDean is offline  
post #7 of 20 (permalink) Old 02-18-2015, 05:03 AM Thread Starter
Newbie
 
Join Date: Feb 2015
Posts: 5
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Thread Starter (Thread Starter)
Quote:
Originally Posted by JCDean View Post
Just had to temporarily tape my cover on because of the exact same problem. Looks to be a poorly designed part. I'll probably just glue the stupid thing down instead of trying to get it replaced.
Yeah, I did it with glue. Basically if they use same screws that can be broken in 7 months, there is no reason to spend 600$. It is designed to be broken easily
crazykiaservice is offline  
post #8 of 20 (permalink) Old 02-18-2015, 05:07 AM Thread Starter
Newbie
 
Join Date: Feb 2015
Posts: 5
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Thread Starter (Thread Starter)
Quote:
Originally Posted by eyeballface View Post
Is this your car? Di you buy is brand new, or second owner?

Let me kick you a scenerio: Your local dealer decides to believe your story and they warranty it. Kia asks to get the part sent to them to have a look, as this is not something that is common to be a bad part. They look at it and say "why is this warranty, its broken and damaged" . They deny to pay the claim to the dealer, now the dealer just gave away over $600 of free parts and service. Why should they take that hit when you have no evidence that is was a factory defect.

Maybe if it was a common issue, but it seems like its not. Ive seen many antenna be broken by car washes, not everyone goes to the same wash, so not everyone has the same experience.

From your pictures it looks like someone or something has hit and broken it off. Not sure what could be dont to prove otherwise.
It was brand new.
Yeah, I can understand your story.

When I asked Kia, I didn't talk about the broken cover. I asked about the screws. I understand the cover can be broken because it's just plastic. But check those screws. The length of 3 screws and one of them is totally red. Does that mean screws can be broken easily as well? I don't think those 3 screws are broken. It didn't pushed properly, that's what I think.

Last edited by crazykiaservice; 02-18-2015 at 05:28 AM.
crazykiaservice is offline  
post #9 of 20 (permalink) Old 02-18-2015, 05:20 AM Thread Starter
Newbie
 
Join Date: Feb 2015
Posts: 5
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Thread Starter (Thread Starter)
Thanks all for your replies.

Even if it's easily broken, I still cannot understand how 3 of screws are such short which cannot hold the cover. And I cannot understand one screw becomes totally red in 7 month which was supposed to be covered.

I don't think those 3 screws were broken. If it's actually broken by some hit or car wash, Kia is using extremely weak screws.

Anyway, thanks again for your replies .
crazykiaservice is offline  
post #10 of 20 (permalink) Old 08-27-2016, 01:12 PM
Newbie
 
Join Date: Aug 2016
Location: Naples
Posts: 2
Drives: Kia Optima 2014 Hybrid
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

I am on the same boat, I live in Florida and my Optima Hybrid has been garage kept for the past year and a half, other than the times I am not at home of course. I always hand wash it, so today I was washing it again and I wanted to pick up some dirt from the antenna cover ( I moved a month ago and no longer have a garage,so it gets dirtier more often ) and - voala, the cover just popped off. I looked at it with disbelief - the plastic that the screws hold on to had just fallen apart. I dunno what to do , I think I will stop by the dealer and see what they will say, but it is obviously bad parts used on it.
angelmarkov is offline  
Reply


Top

  Kia Forum > KIA Models > Kia Magentis & Optima Forum > 4G (2011+) Optima



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Broken Antenna Options Wes_517 3G 2011 - 2016 Sportage 5 06-07-2018 11:15 AM
Sharkfin Antenna Cover abreen612 4G (2011+) Optima 2 11-21-2017 04:44 PM
Optima antenna cover broken angelmarkov 4G (2011+) Optima 2 09-17-2016 01:25 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On