P0455 Major EVAP Leak - Kia Forum

 1Likes
  • 1 Post By JasonK94Z
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 06-24-2019, 05:44 PM Thread Starter
Newbie
 
Join Date: May 2019
Location: South Carolina
Posts: 9
Drives: 2016 Kia Rio LX Sedan auto trans
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Thread Starter (Thread Starter)
P0455 Major EVAP Leak

This code, p0455, has popped up and itís giving me hell of n my 2016 Rio.
I have replaced the gas cap with a new Kia part and cleared the code. No luck there.

So I replaced the purge solenoid this past weekend and cleared the code again. No luck yet again.

Next up is the vapor canister vent valve down by the fuel tank. Iíll do that this weekend

Just going from cheapest part to most expensive. Only thing left will be the charcoal canister after this.
Anyone fight this type of issue on the car?



Sent from my iPhone using Tapatalk

JasonK94Z is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 06-24-2019, 07:39 PM
Veteran
 
Join Date: Sep 2016
Location: USA,WESTERN NY
Posts: 1,756
Drives: 09 kia spectra ex,04 Neon,04 Chry. T&C, 98 Avenger
Gallery: 0
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 364 Post(s)

Sorry that I can't give you specific to your Rio info. BUT a major EVAP leak can also come from one of the hoses in the system and not necessarily a defective part to "throw in" in hopes of fixing it.
How long have you been "fighting" this code? Think back to when it first appeared, did you run over something perhaps that could have torn an EVAP hose under the car? Time for doing some visual inspection before spending more money on parts that may not fix the problem.
MIA KIA 09 is offline  
post #3 of 6 (permalink) Old 06-25-2019, 11:57 AM Thread Starter
Newbie
 
Join Date: May 2019
Location: South Carolina
Posts: 9
Drives: 2016 Kia Rio LX Sedan auto trans
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Thread Starter (Thread Starter)
This code has been goi g on for a few weeks now. Iíll check the hoses over as much as I can this weekend too.


Sent from my iPhone using Tapatalk
JasonK94Z is offline  
 
post #4 of 6 (permalink) Old 07-01-2019, 06:54 AM Thread Starter
Newbie
 
Join Date: May 2019
Location: South Carolina
Posts: 9
Drives: 2016 Kia Rio LX Sedan auto trans
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Thread Starter (Thread Starter)
Looks like the purge solenoid valve replay was the fix. The check engine light did come back on after replacing it, but I cleared it once and continued driving the car. The code hasnít come back in over 1500 miles.


Sent from my iPhone using Tapatalk
JasonK94Z is offline  
post #5 of 6 (permalink) Old 07-04-2019, 05:16 AM
Newbie
 
Join Date: Jun 2018
Location: Atlanta, GA
Posts: 14
Drives: 2013 Rio LX 4-Door
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)

Immediately prior to the code appearing, when filling up your gas tank, did you overfill it or fill it "all-the-way-up?"
BruceTR is offline  
post #6 of 6 (permalink) Old 07-04-2019, 09:32 AM Thread Starter
Newbie
 
Join Date: May 2019
Location: South Carolina
Posts: 9
Drives: 2016 Kia Rio LX Sedan auto trans
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Thread Starter (Thread Starter)
Quote:
Originally Posted by BruceTR View Post
Immediately prior to the code appearing, when filling up your gas tank, did you overfill it or fill it "all-the-way-up?"


I always stop filling when the pump handle clicks off the first time. I never top off.


Sent from my iPhone using Tapatalk
sblake5 likes this.
JasonK94Z is offline  
Reply

  Kia Forum > KIA Models > Kia Rio Forum > 3G (2012 - 2017) Rio



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On