AC and outdoor temp sensor working/not working at the same time - Kia Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 04-14-2019, 07:39 PM Thread Starter
Newbie
 
Join Date: Apr 2019
Location: Ohio
Posts: 2
Drives: 2012 Rio
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
AC and outdoor temp sensor working/not working at the same time

I've been having an interesting issue with the AC and outdoor temperature sensor on my 2012 Rio. Whenever the AC blows warm air, the temperature readout only displays three dashes. As soon as the temperature pops back up, the AC starts working again. I can't seem to find anything about this problem so I was wondering if you all had any thoughts on it.

Kyle Bopp is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 04-15-2019, 06:15 AM
Member
 
Join Date: Jan 2019
Location: Phoenix, AZ
Posts: 25
Drives: 2014 Kia Rio
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Yes, if the temperature sensor sees that it is less than 33.8F outside or in your case nothing at all the AC compressor will turn off. Here is some information. What type of ohm reading you should get at different temperatures plus the location of the temperature sensor. Disconnect sensor and take an ohm reading. If the ohm reading is out of range for the temperature than replace the sensor. If sensor seems fine check the wires are not broken and the connector is tight.
Attached Thumbnails
Click image for larger version

Name:	temperature.gif
Views:	5
Size:	5.2 KB
ID:	104986   Click image for larger version

Name:	sensor location.jpg
Views:	6
Size:	10.5 KB
ID:	104988  

Last edited by danelo; 04-15-2019 at 06:40 AM.
danelo is offline  
post #3 of 3 (permalink) Old 04-15-2019, 07:40 AM Thread Starter
Newbie
 
Join Date: Apr 2019
Location: Ohio
Posts: 2
Drives: 2012 Rio
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Okay thank you, I'll have a look at that today
Kyle Bopp is offline  
Reply

  Kia Forum > KIA Models > Kia Rio Forum > 3G (2012 - 2017) Rio



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On