Kia 5 Speedo and Petrol gauge fault 2011 1.2 - Kia Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-16-2019, 04:09 AM Thread Starter
Newbie
 
Join Date: Feb 2017
Location: Scotland
Posts: 8
Drives: Rio 2011
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)

Thread Starter (Thread Starter)
Kia 5 Speedo and Petrol gauge fault 2011 1.2

Hi, I have an issue with the speedo on my 2011 1.2 Rio.

When I turn the car on, drive away all works as expected. I can be 5 miles from my house doing 60MPH and when i brake to slow down gradually to say 55MPH the speedo then drops to 20MPH and bounces between 20-40MPH for a few seconds then just drops to 0MPH all along i'm doing around 60MPH. occasionally it will flicker up to 10mph then 0 again a few times over a 30 min commute.

The Rev counter is fine, the petrol guage jumps around maybe between 1/8th of the scale. The "Miles displayed to next petrol fill up" jumps around say 220 - 90 - 50 - 200 - 221 constantly.

The "Mileometer" does not change when speedo is at 0MPH.

When I turn car off (overnight), the same happens again - works as planned and 5 miles/10 mins use it goes faulty again.

The car is 8 years old, 65'000 miles.

Can anyone tell me what cable i need to "reseat" or clean under the bonnet that affects these components?

Any help would be much appreciated.

Many Thanks
Martin

skidrow is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Today, 07:43 AM Thread Starter
Newbie
 
Join Date: Feb 2017
Location: Scotland
Posts: 8
Drives: Rio 2011
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)

Thread Starter (Thread Starter)
Hi, Doing some more research this may be a speed sensor?

Can anyone point me in the direction of where this sensor is in a 2011 plate Rio and is it easy to reseat?

I have searched for engine bay diagrams for this model but cannot locate one. If anyone has such a diagram that would be great.

many thanks for reading.
skidrow is offline  
Reply

  Kia Forum > KIA Models > Kia Rio Forum > 2G (2006 - 2011) Rio & Rio5



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List




Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On