Won't start when hot - Kia Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 04-16-2019, 10:53 AM Thread Starter
Newbie
 
Join Date: Apr 2019
Posts: 1
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Thread Starter (Thread Starter)
Won't start when hot

Hi

My 2011 Rio diesel has developed a problem whereby it won't start when hot leaving me broken down for hours twice in the last week.

The first time the mechanic changed the crankshaft position indicator.

The second time he changed the fuel filter and cleaned out the throttle cable. He left it running for over an hour but couldn't replicate the problem.

Now it's happened again. The mechanic doesn't know what's wrong and he's not a Kia mechanic so I wondered if this is a particular Kia problem.

It turns over fine and no warning lights come on, just won't 'catch' and fire. It starts fine from cold and runs perfectly.

Any ideas?

Sara

Sara Kia is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-24-2019, 06:48 PM
Newbie
 
TopekaMan's Avatar
 
Join Date: Aug 2008
Location: Kansas
Posts: 15
Drives: 2008 Kia Rio5 SX m/t
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Quote:
Originally Posted by Sara Kia View Post
Hi

My 2011 Rio diesel has developed a problem whereby it won't start when hot leaving me broken down for hours twice in the last week.

The first time the mechanic changed the crankshaft position indicator.

Sara
I don't have a diesel engine but I recently had a problem that sounds like yours. The first sensor they said needed to be replaced was the Manifold Absolute Pressure sensor (MAP sensor) and that kinda helped but I also needed the Crankshaft Position indicator replaced. On my gasoline engine the MAP sensor is a few inches to the left of the Crankshaft Position indicator and I replaced the MAP sensor myself (it was hard to reach but easy to do). The part cost $25 USD (they ranged from $9 to $42) online so that might be something you can try to do yourself that won't be too much money wasted if it doesn't end up fixing the problem (plus it's one more thing to cross of the list of what could possibly be wrong).
TopekaMan is offline  
Reply

  Kia Forum > KIA Models > Kia Rio Forum > 2G (2006 - 2011) Rio & Rio5



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Push Button Start Intermittent Failure b1uebird 2014 - 2015 Sorento Forum 16 09-17-2018 05:49 PM
Very Intermittent No Start Issue ??? BuckSkin 1G (1993 - 2002) Sportage 33 02-07-2018 05:52 PM
2013 Kia Rio SX Hatch - Starting Problems (Auto- push button Start) psyou97 3G (2012 - 2017) Rio 1 08-09-2017 09:36 AM
Intermittent start problem-seems heat/sun related entletank 2G (1998 - 2001) Sephia 6 05-11-2009 01:49 PM
too cold/too 99' sephia won't start srvlegend 2G (1998 - 2001) Sephia 3 01-15-2008 07:51 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On