2008 KIA Sportage - Died - Multiple codes P1507, P0340, P1505, P1507 - Kia Forum

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 05-19-2019, 03:22 PM Thread Starter
Newbie
 
Join Date: May 2019
Location: Sothern Illinois
Posts: 6
Drives: sportaoge 2008
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Thread Starter (Thread Starter)
2008 KIA Sportage - Died - Multiple codes P1507, P0340, P1505, P1507

MY sportage died going down the interstate. Its throwing these codes.
P1505 idle speed control actuator, P1507 Idle air control valve
P0340 Cam position sensor, P0261 P0264 P0267 P0270 P0273 P0276 injectors
P0455 EVAP Emissions sys. large leak detected
P0448 Evap Emissions control sys. vent control valve/circuit shorted.


What could it be.PLEASE HELP


Last edited by ron1004; 06-17-2019 at 07:50 PM. Reason: Descriptive title added
Taylorsdad16! is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 05-19-2019, 06:28 PM
Veteran
 
Join Date: Sep 2016
Location: USA,WESTERN NY
Posts: 1,756
Drives: 09 kia spectra ex,04 Neon,04 Chry. T&C, 98 Avenger
Gallery: 0
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 364 Post(s)

When you say "died going down the Interstate"..Do you mean bad noises or sudden no run? What mileage and service history has it had, Is this a 2.0 4 cylinder motor? ever had the timing belt done? Does it crank but not start or not even crank? Do other electrical items work? If not have you checked battery and power/ground cables?
MIA KIA 09 is offline  
post #3 of 9 (permalink) Old 06-12-2019, 04:57 PM Thread Starter
Newbie
 
Join Date: May 2019
Location: Sothern Illinois
Posts: 6
Drives: sportaoge 2008
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Thread Starter (Thread Starter)
It just died no noise nothing. Will turn over. Timing belt good. The cam position sensor replace. Same problem same codes
Taylorsdad16! is offline  
 
post #4 of 9 (permalink) Old 06-12-2019, 05:00 PM Thread Starter
Newbie
 
Join Date: May 2019
Location: Sothern Illinois
Posts: 6
Drives: sportaoge 2008
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Thread Starter (Thread Starter)
And there is no pulse to the injectors. Fuel pump works
Taylorsdad16! is offline  
post #5 of 9 (permalink) Old 06-12-2019, 05:18 PM Thread Starter
Newbie
 
Join Date: May 2019
Location: Sothern Illinois
Posts: 6
Drives: sportaoge 2008
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Thread Starter (Thread Starter)
2.7 liter V6
Taylorsdad16! is offline  
post #6 of 9 (permalink) Old 06-17-2019, 06:29 PM Thread Starter
Newbie
 
Join Date: May 2019
Location: Sothern Illinois
Posts: 6
Drives: sportaoge 2008
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Thread Starter (Thread Starter)
2008 KIA Sportage - Multiple codes P1507, P0340, P1505, P1507
MY sportage died going down the interstate. Its throwing these codes.
P1505 idle speed control actuator, P1507 Idle air control valve
P0340 Cam position sensor, P0261 P0264 P0267 P0270 P0273 P0276 injectors
P0455 EVAP Emissions sys. large leak detected
P0448 Evap Emissions control sys. vent control valve/circuit shorted.

What could it be.
Timing belt good. Changed cam position sensor
No pulse/ power going to injectors
PLEASE HELP
Taylorsdad16! is offline  
post #7 of 9 (permalink) Old 06-17-2019, 10:28 PM Thread Starter
Newbie
 
Join Date: May 2019
Location: Sothern Illinois
Posts: 6
Drives: sportaoge 2008
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Thread Starter (Thread Starter)
I checked the timing marks. There is no power to the injectors. No pulse

It has not jumped time

Thank you for help

Last edited by ron1004; 06-18-2019 at 04:25 AM.
Taylorsdad16! is offline  
post #8 of 9 (permalink) Old 06-18-2019, 03:09 AM
Full Member
 
pips's Avatar
 
Join Date: Jul 2007
Location: Manchester, UK
Posts: 98
Drives: 2006 Sportage 2.0 CRDI XE
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

These are what is showing in my manual for the codes p0261, p0270, p0340, p1505, p1507
Attached Images
File Type: png p0270.png (12.2 KB, 7 views)
File Type: png p0340.png (13.2 KB, 6 views)
File Type: png p1505.png (12.6 KB, 6 views)
File Type: png p1507.png (12.3 KB, 6 views)
File Type: png p0261.png (12.3 KB, 7 views)

If it ain't broke, fix it 'til it is!
pips is offline  
post #9 of 9 (permalink) Old 06-18-2019, 03:10 AM
Full Member
 
pips's Avatar
 
Join Date: Jul 2007
Location: Manchester, UK
Posts: 98
Drives: 2006 Sportage 2.0 CRDI XE
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

These are what is showing in my manual for the codes p0264, p0267, p0273, p0276, p0455
Attached Images
File Type: png p0264.png (12.7 KB, 4 views)
File Type: png p0267.png (12.4 KB, 4 views)
File Type: png p0273.png (11.1 KB, 4 views)
File Type: png p0276.png (11.1 KB, 4 views)
File Type: png p0455.png (14.1 KB, 3 views)

If it ain't broke, fix it 'til it is!
pips is offline  
Reply

  Kia Forum > KIA Models > Kia Sportage Forum > 2G (2003-2010) Sportage



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
2008 sportage brake master cylinder jgb 1G (1993 - 2002) Sportage 1 08-31-2017 11:06 PM
Kia Sportage (2012) FCEV ArunPillai 2G (2003-2010) Sportage 5 11-15-2009 11:53 PM
K&n 33-2201 Kia Hyundai Spectra, Sportage, Tiburon MstrTec Parts For Sale / Trade 0 05-12-2009 06:26 PM
Question concerning Dash Kit and Wiring Harness for 2008 Sportage AcidGhost 2G (2003-2010) Sportage 0 02-25-2008 10:44 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On