2016 Sorento..tach not working properly - Kia Forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 06-01-2019, 11:14 AM Thread Starter
Newbie
 
Join Date: Jun 2019
Location: Cogan Station PA
Posts: 2
Drives: Kia Sorento 2016
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
2016 Sorento..tach not working properly

Tach while driving at 70 goes to zero..what going on?

MWilliams is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 06-01-2019, 01:21 PM
Expert
 
Join Date: Jul 2016
Location: New York
Posts: 618
Drives: 2019 Sorento EX V6
Gallery: 0
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 287 Post(s)

Warranty time
scosgt is offline  
post #3 of 5 (permalink) Old 06-01-2019, 06:24 PM
Senior Member
 
Join Date: Apr 2017
Location: Tucson, AZ
Posts: 227
Drives: Sorento LX V6 2018
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 77 Post(s)

Something like that is very often a grounding issue but can be a whole lot worse than that so get thee to the dealer. Hopefully it's a 5/60 warranty item.
tom4416 is offline  
 
post #4 of 5 (permalink) Old 06-02-2019, 11:05 AM
Full Member
 
Join Date: Aug 2017
Location: Atlanta, GA
Posts: 126
Drives: Sorento SX FWD 2015
Gallery: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 25 Post(s)

You did not identify your model or engine so so the RPM to speed numbers will vary. Engine speed is delivered as data to the instrument cluster by the ECM via the CAN (Controller Area Network). A MCU (Micro Controller Unit) internal to the cluster converts the data to indicators. The ECM also sends Check Engine, Coolant Temp, Cruise and Cruise Set data (indicators) to the MCU/cluster on the same CAN lines. If these other indications work and the tac works up to 70 mph then the CAN buss between the ECU and MCU/cluster is most likely functioning. My V6 runs 2000 RPM at 70. My guess is a I4 would be a bit higher. I'm suspecting a bad cable connection to cluster (reseating) or MCU/Cluster failure or a ECM software problem.

Q1- If you put the car in neutral can you run the TAC up to 3000-3500 RPM ? That says MCU/Cluster is capable of handling the CAN RPM data over 70 MPH.
Q2- When on the road does the TAC go to 0 RPM or does it go blank at 70 MPH ? Thinking Maybe ECM software if display goes blank.

Are you still under warranty ?? New clusters vary $500-900 USD. You would really need verification/isolation prior to shotgunning parts. A dealer has tools and free parts access and can swap till they find the problem. Could be cheaper in the long run.

I'm Bob, 2015 Sorento SX , 2007 GMC Envoy (tuned) , 1994 Camaro Z28 (modified/custom tuned)

Last edited by bobdec; 06-02-2019 at 11:10 AM.
bobdec is offline  
post #5 of 5 (permalink) Old 06-02-2019, 12:43 PM
Expert
 
Join Date: Jul 2013
Location: Pennsylvania
Posts: 516
Drives: 2019 Sorento LX AWD 2.4L w/ Convenience Package, 2018 Mitsubishi Outlander SE-AWC
Gallery: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 163 Post(s)

CAN is a communication network. I would not expect that it would stop functioning at a certain speed.

I agree that you should test if the signal is lost above a certain rpm. The sensing of the rpm could be the problem.
SoothingDave is offline  
Reply

  Kia Forum > KIA Models > Kia Sorento Forum > 2016+ Sorento



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On