Won't start - battery? - Kia Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 05-04-2019, 06:00 AM Thread Starter
Newbie
 
Join Date: May 2019
Location: Ontario
Posts: 1
Drives: 2014 kia sorento
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Won't start - battery?

Hi all,

I was in a minor collision earlier this week and while my Sorento started fine for a few days, it now won't start. All the electrical components (radio, wipers, headlights, etc) work but the car just clicks rapidly when I push to start. I've observed no signs of leaking, however, I was running the car in battery mode for 15 ish minutes before trying to turn over the engine.

Is this a battery issue or could the collision have caused some issue that only appeared days later?

Please let me know!

Thank you.

Randomkia is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 05-04-2019, 06:16 AM
Super Moderator
 
ron1004's Avatar
 
Join Date: Jun 2005
Location: USA
Posts: 8,469
Drives: 1999 Kia / 기아 Elan, 2017 Ford Edge Sport, 2015 Ford Mustang, 2008 Harley Nightrain
Gallery: 13
Mentioned: 18 Post(s)
Tagged: 0 Thread(s)
Quoted: 712 Post(s)
Garage

If you don't have a multi-meter to check the battery voltage, take the battery to your local parts store and they'll test it for you.

Yes it sounds like its only a flat battery.

Quality and not quantity counts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Sig image is 500X100 at 11.7 kb
ron1004 is offline  
post #3 of 7 (permalink) Old 05-04-2019, 11:49 AM
Senior Member
 
rejesterd's Avatar
 
Join Date: Apr 2016
Location: Boston, MA (USA)
Posts: 401
Drives: 2016 Sorento LX V6 AWD
Gallery: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 141 Post(s)

A collision could cause a connection issue. Tighten the terminal connections then see where you're at. If it still clicks rapidly, replace the battery (unless you've done that already). A 2014 would certainly be due for that. But the fact that it correlates with the collision points more toward a loose connection.
rejesterd is offline  
 
post #4 of 7 (permalink) Old 05-04-2019, 03:33 PM
LMP
Senior Member
 
LMP's Avatar
 
Join Date: Mar 2005
Location: Chicoutimi, Quebec Canada
Posts: 343
Drives: Sorento 2015 LX 2.4 AWD, Suzuki 2011 SX4 AWD, ( 2000 KIA Sportage, junked)
Gallery: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 73 Post(s)

A ratling starter solenoid is sign of a poor connection, generally at the battery terminals. A low battery usually just turns the starter slowly or not at all.

Bought in Oct 2016 at 55000km, now (June 2019) at 75000 km. I like cars...
LMP is offline  
post #5 of 7 (permalink) Old 05-16-2019, 07:29 AM
Newbie
 
joseph_butler's Avatar
 
Join Date: Sep 2018
Location: Colorado Springs, CO
Posts: 7
Drives: Kia Sorento 2014
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

What did you discover? Was it loose terminal connections on the battery?

Joseph Butler
Colorado Springs, CO
2014 Kia Sorento LX
joseph_butler is offline  
post #6 of 7 (permalink) Old 05-16-2019, 09:19 AM
Senior Member
 
Join Date: Apr 2018
Location: Belleville, ON, Canada
Posts: 374
Drives: Sorento SX AWD 2015
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 75 Post(s)

Probably that he could just disappear, with many others. LOL

Sorento SX V6 3.3L GDI, AWD 2015
19" Factory Rims, Class III hitch' NAV Current 54,000km Nov. 2018
Highlander 2012 4WD 3.5L Sport
Tripplec is online now  
post #7 of 7 (permalink) Old 05-20-2019, 12:03 AM
Newbie
 
Join Date: May 2019
Location: Raleigh, NC
Posts: 9
Drives: 2014 Kia Sorento 3.3 V6
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

My wife's Sorento had a starting issue one time that was connected to the push button start. I had to push the start button without my foot on the brake pedal, to put it in accessory mode. Then I had to put my foot on the brake, shift it out of park down to drive and back to park. Then try to start it and it fired right up. From what I was told, that with push starts, they will occasionally get dirt on the transmission linkage that tricks the computer into thinking the car is not in park, therefor it will not crank. My friend had that happen to his Grand Cherokee and told me about it about two months prior to our Sorento not wanting to start. So luckily I was aware of that and it ended up saving me about $200 in a tow bill.
Steel4pens is offline  
Reply

  Kia Forum > KIA Models > Kia Sorento Forum > 2014 - 2015 Sorento Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
kia sportage 1997 can only start with weak battery kiasportagenew 1G (1993 - 2002) Sportage 18 06-20-2018 05:20 PM
Sorento LX 2004 won't start battery or ? bealert 2003-2010 Sorento Forum 4 03-08-2018 06:15 AM
Disconnected/reconnected battery, now won't start jackd5523 1G (1993 - 2002) Sportage 3 12-05-2015 11:27 PM
02 Cinco headlights dim while driving zfmrchnt 1G (2001-2005) Rio 2 03-19-2007 02:01 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On