Cargo area light problem - Kia Forum

 1Likes
  • 1 Post By LMP
 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 01-29-2018, 08:24 PM Thread Starter
Newbie
 
sassington's Avatar
 
Join Date: Jan 2018
Location: Central Florida
Posts: 4
Drives: 2015 Sorento
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Cargo area light problem

Hey guys. Newbie here. Just recently purchased a 2015 sorento and have already tried searching this forum but haven’t seen this issue yet. Maybe I missed it. Anywho...

The cargo area light is currently set to “door” but when you open the lift gate to the cargo area, the light isn’t on. I can flip the switch from “door” to “on” and it’ll work then and only then. It’s a head scratcher for me. Am I missing something? I’ll feel stupid if I’m just doing something wrong.

Thanks in advance.


Sent from my iPhone using Tapatalk

sassington is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 01-30-2018, 05:58 AM
LMP
Senior Member
 
LMP's Avatar
 
Join Date: Mar 2005
Location: Chicoutimi, Quebec Canada
Posts: 338
Drives: Sorento 2015 LX 2.4 AWD, Suzuki 2011 SX4 AWD, ( 2000 KIA Sportage, junked)
Gallery: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 73 Post(s)

I'll try to find the details in the shop manual....maybe it is there...but the first suspect is the lift gate switch ....hey...I do not know where it is..will pay a visit to SOri in my garage to find out. Of course, probably, all of this must go through the BodyCOntrolMOdule....this thing that replaces the straight wiring that used to work for the last 100 years.....
QUestion: does the cargo light goes ON if you open any other door ?
...and thanks for having filled up your profile right from the start....

Bought in Oct 2016 at 55000km, now (Apr 2019) at 73000 km. I like cars...
LMP is offline  
post #3 of 10 (permalink) Old 01-30-2018, 07:40 AM
LMP
Senior Member
 
LMP's Avatar
 
Join Date: Mar 2005
Location: Chicoutimi, Quebec Canada
Posts: 338
Drives: Sorento 2015 LX 2.4 AWD, Suzuki 2011 SX4 AWD, ( 2000 KIA Sportage, junked)
Gallery: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 73 Post(s)

OK...went to Sori and verified:
-cargo light will NOT turn ON with other doors opening, only with tailgate opening
- no visible switch...light activates as soon as latch quits closed position...switch is integrated within the latch IN THE TAILGATE, probably combined with the switch that will pop "gate unlatched" light on the instrument panel.

here is what the manual says about...
- Tailgate Switch
1. Remove the tailgate trim.
(Refer to Body - "Tailgate")
2. Disconnect the 4P connector from the actuator.
3. Check for continuity between the terminals in each switch position according to the table.
....

In another place I read:
Trunk room lamp does not light
Bulb burned out Replace bulb
Room lamp fuse (10A) blown Check for short and replace fuse
Trunk room lamp switch faulty Check switch
Wiring or ground faulty Repair if necessary
....wow...that's information |

I did not find wiring diagram...yet.....

Bought in Oct 2016 at 55000km, now (Apr 2019) at 73000 km. I like cars...
LMP is offline  
 
post #4 of 10 (permalink) Old 01-30-2018, 07:14 PM Thread Starter
Newbie
 
sassington's Avatar
 
Join Date: Jan 2018
Location: Central Florida
Posts: 4
Drives: 2015 Sorento
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Thanks for looking for me! There is a switch there that I can toggle from “DOOR” to “OFF” and “ON” and the bulb does work but only if the switch is set to “ON” - when I flip it to “DOOR”, the bulb isn’t illuminated.

This makes me think the sensor is broken that tells the vehicle that the tailgate is open so that the light will activate when set on “DOOR”.

I just don’t know what to do at this point. I’ll have to go out and look to see if the light on the instrument panel to see if “gate unlatched”, as you mentioned, is lit.

As suspected, there’s no light on the instrument panel indicating the tailgate is open.

I don’t know what to do at this point. I just don’t know why it works only when set to “ON”


Sent from my iPhone using Tapatalk
sassington is offline  
post #5 of 10 (permalink) Old 01-30-2018, 07:44 PM Thread Starter
Newbie
 
sassington's Avatar
 
Join Date: Jan 2018
Location: Central Florida
Posts: 4
Drives: 2015 Sorento
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Looks like I’ll be taking it to the local Kia dealer. After all, that’s what the warranty is for, right?


Sent from my iPhone using Tapatalk
sassington is offline  
post #6 of 10 (permalink) Old 01-30-2018, 07:56 PM
LMP
Senior Member
 
LMP's Avatar
 
Join Date: Mar 2005
Location: Chicoutimi, Quebec Canada
Posts: 338
Drives: Sorento 2015 LX 2.4 AWD, Suzuki 2011 SX4 AWD, ( 2000 KIA Sportage, junked)
Gallery: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 73 Post(s)

IF the "gate open" sign does not show (you know where it is from the user manual page 4-68 and 4-97 in my 2015 manual) then it is a sign this switch or sensor located in the tailgate is failed...or its signal does not reach or go through the BCM.
OF course, investigation should begin inside the tailgate....but you must consider the condition you describe as serious ...because with all the plastic , there is a risk that something will be broken in attempting this operation. I'll try to figure out from the shop manual I have if the electrical signal can be identified somewhere on a connector....but then you need at least a multimeter....
I'll see what I can find and report later.

Ahhhh...I just read you will have the dealer look at it...OK then.
sassington likes this.

Bought in Oct 2016 at 55000km, now (Apr 2019) at 73000 km. I like cars...
LMP is offline  
post #7 of 10 (permalink) Old 01-30-2018, 08:19 PM Thread Starter
Newbie
 
sassington's Avatar
 
Join Date: Jan 2018
Location: Central Florida
Posts: 4
Drives: 2015 Sorento
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Quote:
Originally Posted by LMP View Post
IF the "gate open" sign does not show (you know where it is from the user manual page 4-68 and 4-97 in my 2015 manual) then it is a sign this switch or sensor located in the tailgate is failed...or its signal does not reach or go through the BCM.
OF course, investigation should begin inside the tailgate....but you must consider the condition you describe as serious ...because with all the plastic , there is a risk that something will be broken in attempting this operation. I'll try to figure out from the shop manual I have if the electrical signal can be identified somewhere on a connector....but then you need at least a multimeter....
I'll see what I can find and report later.

Ahhhh...I just read you will have the dealer look at it...OK then.

Thank you for looking! Getting into multimeters and such is way over my head lol


Sent from my iPhone using Tapatalk
sassington is offline  
post #8 of 10 (permalink) Old 01-31-2018, 12:25 AM
Veteran
 
MikDee's Avatar
 
Join Date: Jul 2011
Location: Milford, PA
Posts: 1,122
Drives: 2015 Sorento EX V6 AWD Ebony Black
Gallery: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 173 Post(s)

IMO, when the tailgate switch is set to door, it should light when you open any door. Theoretically It should also light when you open the hatch in that position. Sorry I never had an occasion to try it at night, but I will soon as I'm curious if so? Don't laugh I had the car a year before I realized there was a switch back there to turn it on so it would work with the rest of the interior lights! (let there be light! ) But, seriously I never tried opening the hatch at night to see if it comes on automatically. If not then it's bad news, it means it's either broken, or not wired to come on independently, when you open the hatch!

Some previous Hyundai/Kia vehicles: 2002 Santa Fe LX V6 AWD, 2005 Tucson LX V6 AWD, 2010 Tucson GLS 2.4L AWD, 2011 Sportage EX 2.4L AWD, 2015 Sorento Ex V6 AWD
MikDee is offline  
post #9 of 10 (permalink) Old 01-31-2018, 06:37 AM
LMP
Senior Member
 
LMP's Avatar
 
Join Date: Mar 2005
Location: Chicoutimi, Quebec Canada
Posts: 338
Drives: Sorento 2015 LX 2.4 AWD, Suzuki 2011 SX4 AWD, ( 2000 KIA Sportage, junked)
Gallery: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 73 Post(s)

Quote:
Originally Posted by MikDee View Post
IMO, when the tailgate switch is set to door, it should light when you open any door. Theoretically It should also light when you open the hatch in that position. ..Don't laugh I had the car a year before I realized there was a switch back there ...!
AS I said before, the cargo light (set on DOOR) comes ON (and gate open light on the IP) only with the tail gate.. , not with any other doors...normal and obviously controlled by the BCM.
AS for features you do not know unless someone asks...well...same for me. It has been 15 months now since I bought it, and myself.....or passengers sometimes, keep finding new surprises ....
BY the way, I do not have remote start.
The user manual is awkward....half of it with yellow alerts about everything....and various properties of same feature stattered all across the manual..so not a model of technical literature....

Bought in Oct 2016 at 55000km, now (Apr 2019) at 73000 km. I like cars...
LMP is offline  
post #10 of 10 (permalink) Old 02-01-2018, 04:36 PM
Full Member
 
Join Date: Aug 2017
Location: Atlanta, GA
Posts: 126
Drives: Sorento SX FWD 2015
Gallery: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 25 Post(s)

Just a bit more info.. on my '15 SX in a dark garage, switch is set to door, same conditions as above, opening other doors does not illuminate cargo light. But if I open the tailgate only, all lights, the front row and second row overheads also come on. Sounds like this ones off to the shop as it still under warranty.. my guess, if cabin lights come on w/tailgate opening then is probably BCM to cargo light circuit, if no cabin lights w/tailgate opening then could be tailgate sensor/open command to BCM.. I don't remember seeing this being a setup option.

I'm Bob, 2015 Sorento SX , 2007 GMC Envoy (tuned) , 1994 Camaro Z28 (modified/custom tuned)

Last edited by bobdec; 02-01-2018 at 04:37 PM. Reason: spelling
bobdec is online now  
Reply

  Kia Forum > KIA Models > Kia Sorento Forum > 2014 - 2015 Sorento Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
2005 Spectra5 Cargo Area Measurements katt42 Cerato (2003 - 2008) & Spectra5 (2004) 6 08-05-2009 10:38 AM
Need help. O/D light blinking and check engine light on. Code P1624. hardworking 2G (1998 - 2001) Sephia 29 01-12-2009 10:22 PM
Light bulbs for 06 Sedona Repsolal Kia Carnival & Sedona 2006+ 2 12-17-2008 10:44 AM
Sorento Gauge Light Problem jimmy8049 2003-2010 Sorento Forum 0 11-30-2008 07:00 PM
Engine Management Light o2 sensor Problem LouLou Kia Picanto Forum 6 05-14-2007 05:03 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On