2011 Sorento TPS Issues - Kia Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 07-15-2018, 07:45 PM Thread Starter
Newbie
 
Join Date: Jul 2018
Location: Kansas city
Posts: 2
Drives: 2011 Sorento
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
2011 Sorento TPS Issues

Hi, recently the check engine came on in my 2011 Sorento, it loses power and goes into limp mode. When I ran the codes there was two issues, the throttle position sensor and the sensor on the gas pedal. I've replaced both but am still having the same issue. Has anyone else come across this? I dont know what to check next.

Msawyer is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 07-15-2018, 08:15 PM
Expert
 
Join Date: Oct 2015
Location: Northeast
Posts: 959
Drives: 2011 Forte SX 2.4L (thankfully MPI) A/T 137K miles
Gallery: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 262 Post(s)

You need to post all of the actual codes, in order for anyone here to have any chance of helping you. And also post which engine is in your vehicle.
kiaguy002 is offline  
post #3 of 6 (permalink) Old 07-15-2018, 10:19 PM
Full Member
 
Join Date: May 2017
Location: Minnesota
Posts: 162
Drives: Sorento 2012
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)

What did you use to read the codes? Which engine do you have? Codes do not tell you what parts are bad but give you a general area that needs to be looked at for troubleshooting. Testing must be done on that area to revile what is causing the issue that tripped the trouble code.
jolt2 is offline  
 
post #4 of 6 (permalink) Old 07-18-2018, 05:45 AM Thread Starter
Newbie
 
Join Date: Jul 2018
Location: Kansas city
Posts: 2
Drives: 2011 Sorento
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Quote:
Originally Posted by Msawyer View Post
Hi, recently the check engine came on in my 2011 Sorento, it loses power and goes into limp mode. When I ran the codes there was two issues, the throttle position sensor and the sensor on the gas pedal. I've replaced both but am still having the same issue. Has anyone else come across this? I dont know what to check next.
Here's some more details- My 2011 Sorento is a V6 3.5. The codes that keep coming up are P2106 and P0121. Both my mechanic and the dealership pulled these codes, the dealership recommended replacing the TPS, I have had issues with the local dealership that makes me not trust them with my car. They have quoted me the wrong price and sold me the wrong parts, so I had my mechanic replace the TPS which in this model means replacing the throttle body as it's built in. When this didn't work we replaced the pedal sensor as well. Any input would be appreciated.
Msawyer is offline  
post #5 of 6 (permalink) Old 07-19-2018, 02:02 PM
Full Member
 
Join Date: May 2017
Location: Minnesota
Posts: 162
Drives: Sorento 2012
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)

So you replaced the throttle pedal assembly and the throttle actuator control (TAC) ie throttle body and still have the check engine light on with the engine in limp in mode (max speed ~15 mph). You only have a little more to check out then, unless one of the new parts is bad also. Bad connections/wiring harness problems with the system or a bad engine control module (ECM). Your mechanic should have been able to check the signals to the ECM for this system with his scanner to verify the proper and smooth changes in voltage values from each of the throttle pedals pots. When he seen that the signal values were not proper, he needs to test each part of the system to find the problem. I would suggest you find a different mechanic that is good with trouble shooting and has the testing equipment and information to troubleshoot these kinds of issues.
jolt2 is offline  
post #6 of 6 (permalink) Old 07-19-2018, 02:28 PM
Super Moderator
 
ron1004's Avatar
 
Join Date: Jun 2005
Location: USA
Posts: 8,469
Drives: 1999 Kia / 기아 Elan, 2017 Ford Edge Sport, 2015 Ford Mustang, 2008 Harley Nightrain
Gallery: 13
Mentioned: 18 Post(s)
Tagged: 0 Thread(s)
Quoted: 712 Post(s)
Garage

Quote:
Originally Posted by jolt2 View Post
So you replaced the throttle pedal assembly and the throttle actuator control (TAC) ie throttle body and still have the check engine light on with the engine in limp in mode (max speed ~15 mph). You only have a little more to check out then, unless one of the new parts is bad also. Bad connections/wiring harness problems with the system or a bad engine control module (ECM). Your mechanic should have been able to check the signals to the ECM for this system with his scanner to verify the proper and smooth changes in voltage values from each of the throttle pedals pots. When he seen that the signal values were not proper, he needs to test each part of the system to find the problem. I would suggest you find a different mechanic that is good with trouble shooting and has the testing equipment and information to troubleshoot these kinds of issues.
Good advice, but bear in mind that this is being relayed to a mechanic that couldn't diagnose the problem correctly, which would have been a relatively simple task with an OBDII scanner (note scanner, not code reader).
I second your advice to find a competent mechanic.

It would be good to hear if these "new" parts were genuine OEM and actually new - many posters here have used that term, only to later confirm that they were used or re-manufactured parts.

Quality and not quantity counts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Sig image is 500X100 at 11.7 kb
ron1004 is offline  
Reply

  Kia Forum > KIA Models > Kia Sorento Forum > 2011 - 2013 (XM) Sorento Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
2011 Sorento EX Badge Replacement mainline 2011 - 2013 (XM) Sorento Forum 8 12-13-2018 01:11 PM
Kia sorento oem 2011 2012 2013 cargo cover retractable cover shade blind scorpioevo8 Parts For Sale / Trade 0 02-02-2018 12:33 PM
2011 Sorento Bluetooth feeezing puddingenie 2011 - 2013 (XM) Sorento Forum 0 12-11-2017 01:24 PM
Mileage on 2011 Kia Sorento BethStuckey 2011 - 2013 (XM) Sorento Forum 3 08-10-2017 12:51 AM
2014 Kia Sorento AWD V6 EX Electrical Issues? Nkutassy 2014 - 2015 Sorento Forum 0 06-09-2017 12:41 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On