Indicator Light//Blinker - Kia Forum
 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 06-12-2018, 09:06 PM Thread Starter
Newbie
 
Join Date: Apr 2018
Location: Winona, MS
Posts: 9
Drives: 2012 Kia Sorento
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)

Thread Starter (Thread Starter)
Indicator Light//Blinker

Hello! I have noticed that my left blinker has been flashing rapidly, much more than the other side. I turned on the hazzards and noticed its the front left light, and when I have the day time running lights on, it usually is very dim or not on at all. Would it be a wiring issue? If not, where can I find a replacement bulb? How do I install it??

2012 Kia Sorento LX

Tilly01 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 06-12-2018, 11:40 PM
Full Member
 
Join Date: May 2017
Location: Minnesota
Posts: 162
Drives: Sorento 2012
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)

You make it sound like it is a wiring issue or poor ground. I would pull both front and rear bulbs, check bulbs with an ohm meter, check the bulb sockets/connectors and spray some WD-40 in the connectors. If a bad bulb is found, replace the bulb. Insert the bulbs back into the wiring connectors two or three times to make sure the connections are good at the bulbs and see if that changes anything. If it is still acting up, you have a wiring or controller problem.
jolt2 is offline  
post #3 of 9 (permalink) Old 06-13-2018, 08:21 AM
Full Member
 
Join Date: Jun 2011
Location: Airdrie AB & Maricopa AZ
Posts: 195
Drives: 2012 Sorento EX-V6 Luxury
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 25 Post(s)

Quote:
Originally Posted by jolt2 View Post
You make it sound like it is a wiring issue or poor ground. I would pull both front and rear bulbs, check bulbs with an ohm meter, check the bulb sockets/connectors and spray some WD-40 in the connectors. If a bad bulb is found, replace the bulb. Insert the bulbs back into the wiring connectors two or three times to make sure the connections are good at the bulbs and see if that changes anything. If it is still acting up, you have a wiring or controller problem.
WD40 on the connectors???? Is it flammable????

Eh!

2012 KIA Sorento EX-V6 Luxury
geeksrus is offline  
 
post #4 of 9 (permalink) Old 06-13-2018, 12:08 PM Thread Starter
Newbie
 
Join Date: Apr 2018
Location: Winona, MS
Posts: 9
Drives: 2012 Kia Sorento
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)

Thread Starter (Thread Starter)
If it is the bulb, what do I replace it with??
Tilly01 is offline  
post #5 of 9 (permalink) Old 06-13-2018, 01:46 PM
Full Member
 
Join Date: May 2017
Location: Minnesota
Posts: 162
Drives: Sorento 2012
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)

Geeksus - Yes it is flammable. If you have an open flame at the connector, it will burn but then if your electrical connector has a open flame in it, you have bigger problems to worry about. If you do not want to use WD-40 (most people have this handy), you can use dielectric grease.


Tilly01 - A new working bulb from the auto parts store.
jolt2 is offline  
post #6 of 9 (permalink) Old 06-13-2018, 04:41 PM Thread Starter
Newbie
 
Join Date: Apr 2018
Location: Winona, MS
Posts: 9
Drives: 2012 Kia Sorento
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)

Thread Starter (Thread Starter)
I just replaced it, didn’t fix anything. The light is still very dim and doesn’t always work, any quick fixes?
Tilly01 is offline  
post #7 of 9 (permalink) Old 06-13-2018, 06:48 PM
Veteran
 
Tapeworm's Avatar
 
Join Date: Nov 2013
Location: California
Posts: 1,140
Drives: 2013 Sorento LX V6 AWD
Gallery: 0
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 254 Post(s)

Used to be a fast-blinking turn signal meant the rear bulb on that side was burnt out. With all the advance electronics & technology these days, don't know if that's still the case or not. Your owner's manual would tell you the bulb # or an auto parts store should be able to look it up for you. Heck, you could probably find it here on the forum or do a Google search.

Live for today as yesterday is gone & tomorrow may never come!
Tapeworm is offline  
post #8 of 9 (permalink) Old 06-14-2018, 12:02 AM Thread Starter
Newbie
 
Join Date: Apr 2018
Location: Winona, MS
Posts: 9
Drives: 2012 Kia Sorento
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)

Thread Starter (Thread Starter)
Already checked the rear, both rears have been fine
Tilly01 is offline  
post #9 of 9 (permalink) Old 06-14-2018, 11:59 AM
Full Member
 
Join Date: May 2017
Location: Minnesota
Posts: 162
Drives: Sorento 2012
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)

Quote:
Originally Posted by jolt2 View Post
If it is still acting up, you have a wiring or controller problem.
See above. ^^^^^^^^
jolt2 is offline  
Reply

  Kia Forum > KIA Models > Kia Sorento Forum > 2011 - 2013 (XM) Sorento Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On