Kia sorento shut off while driving, won't start again - Kia Forum

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 03-12-2017, 06:25 AM Thread Starter
Newbie
 
Join Date: Mar 2017
Location: Sweden
Posts: 1
Drives: Kia sorento 2011
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Kia sorento shut off while driving, won't start again

Our Kia sorento shut of unexpectedly yesterday while driving and we had to get it towed. Start engine runs but the car will not start again. We've checked all the fuses and are unable to locate the problem. Any ideas?

Sent from my ONEPLUS A3003 using Tapatalk

fabiannordstrom9 is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 03-12-2017, 12:52 PM
Veteran
 
Join Date: Sep 2016
Location: USA,WESTERN NY
Posts: 1,756
Drives: 09 kia spectra ex,04 Neon,04 Chry. T&C, 98 Avenger
Gallery: 0
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 364 Post(s)

out of gas? dying fuel pump? Won't run or won't crank over to run?
MIA KIA 09 is offline  
post #3 of 12 (permalink) Old 03-12-2017, 11:31 PM
VIM
Expert
 
Join Date: Sep 2011
Location: Toronto, Ontario, Canada
Posts: 653
Drives: White 2012 SX AWD
Gallery: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 40 Post(s)

It could be the gear selector switch/sensor or whatever it's called.

It will only start if it is in Park or Neutral, I believe...or it thinks it is. If it thinks it is not in P or N then it will not start.

Try shifting into neutral and start it or back to park and try again.
VIM is offline  
 
post #4 of 12 (permalink) Old 03-13-2017, 06:58 AM
Veteran
 
sblake5's Avatar
 
Join Date: May 2014
Location: San Bernardino, Ca.
Posts: 1,079
Drives: 2014 Kia Rio, 2010 Mercedes Benz C300, 2005 Ponitiac GTO, 2017 Chevrolet Colorado 2WT
Gallery: 0
Mentioned: 5 Post(s)
Tagged: 1 Thread(s)
Quoted: 247 Post(s)
Garage

Quote:
Originally Posted by VIM View Post
It could be the gear selector switch/sensor or whatever it's called.

It will only start if it is in Park or Neutral, I believe...or it thinks it is. If it thinks it is not in P or N then it will not start.

Try shifting into neutral and start it or back to park and try again.
That would be a reason for not starting but that wouldn't cause it to stall while driving, however.

2014 RIO LX: Ccruise control, SX console, Ford Taurus spoiler, 3" exhaust tip, K&N filter, dual horns, Proline 950S wheels, catch can, tint. Retired HVAC/MVAC tech.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
sblake5 is offline  
post #5 of 12 (permalink) Old 03-13-2017, 07:18 AM
VIM
Expert
 
Join Date: Sep 2011
Location: Toronto, Ontario, Canada
Posts: 653
Drives: White 2012 SX AWD
Gallery: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 40 Post(s)

Yes, that wouldn't cause the original stall while driving.

I was trying to suggest other reasons that a car wouldn't start and actions to try to make it start again.

The stalling and not restarting could be two different issues.
VIM is offline  
post #6 of 12 (permalink) Old 03-13-2017, 07:28 AM
Veteran
 
Join Date: Sep 2016
Location: USA,WESTERN NY
Posts: 1,756
Drives: 09 kia spectra ex,04 Neon,04 Chry. T&C, 98 Avenger
Gallery: 0
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 364 Post(s)

OP is in Sweden, original battery? how have outside temps been ? extremely cold? POSSIBLE frozen battery? This happened to me once with a Dodge Van...Same description as original poster.
MIA KIA 09 is offline  
post #7 of 12 (permalink) Old 03-13-2017, 01:11 PM
Veteran
 
MikDee's Avatar
 
Join Date: Jul 2011
Location: Milford, PA
Posts: 1,125
Drives: 2015 Sorento EX V6 AWD Ebony Black
Gallery: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 173 Post(s)

Quote:
Originally Posted by MIA KIA 09 View Post
OP is in Sweden, original battery? how have outside temps been ? extremely cold? POSSIBLE frozen battery? This happened to me once with a Dodge Van...Same description as original poster.
Frozen Battery Eek!

Maybe it's a bad battery connection, or it's dirty, corroded? A car will do strange things with a poor battery, or ground connection!

Some previous Hyundai/Kia vehicles: 2002 Santa Fe LX V6 AWD, 2005 Tucson LX V6 AWD, 2010 Tucson GLS 2.4L AWD, 2011 Sportage EX 2.4L AWD, 2015 Sorento Ex V6 AWD

Last edited by MikDee; 03-13-2017 at 01:16 PM.
MikDee is offline  
post #8 of 12 (permalink) Old 03-13-2017, 02:51 PM
Veteran
 
Join Date: Sep 2016
Location: USA,WESTERN NY
Posts: 1,756
Drives: 09 kia spectra ex,04 Neon,04 Chry. T&C, 98 Avenger
Gallery: 0
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 364 Post(s)

Quote:
Originally Posted by MikDee View Post
Frozen Battery Eek!

Maybe it's a bad battery connection, or it's dirty, corroded? A car will do strange things with a poor battery, or ground connection!
A NC van coming to NY, TERRIBLE cold, Battery literally pushed the fill caps OFF ! In Selinsgrove, PA.
MIA KIA 09 is offline  
post #9 of 12 (permalink) Old 03-13-2017, 11:02 PM
Veteran
 
MikDee's Avatar
 
Join Date: Jul 2011
Location: Milford, PA
Posts: 1,125
Drives: 2015 Sorento EX V6 AWD Ebony Black
Gallery: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 173 Post(s)

Quote:
Originally Posted by MIA KIA 09 View Post
A NC van coming to NY, TERRIBLE cold, Battery literally pushed the fill caps OFF ! In Selinsgrove, PA.
It figures! the battery (and it's connections) are under quite a bit of strain on these new computerized vehicles. I once killed the battery on a reliable old around town car, when I took it on a long highway trip! Apparently it cooked from the sudden strain!

Some previous Hyundai/Kia vehicles: 2002 Santa Fe LX V6 AWD, 2005 Tucson LX V6 AWD, 2010 Tucson GLS 2.4L AWD, 2011 Sportage EX 2.4L AWD, 2015 Sorento Ex V6 AWD
MikDee is offline  
post #10 of 12 (permalink) Old 03-14-2017, 01:55 AM
Veteran
 
aquanaut20's Avatar
 
Join Date: Jun 2010
Location: Fraser Valley, BC, Canada
Posts: 2,695
Drives: Caribou, Otter, Buffalo
Gallery: 0
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 251 Post(s)

Quit with the myths and nonsense,

Follow a diagnostic path,

Power (bat) first, then
Ground circuit,
then power and grounds to the ECM..

Guessing will not fix...

... Philip
aquanaut20 is offline  
Reply


Top

  Kia Forum > KIA Models > Kia Sorento Forum > 2011 - 2013 (XM) Sorento Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Sorento LX 2004 won't start battery or ? bealert 2003-2010 Sorento Forum 4 03-08-2018 06:15 AM
2016 sorento winter start - whistling sound Wakesup 2016+ Sorento 10 01-17-2018 12:10 PM
2012 kia sorento lx, remote start Dadstwns 2011 - 2013 (XM) Sorento Forum 1 12-23-2017 06:22 PM
2007 Sorento 3.8L V6 4x4 - mystery failure to start & cut-outs NorseRaider 2003-2010 Sorento Forum 9 03-20-2017 07:01 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On