03 Sorento 4X4 Prob!! - Kia Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 10-13-2010, 03:28 PM Thread Starter
Newbie
 
Join Date: Oct 2009
Posts: 3
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
03 Sorento 4X4 Prob!!

Hi all... 2003 Sorento; when I turn the happy 4x4 knob, I hear a slight click, the 4X4 Hi light comes on, but it does not engage!?!?!? I've been told it's an electrical problem, but I have no idea what to look at / for.
Any thoughts?
Thanx
Jim

BlueDenver is offline  
Reply

  Kia Forum > KIA Models > Kia Sorento Forum > 2003-2010 Sorento Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Towing 5000 lbs with the Sorento - Myths and facts rocky_baker 2016+ Sorento 20 08-27-2018 05:12 PM
2019 Sorento and Towing Larathydo 2016+ Sorento 3 08-22-2018 07:41 PM
'16 Sorento vs '17 CX-9 jenwest99 2016+ Sorento 22 05-01-2016 12:24 PM
2017 Sorento Info mjonis 2016+ Sorento 11 03-10-2016 03:44 PM
Moved from Sedan car to SORENTO and the first impression ! Zaher 2003-2010 Sorento Forum 3 11-04-2007 11:49 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On