Ticking Noise After Icv Recall Completed - Kia Forum

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 07-20-2010, 09:34 AM Thread Starter
Newbie
 
Join Date: Jun 2010
Location: USA
Posts: 16
Drives: 2005 KIA SORENTO USA
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Ticking Noise After Icv Recall Completed

ICV recall work recently completed in 2005 Sorento. Serious damage to engine due to ICV, Sorento towed to dealership. 8 days in shop to repair due to back log at dealership. While in shop also agreed to have serpentine and timing belt changed, transmission fluid changed, spark plugs replaced and oil change. 8 day car rental and $450 later car was ready for pick up. Morning after pick up from service and ever since at start up there is a ticking noise that lasts for first few miles driven then stops. This noise never occured prior to the morning after picking up. Went back to dealership where car was fixed but of course the noise was not recreated because the car was already warmed up. Aprox 5 days after getting car back the battery died. Just recently the AC stopped cranking out cold air. This was all of a sudden, after a 1.5 hr drive with the ac working great it just started blowing warm air. There was no gradual temp increase. I was told by the service manager to bring my car in and leave it over night so that the ticking noise can be heard, since it only happens when the car is started once cooled. While I plan to do this it's just a matter of when I can, already had to rent a car for 8 days. I have a couple questions - Could this ticking noise be some further damage caused by the ICV clip, something they missed when doing the engine repairs? (2) could replacement of either of the belts cause my battery to die and my AC suddenly stop blowing cold air?


Last edited by nosretep; 07-20-2010 at 09:42 AM.
nosretep is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 07-20-2010, 09:52 AM
PLP
Super Moderator
 
PLP's Avatar
 
Join Date: Dec 2008
Location: Haslett, MI, USA, Earth
Posts: 6,809
Drives: 2016 FIAT 500X Trekking Plus AWD; 2016 Kia Forte5 SX 1.6T A/T
Gallery: 3
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 330 Post(s)
Garage

2005 Sorento - is it AUS? UK? USA? Please, fill out profile. How many miles you have on it?

As per ticking - sounds to me like a valve issue. Not getting oil right away... maybe wrong oil filter? Maybe lifter is stuck...

Belts could have something to do with A/C, but not directly. Does clutch engage? Do you hear this typical "click" when A/C supposed to engage?
Sudden loose of cold air (if not damage to radiator on the road and sudden leak of the fluid) could be related to disconnected/failed pressure sensor, blown fuse, damaged relay...


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
USA - paid, repair manual

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Canadian owner manuals (still free)

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Europe - paid, repair manual

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Do you talk/text and drive? Watch it. Very interesting test:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
PLP is offline  
post #3 of 7 (permalink) Old 07-20-2010, 05:36 PM
Veteran
 
Join Date: Dec 2005
Location: Middleton, Idaho
Posts: 2,322
Drives: 2003 S-10 Had an 03 LX 3.5 Sorento
Gallery: 0
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 93 Post(s)

Unless they failed to remove all the damaged parts when they removed the old ICV ......
If it was a part, the engine would probably run the way it did when you took it in.
Your ticking sound, sounds like your describing a lifter running dry for those first few miles. Mine does it if the Sorento has been in the garage for more than three or four days. "Lifter leak down" I think is what it is called. I don't believe the Sorento has a typical "Lifter" but it is a hydraulic unit. Did they change the oil after the repair? They may have got a chemical used for cleaning in the oil and thinned it out. That might allow the lifter to leak down quicker. On the A/C: check the coolant reservoir. If the level is low or or empty it may be causing the the freon to get to high of a pressure due to heat and causing the compressor to drop out.
Hope this helps.
nstoolman1 is offline  
 
post #4 of 7 (permalink) Old 07-20-2010, 05:45 PM
Full Member
 
Join Date: Dec 2008
Posts: 87
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Check the belt on the a/c and make sure they tightened it and it not just hanging there, or not there. All the assoc. belts have to be removed when doing the timing belt. Maybe the tech punchered an a/c line while doing the repair. Just a thought.
jmoore16 is offline  
post #5 of 7 (permalink) Old 07-21-2010, 10:41 AM Thread Starter
Newbie
 
Join Date: Jun 2010
Location: USA
Posts: 16
Drives: 2005 KIA SORENTO USA
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Thanks for the responses. Here is more info : It's a kia '05 USA, gas - aprox 81k mi.
If it was a part, the engine would probably run the way it did when you took it in - car was towed from lot,pulled into parking lot, immediate power failure, engine loud 'whine' noise, no power stearing, never had/heard the ticking noise until the morning after bringing home from dealership after ICV repair. The butterfly clip did lots of damage I was told, could it have damaged a lifter causing this 'lifter leak down'?
Did have oil change as well at some point during it's 8 days in the shop. All belts changed, tran fluid changed, all spark plugs changed.
Regarding the AC - not sure what it means for the clutch to 'engage'. Ticking noise is at startup, does not matter if ac is on or not. If an a/c line was punctured by the mechanic at time of icv repairs could the ac have worked for 3 1/2 wks after and then suddenly stop blowing cold air?
nosretep is offline  
post #6 of 7 (permalink) Old 07-21-2010, 02:35 PM
Veteran
 
Join Date: Dec 2005
Location: Middleton, Idaho
Posts: 2,322
Drives: 2003 S-10 Had an 03 LX 3.5 Sorento
Gallery: 0
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 93 Post(s)

Quote:
The butterfly clip did lots of damage I was told, could it have damaged a lifter causing this 'lifter leak down'?
Not unless the pieces punched a hole in the intake system and found their way into the engine internals

Quote:
Regarding the AC - not sure what it means for the clutch to 'engage'.
The clutch is an electro-mechanical device that when energized causes the spinning hub on the A/C compressor to lockup so to speak thus spinning the A/C compressor.
nstoolman1 is offline  
post #7 of 7 (permalink) Old 01-07-2011, 04:56 PM
Newbie
 
Join Date: Jan 2011
Posts: 1
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

the a/c compressor belt might have broken or came loose, this would explain the sudden loss of cold air. Low gas might as well.
rdhamill is offline  
Reply

  Kia Forum > KIA Models > Kia Sorento Forum > 2003-2010 Sorento Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Clicking / ticking noise from front left ujjc001 Kia Carnival & Sedona 2006+ 3 08-29-2017 05:50 PM
How to permanently solve engine ticking noise with ONLY 10 CENT! Blkid 2G (2006 - 2011) Rio & Rio5 2 02-11-2017 11:23 AM
The Mysterious Honking Noise redsoxmk 3G 2011 - 2016 Sportage 13 07-29-2015 09:27 AM
Strange ticking noise when cold. mozart999uk Cerato (2003 - 2008) & Spectra5 (2004) 14 10-01-2009 02:54 AM
Ticking noise when braking - axle shafts? JoeWag 1G (2001-2005) Rio 8 01-17-2009 09:43 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On