Help Needed with P0106 - Kia Forum
 1Likes
  • 1 Post By ajdragon
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 07-03-2019, 11:52 PM Thread Starter
Member
 
Join Date: Mar 2019
Location: Pierce County WA.
Posts: 59
Drives: 2003 Kia Sorento EX
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)

Thread Starter (Thread Starter)
Help Needed with P0106

Hi

Another code has shown up, a P0106 and I have no idea how to fix it. I think the code has something to do with the MAP sensor but I'm not sure. What really has me confused is that the MAP sensor is on the fuel tank instead of on or near the intake manifold like everyone says it should be. Could someone please confirm where the MAP sensor is at and what it looks like.


Last edited by ajdragon; 07-04-2019 at 12:31 AM.
ajdragon is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 07-04-2019, 12:45 AM
Veteran
 
Join Date: Dec 2005
Location: Middleton, Idaho
Posts: 2,335
Drives: 2003 S-10 Had an 03 LX 3.5 Sorento
Gallery: 0
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 96 Post(s)

Found this

HTH

Re: Check engine still on after replacing map sensor code p0106 Quote Post by tarekaziz Mon Apr 24, 2017 4:05 am For those who get a 'Check engine light ' with DTC P0106 after changing or disconnection of battery should do the following steps:
1) Disconnect the negative connection of the battery
2)Clean the throttle body thoroughly with throttle body cleaner (this is needed in order to recalibrate the IDLE position which has been lost due to battery disconnection)
3) Reinstall back all the intake ducts which were removed and check again that there are no intake leaks or pipes open.
4)Connect the battery back again.
5)Start the vehicle and let it IDLE for 10minutes.( Don't press the accelerator or REV up the engine in these 10minutes because the computer is learning the IDLE position ).
6) Finally when the TPS has learned it's idle position there should be no DTC output for MAP sensor.

Read more at: https://www.obd-codes.com/forums/vie...t=13365#p55821
Copyright OBD-Codes.com
nstoolman1 is offline  
post #3 of 7 (permalink) Old 07-04-2019, 12:58 AM Thread Starter
Member
 
Join Date: Mar 2019
Location: Pierce County WA.
Posts: 59
Drives: 2003 Kia Sorento EX
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)

Thread Starter (Thread Starter)
Hi

I'll give it a try tomorrow, and report back, also what does DTC stand for?

Which of these is the MAP sensor?
Attached Thumbnails
Click image for larger version

Name:	IMG_4243.jpg
Views:	12
Size:	120.3 KB
ID:	105888   Click image for larger version

Name:	IMG_4244.JPG
Views:	12
Size:	722.1 KB
ID:	105890  

Last edited by ajdragon; 07-04-2019 at 01:03 AM.
ajdragon is offline  
 
post #4 of 7 (permalink) Old 07-04-2019, 08:42 AM
Veteran
 
Join Date: Dec 2005
Location: Middleton, Idaho
Posts: 2,335
Drives: 2003 S-10 Had an 03 LX 3.5 Sorento
Gallery: 0
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 96 Post(s)

I would guess that the 4244 jpg is the one. I would think the manifold absolute pressure would be attached to the manifold.

DTC Diagnostic Trouble Codes
nstoolman1 is offline  
post #5 of 7 (permalink) Old 07-04-2019, 03:01 PM Thread Starter
Member
 
Join Date: Mar 2019
Location: Pierce County WA.
Posts: 59
Drives: 2003 Kia Sorento EX
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)

Thread Starter (Thread Starter)
Hi

Thank you nstoolman1 for that information.

I reset the computer and did the 10 minute idle and everything seams to be working OK, and no C.E.L. so far. I'll post if it happens again.
nstoolman1 likes this.

Last edited by ajdragon; 07-04-2019 at 03:04 PM.
ajdragon is offline  
post #6 of 7 (permalink) Old 07-10-2019, 12:12 AM Thread Starter
Member
 
Join Date: Mar 2019
Location: Pierce County WA.
Posts: 59
Drives: 2003 Kia Sorento EX
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)

Thread Starter (Thread Starter)
Hi

Well the code came back, and I don't have the foggiest idea what to do now.
ajdragon is offline  
post #7 of 7 (permalink) Old 07-10-2019, 08:06 AM
Veteran
 
gee6's Avatar
 
Join Date: Jan 2006
Location: Rural Bedfordshire, UK.
Posts: 1,650
Drives: 08 2.5 CRDI Sorento Titan Auto
Gallery: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 65 Post(s)

https://www.yourmechanic.com/article...by-john-nelson

Read down the linked page for possible causes and repairs.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
gee6 is offline  
Reply

  Kia Forum > KIA Models > Kia Sorento Forum > 2003-2010 Sorento Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On