Flickering Battery/charge and stop light - Kia Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 04-20-2017, 10:49 AM Thread Starter
Senior Member
 
Spencernj's Avatar
 
Join Date: Jan 2011
Location: France, Pas-de-Calais
Posts: 268
Drives: Kia Ceed, MGTF, Various Jeeps new and old, FIAT 500
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Flickering Battery/charge and stop light

Yesterday, I a strange problem started to occur. Very intermittently the charge light (and stop/brake) light flicker on my 2009 EX 2.5. (103,000 miles but well maintained since I got it, but no comment on the main Dealer$ efforts, and in v good condition)

I have checked the obvious (belt), connectors, battery (indicator green). Put a voltmeter on the battery stopped and running (both readings correct and stable at different revs). Turned on everything electrical (voltage stable @ 14.2 volts drops to 14.09 when everything is turned on full, but measured inside not at the battery as didn't have a helper). I may be imagining things but when it flickers I may also have a momentary lack of power (like a singe misfire on a petrol). Earth straps seem fine, and have swapped the MAIN relay with one of the accessory ones. (P/WIN). It looks like one of those intermittent faults that I may have to let get worse before I can find the cause unless anyone has experienced anything similar.

Spencernj is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-20-2017, 06:31 PM
Veteran
 
Join Date: May 2011
Location: New Hampshire, USA
Posts: 2,155
Drives: '96 Camry v6 XLE, '00 Camry LE
Gallery: 3
Mentioned: 11 Post(s)
Tagged: 0 Thread(s)
Quoted: 125 Post(s)

Greetings,

How old is the Battery? Has it been load tested?

Original alternator? Any noise from alternator, or accessory tensioner / idler pulley, if equipped? Has it been load tested?

Edit: Have -all- fuses and relays been checked in the engine and passenger cabin compartments for condition / voltage / to ensure they are seated firmly in sockets?

Any aftermarket (lighting, audio, starting, etc.) accessories installed? If so, have they been disconnected / wiring reset to factory stock to see if the issue lessens / goes away?

^^ Above, with cleaning battery terminals & primary ground points would be where I would start, if here.

Regards,
GottaCruise

Laptop/USB OBD-II Scanner at Amazon: search "ScanTool 423001 ElmScan 5" at amazon.com
OBD-II Codes:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by GottaCruise; 04-20-2017 at 06:35 PM. Reason: Check all fuses/relays for condition as a primary diagnostic step..
GottaCruise is offline  
Reply

  Kia Forum > KIA Models > Kia Sorento Forum > 2003-2010 Sorento Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Fog Light stop working after ... Spyde 3G 2011 - 2016 Sportage 8 10-29-2017 11:18 AM
2007 Optima Dome Light Problem lifterguy 3G (2006.5+) Magentis & Optima 0 10-10-2017 05:04 PM
Stop light bar on 5th door trunk (leak) tcrbio 3G (2012 - 2017) Rio 6 02-08-2017 06:08 AM
Rough idle at stop light charlieg 1G (2001-2005) Rio 13 03-25-2010 08:01 AM
Light bulbs for 06 Sedona Repsolal Kia Carnival & Sedona 2006+ 2 12-17-2008 10:44 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On