Kia Forum - View Single Post - What is wrong with this Forum!

View Single Post
post #24 of (permalink) Old 04-20-2017, 08:58 AM
Loyale 2.7 Turbo
Veteran
 
Loyale 2.7 Turbo's Avatar
 
Join Date: Dec 2009
Location: French Harbour, Roatán; Honduras.
Posts: 2,767
Drives: 1985 Subaru Loyale (wagon), 2000 Kia Sephia (sedan), and 1969 Mercury Comet (coupé)
Gallery: 0
Mentioned: 10 Post(s)
Tagged: 1 Thread(s)
Quoted: 145 Post(s)
Garage

I Agree

Quote:
Originally Posted by mechanizeddeath View Post
I see you also have a Subaru. Not sure if you had it in 1999...
Yep, I have my Subie since New in 1985 (My Avatar photo), it came running from California (USA) to Honduras (Central America), already surpassed 400K Miles and thanks God it still runs strong; I accessed the Ultimate Subaru Club online since the EZ boards time, around 1999 and I've seen that mere change on web forums, lately:

Quote:
Originally Posted by mechanizeddeath View Post
... The Subaru scene is a perfect example of that happening: a community filled with helpful folks that was slowly taken over and replaced with vaping, flat-billed dudebros talking about "stance." ...
Also, the Facebook groups are becoming something like "Do you know how to fix ..." and people adding web links to the Forums' threads, but no new posts are being added... the discussion continues on Facebook Groups...

Kind Regards.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Loyale 2.7 Turbo is offline