Stange engine noise - Kia Forum
User Tag List

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 12-01-2012, 08:30 PM
Newbie
 
Join Date: Dec 2012
Location: Columbus Oh
Posts: 7
Drives: 02 Kia Spectra, 06 f-150, 79 CJ 7
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

(Thread Starter)
Default Stange engine noise

Hello,
I have an 02 Spectra with roughly 140,000 on it. When I bought it at 128,000changed the timing belt and plugs just to be sure on the upkeep. Last week the engine started making a strange noise. The best I can describe it is it sounds like an exhaust leak but it is coming from the intake side. The engine runs fine with no hesitation or anything like that. I do catch a small whiff of gas when I start it up in the morning. The trouble codes that came up are 0325 and 0340. I changed the knock sensor, haven't changed the camshaft sensor yet. Any ideas would be appreciated.
Thank you,
Robert
navybee is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 12-01-2012, 11:32 PM
Super Moderator
 
DavesSpectra's Avatar
 
Join Date: Jan 2010
Location: Massillon, Ohio, USA
Posts: 4,427
Drives: 2007 SpectraLX, 2006 SpectraSX, Kubuntu
Gallery: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 18 Post(s)

Default

With your Spectra being 10 years old I'd suggest that you check all rubber hoses like for the pcv valve, vacuum lines to the power brake booster and the gas lines. The tend to get soft or brittle and will allow "illegal" air to get into the engine (or gas to drip out)..
Also with it's age check the ground wires bolted to the engine/body/frame and the connectors on the engine wiring harness for corrosion... The sensors may be fine...the grounds or connections may be at fault.
Dave
DavesSpectra is offline  
#3 (permalink) Old 12-02-2012, 02:45 AM
Newbie
 
norcalkia's Avatar
 
Join Date: Feb 2009
Location: Hayward, Ca.
Posts: 15
Drives: 03 Kia Spectra, 08 F150 SCREW 2WD, 98 Plymouth Voyager
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

I had a similar situation with my 03. It was leaking from the Fuel Pulsation Damper which is mounted on the end of the fuel rail "passenger side". Sometimes an exhaust leak could be a noisy injector. I would get a mechanics stethoscope 'HARBOR FREIGHT" and have a listen around.
Post what you find.
Cheers,
Tony

Last edited by norcalkia; 12-03-2012 at 12:35 AM.
norcalkia is offline  
#4 (permalink) Old 12-06-2012, 04:49 PM
Newbie
 
Join Date: Dec 2012
Location: Columbus Oh
Posts: 7
Drives: 02 Kia Spectra, 06 f-150, 79 CJ 7
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

(Thread Starter)
Default More information

Hello all,
Thanks for all the information. I did pick up the stethascope and checked all around the injectors. All had the same harmonics so I don't think it is them also checked all the hoses and grounds. It seems that the noise is coming from the intake manifold near the throttle body. Is there anything inside that will loosen up when driven. Also the noise increases when driven for a period of time and the engine warms up. Don't think it is the gasket for the intake manifold, took starting fluid and sprayed around them with the engine running and the rpm did not change, so its not sucking air that way. I hope this information will help with a diagnosis. i am used to working on jeeps not cars so this problem is throwing me a curve ball.
Thanks again,
Robert
navybee is offline  
#5 (permalink) Old 12-07-2012, 01:05 AM
Super Moderator
 
DavesSpectra's Avatar
 
Join Date: Jan 2010
Location: Massillon, Ohio, USA
Posts: 4,427
Drives: 2007 SpectraLX, 2006 SpectraSX, Kubuntu
Gallery: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 18 Post(s)

Default

Sounds like the IAC (Idle Air Control) valve is noisy...Does it sound like a "buzz"?
They get noisy...How's your car's idle? Does it stall or increase in RPM by itself?
Dave
DavesSpectra is offline  
#6 (permalink) Old 12-07-2012, 02:19 PM
Newbie
 
Join Date: Dec 2012
Location: Columbus Oh
Posts: 7
Drives: 02 Kia Spectra, 06 f-150, 79 CJ 7
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

(Thread Starter)
Default

Hello,
It normally idles smooth. I have noticed it idle a little rough lately. The only time it stalls is when I don't give it engough gas and basically pop the clutch ( big work boots does not do real good with small peddles designed for a womans foot) . I will take the IAC out and try to clean it or see if I can see if there is something loose or what. Thanks for the reply.
Robert
navybee is offline  
Reply

  Kia Forum > KIA Models > Kia Cerato, Shuma & Spectra Forum > Shuma & Spectra (1997-2003)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On