2007 Hyundai Sante fe transmission problems - Kia Forum
 1Likes
  • 1 Post By Tape
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 11-21-2015, 04:32 PM Thread Starter
Newbie
 
Tape's Avatar
 
Join Date: Aug 2015
Location: Panama city, Fl
Posts: 20
Drives: '12 2.0l Soul auto
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)

Thread Starter (Thread Starter)
2007 Hyundai Sante fe transmission problems

Hello people, I know it isn't a Kia but it's close and I rather deal with Kia owners here and maybe this will be as far as I need to go

My sister's 2007 Hyundai Santa Fe has 168k without any prior problems and has never serviced the automatic transmission either, the fluid is a brownish pink and has a "working fine" smell and not a burnt smell. Fluid level is about a pint to much because before they contacted me they put that Lucus transmission crap in it but did not tell me this until I told them someone put something in it because they spilled it all over the battery like they tried to add it without a funnel.

When you first start it you can go into sport mode and put it in first and it will remain there until you up shift it to 2nd, when you upshift it; it jerks and bucks then goes to 3rd without upshifting, from there on it will not go back into 1st until you shut it off and remove the key, wait a few seconds then you can repeat the same function.

If you start off going directly into drive it will start in 1st then within a second or 2 seconds it will go straight to 3/drive. It will remain there until you shut it off and repeat the start up.

The transmission does not feel like it is slipping at all and functions well but will not downshift. I plan to remove the pan and check the filter and see if there is a restriction, it seems as if it has a restriction because it jerks and bucks before changing while using sport mode and at that moment it seems to slip for a second.

That's about it right now, I will not do anything until tomorrow (Sunday)

I hope you people can assist me and give me some ideas.


Last edited by Tape; 11-21-2015 at 05:14 PM.
Tape is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 11-22-2015, 08:18 AM
Veteran
 
Jeff.G's Avatar
 
Join Date: Apr 2015
Location: Essex England
Posts: 1,503
Drives: Gen 1 Vanilla Soul Shaker 1.6 crdi Auto 2013
Gallery: 0
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 167 Post(s)
Garage

Hi the correct fluid and level is very important. The transmission sounds like it is going into 3rd as Safe Mode.
It is unlikely you will get all the bad fluid out in one drain and refill so plan for two.
After running for a few weeks do the second change Hot before fluid has chance to settle and fibres from friction plate wear drop back into sludge formation.
The first change could be done hot but because of burning dangers may be best to familiarise with procedure when cool.
It is not the burning this rarely happens with these boxes it is the sludge and fluid deterioration from the friction plate materials.

Jeff
Jeff.G is offline  
post #3 of 3 (permalink) Old 11-26-2015, 09:28 PM Thread Starter
Newbie
 
Tape's Avatar
 
Join Date: Aug 2015
Location: Panama city, Fl
Posts: 20
Drives: '12 2.0l Soul auto
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)

Thread Starter (Thread Starter)
Thanks Jeff but she took it to a shop and all that they said was it needed a "Sensor" they are vague on telling the exact part because many of us will do the job on our own. The job was $550 otd and I assume it was a $50 part. Best Holidays to you my friend.
Jeff.G likes this.
Tape is offline  
Reply

  Kia Forum > General > Other Cars



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On