kia sedona running hot - Kia Forum
User Tag List

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 05-03-2011, 05:53 PM
Newbie
 
Join Date: May 2011
Location: georgia
Posts: 2
Drives: kia sedona, 2005
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

(Thread Starter)
Default kia sedona running hot

I have a kia sedona, 2005, 3.5 engine. Husband changed thermostat today, but it is still running hot. the heat hand goes above 3/4 of way to H and today went all the way up twice. driving at 55 it does usually go back down below to regular setting. what else do we need to try. mechanic told him it was not the water pump. is there a second thermostat under the large radiator hose?? any help or suggestions would be appreciated.
melba is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 05-03-2011, 08:50 PM
Veteran
 
Join Date: Feb 2010
Location: CNY-USA
Posts: 1,016
Drives: 2004 Optima 2.4 EX, 2005 Yamaha R1 (street) 2001 GSXR 1000 (track)
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

How's the coolant level? Any leaks? We've had big problems with the rear coolant lines.

NEW MEMBERS- Please fill in your profile info in the "user CP" link (year, make, model, location, etc..), it makes it easier for us to help you.
Go to www.kiatechinfo.com and register for free for service information.
mattybyzf is offline  
#3 (permalink) Old 05-03-2011, 09:00 PM
Veteran
 
Join Date: Mar 2010
Location: Southwest PA
Posts: 1,409
Drives: 10 Optima LX, 07 Rondo EX, 89 Chevy C1500
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)

Default

How bad and for how long did the van overheat before you changed the thermostat? Was the coolant low when the t-stat was changed? Have the rear heater lines been replaced? Are the fans running when it is hot?
spongebob218 is offline  
#4 (permalink) Old 05-04-2011, 05:43 AM
Newbie
 
Join Date: May 2011
Location: georgia
Posts: 2
Drives: kia sedona, 2005
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

(Thread Starter)
Default

van started running hot this past weekend, so about 5 days now, we will put coolant in it today and see if that helps. thanks for help . I will update if it works or not
melba is offline  
Reply

  Kia Forum > Welcome > New Member Area/Introduction


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On