spiders - Kia Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 10-03-2011, 08:12 PM Thread Starter
Newbie
 
Join Date: Oct 2011
Posts: 1
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
spiders

i got a kia rio 2 months ago and i have spiders in it at least 2 a day i kill, dont have them in any other vehicles in the driveway,, does anyone else have this problem,, its weird

pattibain is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 11-10-2011, 06:04 PM
Member
 
Join Date: Nov 2011
Location: Lakeside-Marblehead, Ohio
Posts: 74
Drives: 2008 Rio LX, 2007 Honda Shadow (Bike)
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

YES! I had the same problem! I used to get webs all the time, haven't actually seen one yet. There are a lot of spiders where I live. I almost completely eliminated it. Turns out my Rio, and probably all of them, didn't come with a cabin air filter installed. I put one in and they don't seem to be able to get around it too well. Pretty damn cheap to not put one in in the factory. They're usually located behind the glove compartment. My filter was around $12 I think. Got it at Autozone and they had it in stock. Also, you get a lot of dust and debris without it. Much better afterwards! Good Luck!
wadmancpu is offline  
post #3 of 5 (permalink) Old 03-15-2012, 05:17 AM
Full Member
 
PowerWagon's Avatar
 
Join Date: Mar 2012
Location: Near Boston
Posts: 123
Gallery: 0
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)

lol, I have them in every car I own including my Rio, they're those gross semi-transparent yellowish ones that always run out on the windshield in the middle of traffic and scare the crap out of me. Could be worse though, I used to have mice jump out of the dash and run up my legs while driving my old Mustang!

Current cars: '03 Rio, '98 S-10, '03 Taurus, '02 Rio, '05 Prius
PowerWagon is offline  
 
post #4 of 5 (permalink) Old 04-27-2012, 11:40 AM
Newbie
 
Join Date: Apr 2012
Posts: 3
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Spiders

I had spiders too - last year. I couldn't tell where they were coming from. It seemed to be from the dash area. I replace my in cabin filter on a regular basis and wonder if the one at the time had eggs in it. I did a lot of reading on the internet and tried everything from spraying Fabreeze in the vents to having it detailed. I ended up spraying the interior of the car with Raid and left it closed for 24 hours. I wiped everything down afterwards and, other than the smell, no more spiders. It's a bit extreme but it did work. Good luck!
Charleigh is offline  
post #5 of 5 (permalink) Old 05-24-2012, 01:19 PM
Newbie
 
417RIO's Avatar
 
Join Date: May 2012
Location: Greene County,Missouri
Posts: 9
Drives: 2011 Kia Rio LX
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

I used to get spiders in my Ranger be4 I sold it during the summer time. Charleigh is right had to use bug spray to rid of them. Mother nature at its finest.
417RIO is offline  
Reply

  Kia Forum > KIA Models > Kia Rio Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On