'05 Optima Driver Door WON'T Unlock - Kia Forum
User Tag List

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 02-10-2010, 01:19 PM
Newbie
 
Join Date: Feb 2010
Posts: 3
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

(Thread Starter)
Default '05 Optima Driver Door WON'T Unlock

Good Afternoon,

I have been having this frustrating problem for about 2 months now. My driver's side door will not unlock either from the outside or the inside. At least, not consistently. Every once in a while I can get it open with the key but never from the inside if it's locked. I searched the forum and couldn't find any solution. If anyone has any suggestions on how to solve this issue on my own without having the need to take my car to my mechanic or my dealer (hoping to save some $$$$) I would appreciate any assistance.

Thanks in advance
Hollywood118 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 02-10-2010, 01:48 PM
Memorial Super Moderator
 
pulsar86's Avatar
 
Join Date: Jul 2009
Location: Sunshine Coast,Queensland, Australia
Posts: 2,863
Drives: 2005 Kia Cerato LD [2L petrol] manual, 1986 Nissan Pulsar hatch
Gallery: 3
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Default

Welcome to the KIA forums. When you use the remote do you hear the electric solenoid in the door trying to operate at all? If you can hear the solenoid trying to move it most likely is not at fault as they are fairly simple with a single winding and usually are fairly reliable. You will have to remove the trim to check that the solenoid is getting full power supply and that terminals are clean and tight on the solenoid. The main other thing to look for is that the adjusting screws on the activating rods to the lock are tight and that they are not fouling on any thing to stop the solenoid from moving through it's full range of movement to activate the catch and that the mechanism is lubricated..

TAKE YOUR TIME, THINK IT OUT, DO IT RIGHT, DO IT ONCE!! original quote by me as far as I know. :rolleyes:
ALL MEMBERS PLEASE FILL IN USER PROFILES. DETAILS HELP OTHER MEMBERS HELP YOU .

Last edited by pulsar86; 02-10-2010 at 01:50 PM. Reason: typo
pulsar86 is offline  
#3 (permalink) Old 02-10-2010, 02:43 PM
Newbie
 
Join Date: Feb 2010
Posts: 3
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

(Thread Starter)
Default

Pulsar86,

Thanks for the reply. Unfortunately, I do not have a remote for the locks. I also probably should have mentioned that when I am able to get the door open, I can successfully lock the door and close the latch on the side and then unlock and use the handle to pop the latch open, both from the inside and outside. It's very mind boggling as well as frustrating as I have to climb through the passenger side of the car to get in and out.
Hollywood118 is offline  
#4 (permalink) Old 02-10-2010, 06:57 PM
Full Member
 
Join Date: Jan 2010
Posts: 82
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

Sounds like you need to replaced the door latch. I just replaced one today for the same issue. The latch has a return spring on it that may become damaged and will not allow the latch to unlock. Once unlocked the door works properly until locked again then you would not be able to unlock again with out struggling
cdavis is offline  
#5 (permalink) Old 02-10-2010, 08:29 PM
Newbie
 
Join Date: Feb 2010
Posts: 3
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

(Thread Starter)
Default

So is this a part I'd be able to get at a local auto parts store or do I have to get it from a dealer?
Hollywood118 is offline  
#6 (permalink) Old 02-11-2010, 03:24 PM
Newbie
 
Join Date: Feb 2010
Posts: 1
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

I,m having the exact same problem. It's a real pain!
el-gringo is offline  
#7 (permalink) Old 02-11-2010, 03:49 PM
Veteran
 
Join Date: Feb 2010
Location: CNY-USA
Posts: 1,016
Drives: 2004 Optima 2.4 EX, 2005 Yamaha R1 (street) 2001 GSXR 1000 (track)
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

+1 on CDAVIS's reply. Definitely sounds like a latch problem. I'm pretty sure this is a dealer only part. They're not to bad to replace, but the door lock actuator HAS to be removed with the latch, and seperated once both parts have been remove together. Be careful of the little plastic clip that secures the 2 parts together at the link rod. It does comes off, just be gentle and use a small pick or screwdriver to remove it.
mattybyzf is offline  
#8 (permalink) Old 06-20-2014, 09:20 AM
Newbie
 
Join Date: Jun 2014
Posts: 1
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default 2005 KIA driver door won't open 6-2014

Quote:
Originally Posted by Hollywood118 View Post
Good Afternoon,

I have been having this frustrating problem for about 2 months now. My driver's side door will not unlock either from the outside or the inside. At least, not consistently. Every once in a while I can get it open with the key but never from the inside if it's locked. I searched the forum and couldn't find any solution. If anyone has any suggestions on how to solve this issue on my own without having the need to take my car to my mechanic or my dealer (hoping to save some $$$$) I would appreciate any assistance.

Thanks in advance
6-20-2014 The above message from 2010, talks about the exact same thing that is happening to my 2005 KIA this month. I saw suggestions on how to fix the problem and was curious how "Hollywood118" finally resolved the problem.

If anyone has fixed this problem please reply as I have to deal with this now too.

Thanks.
Hirst2005KIA is offline  
Reply

  Kia Forum > KIA Models > Kia Magentis & Optima Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On