ughh, car making a whining noise when accelerating. help... - Kia Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 04-17-2009, 04:32 PM Thread Starter
Newbie
 
Join Date: Apr 2009
Posts: 14
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default ughh, car making a whining noise when accelerating. help...

the problems continue to rack up with this car. Since ive bought it ive had

a front drivers side door unable to open
rear power lock needed a new actuator
new timing belt
engine took much to long to catch on startup
taillight went out
alarm kept going off
one of the belts needed dressing


NOW i can hear this whining noise coming from the engine when accelerating.

It seems only to happen at around 3000 rpm when accelerating at a good pace from stop signs and such

What could this be and how can i fix it myself?
Janks01 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 10-09-2009, 07:00 PM
Newbie
 
Join Date: Jul 2008
Posts: 10
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

you driving it like a dragster?
NorthIdaho is offline  
post #3 of 4 (permalink) Old 10-09-2009, 08:35 PM
Full Member
 
/Womby\'s Avatar
 
Join Date: Sep 2009
Location: Pittsburgh[saab mech]
Posts: 86
Drives: 91eagletsi-06optima
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

That's just your turbo whinning....
/Womby\ is offline  
post #4 of 4 (permalink) Old 11-08-2009, 06:34 PM
Newbie
 
Join Date: Jan 2008
Posts: 11
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

Quote:
Originally Posted by Janks01 View Post
the problems continue to rack up with this car. Since ive bought it ive had

a front drivers side door unable to open
rear power lock needed a new actuator
new timing belt
engine took much to long to catch on startup
taillight went out
alarm kept going off
one of the belts needed dressing


NOW i can hear this whining noise coming from the engine when accelerating.

It seems only to happen at around 3000 rpm when accelerating at a good pace from stop signs and such

What could this be and how can i fix it myself?
I took my kia 3x’s when it was under warranty and they lied to me over and over and stated they could not find the problem. Because it was warranty work and you could spend over $ 800 they just strung me along until the warranty expired, but I never and I mean never bring my vehicle to kia not unless its under warranty. I still have the vehicle. See my post on 1/22/2008 Titled 01 Kia optima Lx 5 Speed High Pitch Sound. I would start with these two parts and this should solve your problem.

Have your mechanic, not kia, check the left timing belt Idler $30.95 dam part, you could see the blue burn marks around the idler itself and since he is in that area change the right time belt Idler $ 37.48. The down side to his all is that the timing belt, water pump, and other items are being taking apart and you may want to change those items. I can tell you when the work was completed my vehicle ran better that when I first had it. If you have any other questions send me a note.
Stratford CT Kia is offline  
Sponsored Links
Advertisement
 
Reply

  Kia Forum > KIA Models > Kia Magentis & Optima Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Kia Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On