2002 Kia Spectra COOLING FAN Not Working! - Kia Forum
User Tag List

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 01-22-2011, 02:52 PM
Newbie
 
Join Date: Jan 2011
Posts: 4
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Unhappy 2002 Kia Spectra COOLING FAN Not Working!

I Cant Get My Cooling Fans To Work, They Are Supposed To Kick In After The Vehicle Has Been Running For A While And Gets Hot Enough But They Dont,
I Have Checked: The Relays, Fuses, Wiring, Tested Both Fan Motors And They Work, Replaced The (ECT) Sensor, Engine Coolant Temperature Sensor, The Coolant Thermostat, I Have Checked The Coolant Level, And Visually Inspected The Wires. I REALLY Dont Know What Else It Could Be


UPDATE!: Problem Solved

I Took My Car To The Shop And There Turned Out To Be A Short Inside The First Fan Motor. Even Though I Was Able To Wire The Fans To The Battery And Test Them And They Worked, It Wasnt Good For It And They Wouldnt Off Even Lasted An Hour More Running Because They Were Going Out. There Was Not Enough Voltage For The Fans To Turn On!

I Hope This Helps Anybody Else!

Last edited by RobGarrett88; 02-04-2011 at 03:34 PM.
RobGarrett88 is offline  
Reply

  Kia Forum > KIA Models > Kia Cerato, Shuma & Spectra Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On