2005 Steering hard sometimes-- - Kia Forum
User Tag List

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 12-11-2011, 06:21 PM
Member
 
Join Date: Apr 2008
Posts: 28
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

(Thread Starter)
Default 2005 Steering hard sometimes--

My 2005 turns really hard at low speeds, sometimes.

Started after hearing a belt squeal in the morning. It was bad, almost impossible for my wife to turn to park.

Trying to test if the belt was loose I sprayed it with some belt conditioning spray. Did not seem to help.

I also lubed, with some spray lube, the steering intermediate shaft.

Nothing helped.

Today it was a little better, but still had trouble in a parking lot one time. I parked it several times today.

Later I put a couple turns on the tensioner for the power steering pump. Drove it for a little while and it would catch at the start of a turn. Then it would turn normal.

Loose belt? Intermediate steering shaft? Steering pump? Always steers easier if I give it a little gas.

I am not sure what to try so I can narrow down what the problem might be.

STeve

Last edited by Electech1; 12-12-2011 at 07:35 AM. Reason: Left something out
Electech1 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 12-12-2011, 11:21 AM
Veteran
 
Pacosworld's Avatar
 
Join Date: Feb 2009
Location: Urbana, IL
Posts: 1,030
Drives: 1990 VW Corrado SC 1.8L, 2005 Kia Spectra EX
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)

Default

Quote:
Originally Posted by Electech1 View Post
My 2005 turns really hard at low speeds, sometimes.

Started after hearing a belt squeal in the morning. It was bad, almost impossible for my wife to turn to park.

Trying to test if the belt was loose I sprayed it with some belt conditioning spray. Did not seem to help.

I also lubed, with some spray lube, the steering intermediate shaft.

Nothing helped.

Today it was a little better, but still had trouble in a parking lot one time. I parked it several times today.

Later I put a couple turns on the tensioner for the power steering pump. Drove it for a little while and it would catch at the start of a turn. Then it would turn normal.

Loose belt? Intermediate steering shaft? Steering pump? Always steers easier if I give it a little gas.

I am not sure what to try so I can narrow down what the problem might be.

STeve
The intermediate steering shafts have a history of the u-joints loosing lubrication and causing the problem you're describing. You might start with replacing that and go from there.

http://images.animelab.com/gallery/Akira/Images/akira022.jpg
Mike AKA Paco
For US Kia service info Kiatechinfo
Pacosworld is offline  
#3 (permalink) Old 12-12-2011, 01:51 PM
Member
 
Join Date: Aug 2011
Location: county of kent uk
Posts: 32
Drives: kia sedona 2.9 tdi 2002
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

hi
i may be stating the obvious but have you checked the fluid level?
regards kia mad uk
KIA mad is offline  
#4 (permalink) Old 12-19-2011, 02:11 PM
Member
 
Join Date: Apr 2008
Posts: 28
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

(Thread Starter)
Default

The fluid level is fine.

I bought some spray lube and sprayed the steering shaft. For another day I had problems. But now it is gone. It has been a week.

I will order a replacement shaft.
Electech1 is offline  
Reply

  Kia Forum > KIA Models > Kia Carnival & Sedona Forum > Kia Carnival & Sedona


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On